Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-21-07, 02:58 PM   #25
mdt3k
Registered User
 
Join Date: Jul 2007
Posts: 2
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

I also have this problem, I've posted my edid and xorg logs to the 100.14.11 thread here: http://www.nvnews.net/vbulletin/showthread.php?t=93623
mdt3k is offline   Reply With Quote
Old 08-05-07, 08:33 AM   #26
EvilGuru
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

I would also like to join the club, with a 7600GT and two ViewSonic VX2025WM monitors. However what makes this all the more interesting that the EDID acquisition only fails for DFP-1 and not DFP-0 (which it picks up fine). Anyway the old drivers work fine and it is just the new ones which are giving me trouble.

Does anyone know when this is going to get fixed. Since it worked in a previous version I would assume that it can't take all that long. If you want logs or anything of the soft do ask.

Regards, Freddie.
EvilGuru is offline   Reply With Quote
Old 09-22-07, 11:18 AM   #27
EvilGuru
Registered User
 
Join Date: May 2007
Posts: 28
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

Does anyone know if this bug is fixed in the 100.14.19 drivers? Or is there is a suitable workaround for it?

Regards, Freddie.
EvilGuru is offline   Reply With Quote
Old 11-01-07, 02:53 AM   #28
avatraxiom
Registered User
 
Join Date: Feb 2004
Location: San Jose, CA
Posts: 2
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

Quote:
Originally Posted by EvilGuru
Does anyone know if this bug is fixed in the 100.14.19 drivers? Or is there is a suitable workaround for it?.
I seem to be having the same problem with the 100.14.19 drivers, and I haven't yet discovered a workaround.

-Max
avatraxiom is offline   Reply With Quote
Old 11-01-07, 09:35 AM   #29
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

Please generate and attach an nvidia-bug-report.log.
netllama is offline   Reply With Quote
Old 11-01-07, 05:11 PM   #30
avatraxiom
Registered User
 
Join Date: Feb 2004
Location: San Jose, CA
Posts: 2
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

Quote:
Originally Posted by netllama
Please generate and attach an nvidia-bug-report.log.
Okay, here it is.

I tried reverting to 96.43.01 and that worked fine. I generated an edid.bin from that, but the 100.14.19 driver refused to read it with CustomEDID, saying:

Code:
(WW) NVIDIA(GPU-0): The EDID read for display device DFP-0 is invalid: EDID
(WW) NVIDIA(GPU-0):     version 1 size exceeds EDID buffer size, or checksum for
(WW) NVIDIA(GPU-0):     EDID failed
I think that I upgraded the driver, then shut down the computer and installed a new sound card in a PCI slot. (The card is the ice1712, Envy24 chipset--it's an M-Audio card.) So either may have been responsible for this. However, the old nVidia drivers work, so it seems like a driver problem.
Attached Files
File Type: log nvidia-bug-report.log (94.9 KB, 108 views)
avatraxiom is offline   Reply With Quote
Old 11-07-07, 10:04 AM   #31
arnaudq
Registered User
 
Join Date: Nov 2007
Posts: 2
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

Quadro FX1500 with driver 100.14.19 on a Sun Ultra40 workstation (AMD64) running Ubuntu.
I have the same symptoms (resolution of 640x480 instead of the expected 1920x1200, EDID problem) against a Sun 24'' LCD panel.

I'm including the debug log but here is the EDID related error message:

(WW) NVIDIA(GPU-0): The EDID read for display device DFP-1 is invalid: EDID
(WW) NVIDIA(GPU-0): version 1 extension exceeds EDID buffer size, or checksum
(WW) NVIDIA(GPU-0): for EDID extension failed.
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): Raw EDID bytes:
(--) NVIDIA(GPU-0):
(--) NVIDIA(GPU-0): 00 ff ff ff ff ff ff 00 4e ae 86 05 30 30 30 30
(--) NVIDIA(GPU-0): 34 0d 01 03 80 33 20 96 2a 1a 08 a2 5a 4b 98 24
(--) NVIDIA(GPU-0): 15 51 59 bf ef 80 d1 00 d1 c0 81 80 81 90 a9 40
(--) NVIDIA(GPU-0): 71 86 01 01 01 01 10 3b 80 88 70 b0 22 40 08 40
(--) NVIDIA(GPU-0): 24 00 06 44 21 00 00 1e ca 35 80 88 70 38 20 40
(--) NVIDIA(GPU-0): 08 40 24 00 06 44 21 00 00 1e 30 2a 00 98 51 00
(--) NVIDIA(GPU-0): 2a 40 30 70 13 00 06 44 21 00 00 18 ae 33 40 b0
(--) NVIDIA(GPU-0): 60 b0 27 40 08 40 5a 00 06 44 21 00 00 1e 01 58
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
(--) NVIDIA(GPU-0): ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
Attached Files
File Type: gz nvidia-bug-report.log.gz (29.6 KB, 92 views)
arnaudq is offline   Reply With Quote
Old 11-07-07, 10:06 AM   #32
netllama
NVIDIA Corporation
 
Join Date: Dec 2004
Posts: 8,763
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

arnaudq,
This looks like a problem with the EDID in the display. You should report this to SUN.
netllama is offline   Reply With Quote

Old 11-08-07, 01:11 PM   #33
arnaudq
Registered User
 
Join Date: Nov 2007
Posts: 2
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

The model date back from 2003 and I'm not sure there is a simple way to "patch" the display. Or is there any ?

Anyway, using http://cgit.freedesktop.org/xorg/app/edid-decode/ i was able to fix the EDID and declare it in the Driver options of xorg.conf.
Just in case somebody faces the same issue (Sun 24'' LCD from 2003), I'm including the fixed EDID.
Attached Files
File Type: gz sun24edid.bin.gz (137 Bytes, 125 views)
arnaudq is offline   Reply With Quote
Old 12-26-07, 03:05 AM   #34
Racingeg
Registered User
 
Join Date: Dec 2007
Posts: 22
Default Re: 100.14.09 - NVIDIA(GPU-0): Unable to read EDID for display device DFP-0

rg2003
...

your EDID's 8bit checksum is E0h, and it must 00h.

I change 128th-byte 9Fh -> BFh.

Now, perhaps you can use customedid option

with this file.

(maybe "nv" driver ignore EDID data's checksum, so you couldn't use same EDID on "nvidia" driver)
Attached Files
File Type: zip edid-rg2003-fix.zip (248 Bytes, 163 views)
Racingeg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:13 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.