Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-04-08, 03:17 AM   #1
SaiotX
Registered User
 
Join Date: Jan 2008
Posts: 4
Default Asus G2S: startx reboot systems or X hangs

I see some other people is having a similar problems, but till now I didn't find any working solution.

System is Asus notebook (G2S) with a GeForce 8600M GT

Distribution is Gentoo (stable)
Nvidia-drivers tested:
100.14.19
100.14.11
100.14.09
169.04

Problem: after 'startx' command there are two possibilities:

1) the system reboots !!!! (never seen anything like this in Linux environments!)

2) X hangs and there is no possibility to come back to a console.
When I startx from ssh I can see this error in the console:
(EE) NVIDIA(0): Unable to initialize Xv sync to vblank
--> no informations found about this error

Some notes:

- The PC is new and the BIOS is up to dated
- There are no hardware problem because this is a dual boot system and in Windows Vista the board works fine.
- I tried with both framebuffer enabled and disabled in the kernel. without the frame buffer the system doesn't reboot anymore, but I have the above error.
- At home I have other two PC with nvidia boards on Gentoo and Sabayon (Gentoo based) and I didn't have any problem even with frame buffer enabled in the kernel (and bootsplash). The other PC specs are:
- Intel E6600 + PCI Express GeForce 8500GT
- P4 + AGP GeForce 6800XT

So, you see I already experienced nvidia board installations on Linux machines...

Attached you can find two logs, one generated with knoppix xorg.conf and one with a nvidia-xconfig one. Both have the same result.
Attached Files
File Type: log nvidia-bug-report.log.nvidia-xconfig_xorg.log (77.4 KB, 112 views)
File Type: log nvidia-bug-report.log.KNOPPIX_xorg.log (99.2 KB, 116 views)
SaiotX is offline   Reply With Quote
Old 01-04-08, 03:31 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Asus G2S: startx reboot systems or X hangs

01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0407 (rev a1) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Unknown device 1515
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
Memory at 100000000 (64-bit, prefetchable) [size=256M] <--
Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
I/O ports at 9c00 [size=128]
One of the GPU's BARs was mapped above 4GB, which is not a supported configuration. There have been several reports of similar problems with Asus G2S notebooks caused by SBIOS bugs, see e.g. http://www.nvnews.net/vbulletin/showthread.php?t=101706.
zander is offline   Reply With Quote
Old 01-04-08, 04:24 AM   #3
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Asus G2S: startx reboot systems or X hangs

This patch/hack isn't necessary anymore, since ASUS has released a BIOS update!
chunkey is offline   Reply With Quote
Old 01-04-08, 04:43 AM   #4
SaiotX
Registered User
 
Join Date: Jan 2008
Posts: 4
Default Re: Asus G2S: startx reboot systems or X hangs

Well, following the first suggestion, I hacked the i386.c file exactly as suggested expecting some problems (because I do not have 4GB Ram, but 3)... instead after recompiling the kernel and rebooting X starts.
There are other errors (for example, X Error: BadWindow (invalid Window parameter) 3) but kde is running and direct rendering already enabled.

@ chunkey:

I can tell you I updated the BIOS or at least I suppose I did
When I connected the PC to the net for the first time the Asus LiveUpdate tool realized there was a BIOS update. I downloaded it and at the beginning of the next reboot the bios was flashed....
This update was done yesterday. So, I guess it is the latest.

Is there anything I can check to verify I have a correct BIOS version, in order maybe to come back to the original kernel files?

EDIT: the BIOS version is 209
SaiotX is offline   Reply With Quote
Old 01-04-08, 11:17 AM   #5
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Asus G2S: startx reboot systems or X hangs

Quote:
Originally Posted by SaiotX
Well, following the first suggestion, I hacked the i386.c file exactly as suggested expecting some problems (because I do not have 4GB Ram, but 3)... instead after recompiling the kernel and rebooting X starts.
There are other errors (for example, X Error: BadWindow (invalid Window parameter) 3) but kde is running and direct rendering already enabled.

@ chunkey:

I can tell you I updated the BIOS or at least I suppose I did
When I connected the PC to the net for the first time the Asus LiveUpdate tool realized there was a BIOS update. I downloaded it and at the beginning of the next reboot the bios was flashed....
This update was done yesterday. So, I guess it is the latest.

Is there anything I can check to verify I have a correct BIOS version, in order maybe to come back to the original kernel files?

EDIT: the BIOS version is 209
well, I maybe the fix is in the latest 212...

BTW:
http://lkml.org/lkml/2007/12/17/429
chunkey is offline   Reply With Quote
Old 01-06-08, 01:41 PM   #6
SaiotX
Registered User
 
Join Date: Jan 2008
Posts: 4
Default Re: Asus G2S: startx reboot systems or X hangs

So it seems I have to wait Asus LiveUpdate will 'deliver' us this 212 release.
In the meanwhile, I suppose I can give with the kernel hack.
SaiotX is offline   Reply With Quote
Old 01-07-08, 05:29 AM   #7
chunkey
#!/?*
 
Join Date: Oct 2004
Posts: 662
Default Re: Asus G2S: startx reboot systems or X hangs

?! you can get the G2SAS212.bin directly from ASUS' Support Center and flash it with the given winflash on Vista IA32 (Not on x64!)...

Anyway, the hack has nothing to do with any " X Error: BadWindow (invalid Window parameter)" errors, maybe it compiz?
chunkey is offline   Reply With Quote
Old 01-07-08, 09:43 AM   #8
SaiotX
Registered User
 
Join Date: Jan 2008
Posts: 4
Default Re: Asus G2S: startx reboot systems or X hangs

well, I didn't download the BIOS update from ASUS web site, because I am lazy, I guess
I will do this later.

The error I mentioned doesn't have anything to do with nvidia. It was just due to the fact I started x from ssh.

In any case, thank a lot for all your hints.
SaiotX is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:36 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.