Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-01-03, 11:58 AM   #1
misha
Registered User
 
Join Date: Jul 2003
Location: San Jose, CA
Posts: 2
Default X locks up on shut down

Hi,

I have a problem with GeForce 4 MX integrated GPU, PCI id 0x01f0.


Model: GeForce4 MX Integrated GPU
IRQ: 11
Video BIOS: 04.1f.00.07.10
Card Type: AGP


Problem:

I was able to install 4363 drivers, and system is working, but once in a while computer locks up during X shut down (it may happen when I try to
re-login, use ALT-CTRL-Backspace, etc). It always happens when X goes down. No other problem indicated.

This typically happens once per 10-20 starts. Computer shows graphical garbage, seems that video switches to 60 Hz. No ability to ping from
other computer. The only way out is to switch power off.

I was not able to install previous drivers so I don't know how they would behave.

I have tried another computer with GeForce 2 MX/MX 400 (not integrated) and there is no problem. However I noted that when X
goes down it switches graphic mode few times back and forth.


Here is problem system:

Software:
SuSe Linux 8.1 I was using rpm files for Suse to install driver and GLX, then "switch2nvidia_glx" script and sax2 to configure X.


Hardware:
HP pavilion 725 with ASUS A7N8X-LA motherboard nForce2-IGP chipset.
Processor AMD Athlon XP 2400+.
It seems that these motherboards were made specially for HP because ASUS does not have them on their web site. Closest match from ASUS is A7N8X-VX, but it apparently has different BIOS.

HP has update for the BIOS from their web site but it did not mention any problems with graphics. ASUS also has updates for BIOS but
revision numbers did not not match. It seems that ASUS bios has more setup options than BIOS from HP. I did not upgrate BIOS yet. I am not
sure that BIOS from ASUS would match this motherboard.

Thnaks,
Misha
Attached Files
File Type: log xfree86.0.log (25.9 KB, 164 views)
misha is offline   Reply With Quote
Old 07-02-03, 12:46 PM   #2
misha
Registered User
 
Join Date: Jul 2003
Location: San Jose, CA
Posts: 2
Wink

Hi,

I have changed kernel to 2.4.21 from www.kernel.org. It seems that lock
up problem is gone now. I had to re-compile
nvidia kernel module by hand and install latest
ALSA package to get sound work. It seems
everything is great now.

I was using as guide

http://attila.stevens-tech.edu/~dkopko/a7n8x.txt

But I have just downloaded latest 2.4.21 kernel and latest ALSA files. Everything is working now (including network and sound).

I noted that X shuts down now in one signle switch.

BTW my other computer (with GeForce2 MX/MX 400) seems had a lock up too. I am going to install
2.4.21 kernel there,

Thanks,
Misha
misha is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lawyer tries and fails to shut down The Oatmeal's charitable fundraiser News Archived News Items 1 06-15-12 05:37 PM
nvidia: If you have an insect phobia, your eyes are likely shut during this part of t News Archived News Items 0 05-16-12 10:00 PM
Feature: Government asks: when can we shut down wireless service? News Archived News Items 0 05-08-12 02:30 AM

All times are GMT -5. The time now is 04:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.