Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-04-03, 10:20 AM   #1
oguh
Registered User
 
Join Date: Jul 2003
Posts: 2
Default System hangs when starting X with Mandrake 9.1 Pack (here is a solution)

When starting X after installing a new system with the Mandrake 9.1 PowerPack (note that this is important, since the proprietary drivers for Nvidia based cards are only given by Mandrake with Packs) the whole system hangs and I need to hard boot !

If I install the new drivers from the site of Nvidia, and then I start X without booting, it works (X starts and I can play 3D games with acceleration).
But if I reboot the system and that I start X again, the system hangs !

You can try to do it again (install the new nvidia drivers, start X), it works... , if you don't reboot !


After a lot of debugging, I found out that at boot time, HardDrake is launched to detect new hardware; HardDrake detects the Nvidia graphics card and installs the Nvidia proprietary drivers from the Mandrake Pack distribution !!

So, the solution is to remove the drivers that the Mandrake 9.1 Pack installs at the install time, for example with the command (as root) "urpme NVIDIA***" (NVIDIA*** is the name of the rpm package, urpme will give it to you).
After making that, you need to install the new Nvidia proprietary drivers from the Nvidia site and it will work !!!

Well... it will quite work In fact, there is another bug : when you launch a 3D game as a user (not root), the game won't work, and you will given an error by the Nvidia driver. You simply follow the instructions given bye the Nvidia Readme and then it will work (Actually, the rights of the device are 600 and they should be 666).

I have seen a lot of guys who have the same problem around the forums in the Internet, I hope this will help some !!

Linux rules

PS : My hardware :
ASUS A7V7-X (KT400)
Leadtek Nvidia GEFORCE 4 MX 64Mo DDR
512 Mo RAM DDR PC2700
AMD Athlon XP2000+
oguh is offline   Reply With Quote
Old 07-04-03, 10:41 AM   #2
Rapsys|Phoenix
Registered User
 
Rapsys|Phoenix's Avatar
 
Join Date: May 2003
Location: France, Villeurbanne
Posts: 61
Default

how set the priority in 666
please put all the command you use here for the newbie!
__________________
**** off M$ and his ****ing software
Rapsys|Phoenix is offline   Reply With Quote
Old 07-04-03, 10:52 AM   #3
oguh
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

As I wrote, it's written in the Readme :
Quote:
Q: OpenGL applications exit with the following error message:

Error: Could not open /dev/nvidiactl because the permissions
are too restrictive. Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.

A: It is likely that a security module for the PAM system may be
changing the permissions on the NVIDIA device files. In most cases
this security system works, but it can get confused. To correct this
problem it is recommended that you disable this security feature.
Different Linux distributions have different files to control this;
please consult with your distributor for the correct method of
disabling this security feature. As an example, if your system has
the file
/etc/security/console.perms
then you should edit the file and remove the line that starts with
"<dri>" (we have also received reports that additional references to
<dri> in console.perms must be removed, but this has not been verified
by NVIDIA). If instead your system has the file
/etc/logindevperms
then you should edit the file and remove the line that lists
/dev/nvidiactl. The above steps will prevent the PAM security system
from modifying the permissions on the NVIDIA device files. Next,
you will need to reset the permissions on the device files back
to their original permissions and owner. You can do that with the
following commands:
chmod 0666 /dev/nvidia* chown root /dev/nvidia*
Actually, you don't need to remove the line with dri, you simply change the permissions in the /etc/security/console.perms of the /dev/nvidia from 0600 to 0666

and then update the perms as written in the Readme with
chmod 0666 /dev/nvidia*
chown root /dev/nvidia*

J'espère que ça aide
oguh is offline   Reply With Quote
Old 07-04-03, 11:06 AM   #4
Rapsys|Phoenix
Registered User
 
Rapsys|Phoenix's Avatar
 
Join Date: May 2003
Location: France, Villeurbanne
Posts: 61
Default

cool un frenchie comme quoi c que les frenchie qui se cassent la tête sur le drivers a débugguer!
__________________
**** off M$ and his ****ing software
Rapsys|Phoenix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
SMP system hangs with OpenGL chazmati NVIDIA Linux 9 08-26-02 10:28 AM

All times are GMT -5. The time now is 12:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.