Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-04-03, 04:02 PM   #1
DeusManus
Registered User
 
Join Date: Jul 2003
Posts: 4
Default Linux RH9 n00b needs help

hello =P

im running linux red hat 9, and im trying to install the Nvidia drivers.

now in the readme it tells me to cd into the nvidia_kernel directory. i do that and then type make install

according to the readme, that should word, but i keep getting this:

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1

i tried setting ignore_cc_mismatch, but no avail.

any help here would be hot .
DeusManus is offline   Reply With Quote
Old 07-04-03, 04:23 PM   #2
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

There shouldn't be any need to recompile the kernel. Use the new installer which will build a modual that load after the XF86Config file is modified to use it. To make the interface modual, the installer will need access to the source code of the Kernel, so make sure that is installed first...ignore the part about getting one online and have the installer script build the interface modual.

That should work fine without having to build the driver into the Kernel, and also will retain the old driver for you to go back to if you decide to later.
Bobmeister is offline   Reply With Quote
Old 07-04-03, 04:27 PM   #3
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

I'm sorry, I didn't read your post closely enough the first time and see that you aren't trying to recompile the kernel itself. However, the intstaller should do all of the work for you. The Module build should be built with the same compiler....not sure if you have updated that since the Kernel was built. If you do a uname -a command, it should tell you what compiler built the kernel, if I recall correctly.
Bobmeister is offline   Reply With Quote
Old 07-04-03, 04:58 PM   #4
DeusManus
Registered User
 
Join Date: Jul 2003
Posts: 4
Default

um...when i said n00b, i wasnt kidding. i know next to nothing about linux, but i am trying to learn.

as far as updating the kernal, im running the latest kernel that i know of (i let linux update itself just this morning, i hope thats what your talking about).

i did a uname -a and got this:


Linux bgp01389187bgs.sequoa01.nm.comcast.net 2.4.20-18.9 #1 Thu May 29 06:54:41
EDT 2003 i686 athlon i386 GNU/Linux


no clue what any of it means. i would just like to be able to install these drives, 800X640 res is not fun
DeusManus is offline   Reply With Quote
Old 07-04-03, 05:22 PM   #5
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

OK! I'm sorry for being so unclear! Also, I am on vacation and don't have any of my Linux stuff with me, so hopefully someone will step in and clarify what I have to say. I'm running Red Hat 9 also and got the Driver to work fine.

One thing is that you HAVE to have the source code for the Kernel for this Module to build correctly. If you go to your rpm log, you should see if this is installed or not. If it is NOT, go to your Red Hat updater and GET the code installed. That will give you the tools that are needed.

Another thing is that you SHOULD NOT HAVE THE X-SERVER (your windows system) running during the install. You should go to Run Level 3 and do this from the TEXT mode. This is easily done by doing a temperary edit of your GRUB at boot time. The DANGER of this is that if something goes wrong, you will end up trying to go to run level 5 again at next boot. No big deal...if something goes wrong, you can always go back to run Level three to get the system up without X trying to start up again.

Your original post said that it was having trouble because of a wrong compiler. But if you are new, and haven't changed anything, your compiler should be the correct one. I'm sorry, but I was wrong, the uname command doesn't tell you what the compiler was durning the kernel build. I'm not sure about this problem except that someone might be able to jump in here and help with that.

The nVidia installer works fine. Follow the instructions, however, I would START OVER. If you have any components installed, I would UNINSTALL it and try again. The installer has an uninstall component that you can invoke...read the command in the Read Me file.

Then find any left over files and maybe delete them...this isn't ALL that important in that the next install should overwrite the files anyway...so take that one or leave it.

Try a new install from RUN LEVEL THREE (you will be in command line mode only, so make sure that you are comfortable doing this...if not, practice first).

After the install, the module will NOT load until you edit the XF86Config file...the Read Me file is not too clear on all of this but DOES have an example. You will have to change the "nv" to "nvidia" in the Device section and it's a good idea to remove the Load "Dri" in the section toward the top. Also, you might want to add an option to "IgnoreDisplayDevices" "insert your options here" as indicated in the read-me file...this has helped a lot of people with a problem of a slow X-Server startup.

I am being incomplete here...so hopefully others will help soon as I don't have my resources with me right now (in D.C. with the family!) And I'm a newbie too...just a couple of months now (see how far we come?)...

It is now working great for me and I'm confident that you will get things going as well.

Good Luck
Bobmeister is offline   Reply With Quote
Old 07-04-03, 06:22 PM   #6
DeusManus
Registered User
 
Join Date: Jul 2003
Posts: 4
Default

ok, i got to where i edit the grub, but not sure what commands im supposed to use
DeusManus is offline   Reply With Quote
Old 07-05-03, 12:41 AM   #7
Bobmeister
Registered User
 
Join Date: Jun 2003
Location: Mt. Prospect, IL
Posts: 13
Default

OK...when in the edit mode, you will probably see three lines...run down to the second one where it lists the kernel and hit "e" for edit again. Add a "3" at the end of the line with a space between the end of the line and the "3" and you will be booted into Run Level 3. Then boot by using the boot command which I believe is "b"

The next time you boot up, you will default back to the normal run level of 5.

I'll be on the road tomorrow driving home all day and also Sunday...I sure hope that someone helps you out.

I would also recommend you try to get help at http://www.linuxquestions.org
where there is a lot of activity and a lot of help. I have found solutions to MANY problems and questions at that forum. Check it out...and I'm sorry that I have to leave you hanging like this.
Bobmeister is offline   Reply With Quote
Old 07-05-03, 10:17 AM   #8
hughesjr
Registered User
 
Join Date: Jul 2003
Posts: 2
Default

I always boot my machines to runlevel 3 and after logging in as the user I want to be just type:

startx

to start the GUI mode...

If you want to always boot up in runlevel 3 (or if you want to switch to runlevel 3 now and back to 5 later ... ) then go to the /etc directory and edit the file:

inittab

inside the file you will find a line (near the top) that says:

id:5:initdefault:

Change the 5 to a 3 and save it ... from now on, you boot to run level 3.

--------------------------------------------------
Also to compile the kernel module for video, you need to have the kernel-source file.....

If you are using the latest kernel and you are using up2date to do system updates (loks like you are) ... then from a terminal ... (command line) type the following command:

up2date kernel-source

You will download and install the latest kernel-source (currently 2.4.20-18.9 ... which matches your current kernel from uname -a). After the kernel-source is laoded, you should be able to download the latest driver file (currently for GeForce and TNT):

http://download.nvidia.com/XFree86/L...6-1.0-4363.run

then go to runlevel 3 and change to directory you downloaded the file and follow the directions here:

ftp://download.nvidia.com/XFree86/Li...363/README.txt

One thing you may have to do is make the file executable ... to check the permissions, type the command:

ls -al NV*

you should get a display like this:
-rwxr-xr-x 1 root root 6574583 Jun 10 02:14 NVIDIA-Linux-x86-1.0-4363.run

The -rwxr-xr-x show the file permissions. The first position [-] can be either d for directory, - for file, l for a link ... also a couple other things. Positins 2-4 [rwx] means that the owner of the file (in this case root) has permissions to read, write, and execute the file. The next 3 positions [r-x] shows the group the file belongs to (in this case also root) has read and execute permissions only and the last 3 positions [r-x] show that eveyone else also has read and execute permissions.

If there is no x for the root user, then you need to make the file executable so it can be run ...this command will do the trick:

chmod 755 NVIDIA-Linux-x86-1.0-4363.run

Then just type the command:

sh NVIDIA-Linux-x86-1.0-4363.run

And you should be in business...and remember - This has to be done from outside of X in character mode .... not just in a terminal window.
hughesjr is offline   Reply With Quote

Old 07-05-03, 07:53 PM   #9
DeusManus
Registered User
 
Join Date: Jul 2003
Posts: 4
Default

Thanks a bunch for you help guys. ill get working on this when i get home =)
DeusManus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux GTX 675M support geophph NVIDIA Linux 37 06-13-12 08:40 PM
295.59 (long-lived branch release) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 06-13-12 03:38 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 01:52 PM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 11:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 04:47 PM

All times are GMT -5. The time now is 01:49 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.