Go Back   nV News Forums > Graphics Card Forums > NVIDIA Legacy Graphics Cards

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-09-08, 06:23 PM   #1
Horio77
Registered User
 
Join Date: Jan 2008
Location: NH USA
Posts: 1
Default GeForce 6600 GT and Direct3D Problem

Hello,

Interesting problem here: I recently got Civilization IV and have been playing it for about 2 weeks with no problems. Out of the blue (no changes to the system except a minor Windows automatic update) all of the video displayed in game are skewed and twisted making everything unreadable. Every 2D feature (desktop, web browsing, etc.) all work fine. Going by memory I could get all the way into the game, so the game is running fine, but it is completely unplayable with the graphics all distorted. The GPU core idle temperature is 48C (ambient temp currently 40C) not sure what it runs at during load.

Here is my current set up:
P4 3.00 GHz
2GB DDR2 RAM
LeadTek GeForce 6600GT

Here is what I've tried already:
Uninstalled and reinstalled Civ IV (did not fix the problem)
Updated NVIDIA drivers from nvidia.com (did not fix the problem)
Uninstalled and reinstalled device drivers to defaults (did not fix the problem)
Ran DxDiag and Direct3D does not test properly (DirectX test were fine)
Ran logging in Civ IV and got the InitWinApp() failure message

Since it looks like Direct3D is the problem, any suggestions on what would cause this so I can avoid it in the future? Additionally, is there any way to fix it? I'd prefer not to have to buy a new video card. I've also uninstalled and reinstalled DirectX 9.0c (which from what I understand has Direct3D with it) with no change.

Any suggestions would be great. Thanks!


Horio

**** UPDATE ****

I also tried flashing in a fresh copy of the original card BIOS and an updated one, neither worked. I think I need to accept the fact that my card got messed up somehow and I should buy a new one.

Last edited by Horio77; 01-13-08 at 11:20 AM.
Horio77 is offline   Reply With Quote
Old 02-09-08, 04:08 PM   #2
pixelmechanic
Registered User
 
Join Date: Feb 2008
Posts: 1
Default Re: GeForce 6600 GT and Direct3D Problem

I have the same exact card, same problem. I think I'll have to just buy a new card as well.
pixelmechanic is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:07 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.