Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-03-08, 11:37 AM   #1
hoosfoos
Registered User
 
Join Date: Sep 2005
Posts: 3
Default twinview 2nd monitor not working

I have a GeForce 7800 GTX with two dvi outputs to two Acer AL2216W 21" LCDs.
I've been running Ubuntu for the past two years and although it's always been a pain to get both monitors working correctly and I've had to reconfigure several times because of some update or other, I've always (with help and on my own) been able to get things working.

This time something is different, because of my success at home I upgraded my system at work to the development branch of Ubuntu, 8.02 (on hindsight this may have been a mistake )

Anyways this broke my working xorg.conf and after wasting much time I backed up my /home and did a clean install of the stable version of Ubuntu (7.10) The best I could get from this setup was one monitor at the normal 1680x1050 and the second at 800x600. I figured I had nothing to lose and went and dist-upgraded to 8.02 again. With some help I got my xorg.conf cleaned up and went from one monitor at 1680x1050 and the second at 800x600 to just one monitor at 1680x1050.

This is where I'm at right now one monitor at 1680x1050 and the second blank and not even recognized in nvidia-settings.

Here's my config and bug report:
xorg.conf.bz2

nvidia-bug-report.log.bz2
hoosfoos is offline   Reply With Quote
Old 03-03-08, 11:50 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: twinview 2nd monitor not working

The driver isn't getting an EDID for your second monitor. Can you please try commenting out the ConnectedMonitor option, restarting the X server, and then generating a new bug report?

If for some reason your second monitor just doesn't return an EDID, you can probably work around that (assuming your monitors really are identical) by capturing the EDID for the first monitor with nvidia-settings and then using the CustomEdid option to feed it back to the driver for the second monitor.
AaronP is offline   Reply With Quote
Old 03-03-08, 12:09 PM   #3
hoosfoos
Registered User
 
Join Date: Sep 2005
Posts: 3
Default Re: twinview 2nd monitor not working

Here's the bug report with ConnectedMonitor commented out.

nvidia-bug-report.log.bz2
hoosfoos is offline   Reply With Quote
Old 03-03-08, 12:22 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: twinview 2nd monitor not working

Yep, sure enough,
Code:
(WW) NVIDIA(GPU-0): Unable to read EDID for display device DFP-1
You might want to try a different cable, or you could use the CustomEdid option that I suggested. It is showing it as connected, so you shouldn't need ConnectedMonitor.

Also, your hard drive looks like it's dying...
Code:
[15301.817875] hda: drive not ready for command
[15301.817925] hda: status error: status=0x59 { DriveReady SeekComplete DataRequest Error }
[15301.817933] hda: status error: error=0x00 { }
[15301.817936] ide: failed opcode was: unknown
AaronP is offline   Reply With Quote
Old 03-03-08, 12:33 PM   #5
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: twinview 2nd monitor not working

Quote:
Originally Posted by AaronP
Also, your hard drive looks like it's dying...
Code:
[15301.817875] hda: drive not ready for command
[15301.817925] hda: status error: status=0x59 { DriveReady SeekComplete DataRequest Error }
[15301.817933] hda: status error: error=0x00 { }
[15301.817936] ide: failed opcode was: unknown
Bah, just bad cabeling :-)

SCNR

Bernhard
JaXXoN is offline   Reply With Quote
Old 03-03-08, 01:55 PM   #6
hoosfoos
Registered User
 
Join Date: Sep 2005
Posts: 3
Default Re: twinview 2nd monitor not working

It works!
I checked the cable by swapping it out with a spare and had the same problem, so I don't think it's the cable.
Adding
Code:
Option 		"CustomEDID" "DFP-1:/etc/X11/edid.bin"
to my xorg.conf under the device section, did the trick.

The edid.bin file was created by choosing the Acquire EDID button under the working monitor (DFP-0 in my case) in the GPU section of the nvidia-settings control panel.
Then I copied it to the /etc/X11 directory and editied my xorg.conf to add the CustomEDID option.
Thank you for the quick response AaronP.
hoosfoos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Twinview? ghorsepower NVIDIA Linux 2 10-11-02 01:46 PM
XF86Config for a Quadro4 without TwinView? Twirlip NVIDIA Linux 1 10-09-02 11:36 AM
TV-out not working nomatter what driver.. Dr_Gigolo NVIDIA Windows Graphics Drivers 11 09-11-02 12:11 PM
Suse Linux 8.0 - Geforce 4 TwinView TA00 NVIDIA Linux 8 08-30-02 04:24 AM
How do I configure TwinView on Dell Inspiron rutgerclaes NVIDIA Linux 6 08-01-02 04:20 AM

All times are GMT -5. The time now is 07:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.