Go Back   nV News Forums > Hardware Forums > General Hardware

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-07-08, 01:38 AM   #1
Heinzftw
Im 57 Flavors!!!
 
Heinzftw's Avatar
 
Join Date: Jan 2008
Location: San Jose Cali
Posts: 191
Default Creative Sound Blaster X-fi Extreme

So on my new rig I have a #$%^ing amazing sound blaster card which I love and adore. But I try and hook up my headset to it and the mic just doesnt work!!! Everything on this works fine and all my drivers are upto date. Any suggestions?!?!?
__________________
The Main Rig:

Apexia Full Tower, Thermaltake 750 Watt Psu, Intel Q6600, Dual 8800GT's, Coolermaster Liquid Cpu Cooling, 3 Gb Corsair XMS2, Evga 780i Striker Motherboard, 2 X 160Gb Dual Hitachi Raid 0, Windows Xp Pro
3DMark06: 13,601

Quote:
Originally Posted by methimpikehoses
We're gonna need a bigger fence.
Heinzftw is offline   Reply With Quote
Old 03-07-08, 02:14 AM   #2
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: Creative Sound Blaster X-fi Extreme

Headset and Mic are broken.
crainger is offline   Reply With Quote
Old 03-07-08, 07:14 AM   #3
Bman212121
Registered User
 
Join Date: Jan 2006
Posts: 6,726
Default Re: Creative Sound Blaster X-fi Extreme

Is it running Vista or XP? What are you trying to use the headset with?
Bman212121 is offline   Reply With Quote
Old 03-07-08, 07:41 AM   #4
EciDemon
Registered User
 
EciDemon's Avatar
 
Join Date: Nov 2002
Location: Sweden
Posts: 1,423
Send a message via ICQ to EciDemon
Default Re: Creative Sound Blaster X-fi Extreme

I dont have the extreme version (the one with external module), got the one with front bay, On that one it's important to note that Mic2 is the one on the frontbay. Mic1 is the actuall card.

So check your source, you want to record from the right source.
EciDemon is offline   Reply With Quote
Old 03-07-08, 12:20 PM   #5
Heinzftw
Im 57 Flavors!!!
 
Heinzftw's Avatar
 
Join Date: Jan 2008
Location: San Jose Cali
Posts: 191
Default Re: Creative Sound Blaster X-fi Extreme

No mic is not broken due to the microphone ports on the top of my Apevia case do work. Windows Xp
__________________
The Main Rig:

Apexia Full Tower, Thermaltake 750 Watt Psu, Intel Q6600, Dual 8800GT's, Coolermaster Liquid Cpu Cooling, 3 Gb Corsair XMS2, Evga 780i Striker Motherboard, 2 X 160Gb Dual Hitachi Raid 0, Windows Xp Pro
3DMark06: 13,601

Quote:
Originally Posted by methimpikehoses
We're gonna need a bigger fence.
Heinzftw is offline   Reply With Quote
Old 03-07-08, 03:39 PM   #6
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: Creative Sound Blaster X-fi Extreme

Have you set the mic to be the input source in the audio panels?
crainger is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Support Finally For Creative Sound Core3D News Latest Tech And Game Headlines 0 05-24-12 02:50 AM
Creative drivers ? SparrowHawk General Hardware 39 11-18-02 08:03 AM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 01:50 AM
nForce - BattleField 1942 demo - Sound cuts out rtz General Hardware 3 09-05-02 12:48 PM

All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.