Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-17-04, 02:54 AM   #13
drees
Registered User
 
Join Date: Dec 2003
Posts: 13
Default Re: Failed to initialize the NVIDIA kernel module!

The X server needs the devices in order to communicate with the card. If they are not there, it can't initialize the card!
drees is offline   Reply With Quote
Old 12-17-04, 05:29 PM   #14
softice
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: Failed to initialize the NVIDIA kernel module!

I had this problem too, after install nvidia drivers 6629, everything is fine but ... i have the same error:

(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration

suse9.2 pro
kernel 2.6.8
Xorg 6.8.1

Can anyone help me, pls
softice is offline   Reply With Quote
Old 12-18-04, 09:16 AM   #15
HMSS013
Registered User
 
Join Date: Dec 2004
Posts: 1
Default Re: Failed to initialize the NVIDIA kernel module!

im having this exact same problem

using Fedora Core 3
Nvidia GeForce 4 MX440
Driver Package 6629
HMSS013 is offline   Reply With Quote
Old 01-06-05, 07:53 AM   #16
Herluf
Registered User
 
Join Date: Feb 2004
Posts: 1
Default Re: Failed to initialize the NVIDIA kernel module!

Thanks to Daniel for the suggestion. Creating the devices in rc.local fixed the problem for me.
Wonder why udev doesn't do it... oh well works now
Herluf is offline   Reply With Quote
Old 01-06-05, 08:47 AM   #17
Prommy
King of the hill
 
Join Date: Aug 2003
Location: Sweden
Posts: 60
Send a message via ICQ to Prommy
Default Re: Failed to initialize the NVIDIA kernel module!

Try copying the files from /dev to /etc/udev/devices (cp -a /dev/nvidia* /etc/udev/devices/). Did the trick for me, so I don't need those lines anymore...

/Daniel
Prommy is offline   Reply With Quote
Old 01-06-05, 10:39 AM   #18
drees
Registered User
 
Join Date: Dec 2003
Posts: 13
Default Re: Failed to initialize the NVIDIA kernel module!

Yep, putting the nvidia devices into /etc/udev/devices/ is the proper thing to do.

This should be addressed by the installer...
drees is offline   Reply With Quote
Old 01-07-05, 12:23 AM   #19
jmcqueen
Registered User
 
Join Date: Dec 2004
Posts: 16
Arrow Re: Failed to initialize the NVIDIA kernel module!

hi all:

the error is caused because the nvidia kernel is not updated (compiled for new driver). to do this, reboot your system to run level 3 so X is not started. login the terminal as su - and then:

/sbin/modprobe nvidia
cd /dev
cp -a nvidia* /etc/udev/devices
chown root.root /etc/udev/devices/nvidia*
logout
exit


reboot and you should be good to go. you need to have the driver installed FIRST before running what's above. after rebooting, X will load the generic 'Vesa' driver unless you have already updated /etc/X11/xorg.conf for your screen settings. if you haven't updated xorg.conf, you can look at samples of this file elsewhere in these forums.

hope this helps. nVidia is THE MOST LINUX FRIENDLY vid card manufacturer out there.

j
jmcqueen is offline   Reply With Quote
Old 01-10-05, 01:46 AM   #20
hanjin51
Registered User
 
Join Date: Jan 2005
Posts: 1
Default Re: Failed to initialize the NVIDIA kernel module!

I had the same problem.
i add the line

nvidia

in the file modprobe.preload in /etc

now, works fine.

I think which the problem is the module doesnt loaded at boot.

if someone get sucess, try a reply :-)

nvidia Gforce Fx 5200
Mandrake 10.1
Duron 1300
Soyo K7VTa-PRO

Last edited by hanjin51; 01-10-05 at 09:34 AM.
hanjin51 is offline   Reply With Quote

Old 01-10-05, 09:47 PM   #21
midna
Registered User
 
Join Date: Oct 2004
Posts: 5
Default Re: Failed to initialize the NVIDIA kernel module!

hahhaha yay!!! u guys made my day hallelujah... i've given up on nvidia drivers many times before now and for once it works!! followed both jmcqueen and hanjin51's directions just to be sure... and it works!
midna is offline   Reply With Quote
Old 04-06-08, 09:33 AM   #22
inzpektor
Registered User
 
Join Date: Apr 2008
Posts: 2
Default Re: Failed to initialize the NVIDIA kernel module!

Hi. Got the same problem. I don't have a /etc/modprobe.preload and I neither a /etc/udev/devices.

What should I then do to get it to work? I tried putting the "nvidia" line in the /etc/modules, and copying the /dev/nvidia* to /etc/devfs/devices.d/ (wild guess) to no avail.

Where do I go from here?

System: Ubuntu Gutsy 7.10

lspci stuff:
Code:
00:10.0 VGA compatible controller: nVidia Corporation Unknown device 07e3 (rev a2) (prog-if 00 [VGA])
        Subsystem: Biostar Microtech Int'l Corp Unknown device 1407
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at ed000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at ee000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at 40000000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
inzpektor is offline   Reply With Quote
Old 04-07-08, 06:51 AM   #23
inzpektor
Registered User
 
Join Date: Apr 2008
Posts: 2
Default Re: Failed to initialize the NVIDIA kernel module!

OBTW: When I change the xorg.conf to use driver "nvidia", the machine goes completely cold upon bootup. I can't switch TTY and nothing works except CTRL+ALT+DEL. Startup looks normal until gdm is to be started.
inzpektor is offline   Reply With Quote
Old 04-07-08, 07:36 AM   #24
energyman76b
Registered User
 
Join Date: Dec 2002
Location: Clausthal/Germany
Posts: 1,104
Default Re: Failed to initialize the NVIDIA kernel module!

nvidia-bug-report.sh
?

and maybe you are trying to install different driver versions at the same time?

cleaned bios from crap (deactivated spread spectrum)?
energyman76b is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
UEFI+Nvidia - NVRM: Your system is not currently configured to drive a VGA console... interzoneuk NVIDIA Linux 0 06-26-12 04:51 AM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
X Failed to load NVdriver c00lr4c3r NVIDIA Linux 13 10-22-02 01:44 PM

All times are GMT -5. The time now is 07:47 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.