Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-08-08, 03:09 AM   #1
cjk
Registered User
 
Join Date: Aug 2007
Posts: 5
Default Driver swaps odd and even pixels on Chi Mei V562D1-L01 screen

Our latest batch of Chi Mei V562D1-L01 56" 3840x2160 screens don't work at all with any nvidia card or driver that we have tried. In windows we get big blocks getting copied to other parts of the screen, but our main problem is in Linux.

Odd and even pixels get swapped and the whole screen looks like this:



We have seen this problem before, but 6 months ago, it was a 50-50 chance of it happening on the first half of the screen (of the two 1920x2160 playfields), then 100.14 was totally unusable and with 169.12 it happened only very rarely.

But now we got a new batch from Chi Mei, and someone must have changed something cause now it happens 99% of the time, and on both halves.

We have tried the following OSes:

Fedora 6, Fedora 8, Fedora 9 and Windows XP

Cards:

Sparkle 8600 GT, EVGA 8600 GT

Drivers:

169.12 and 173.08 beta, and the latest XP driver.

The thing is that you can see this swapping even in BIOS, albeit at a much lower resolution.

Any tips on this one? Will it ever be fixed?
cjk is offline   Reply With Quote
Old 05-08-08, 04:08 AM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default Re: Driver swaps odd and even pixels on Chi Mei V562D1-L01 screen

When you see this problem on different OSes, different cards and different drivers, and even in the BIOS, I wonder why you blame it on the driver and not on the display.
Does this display work correctly in any setup that you have tested?

I have read before (on this forum) about this kind of problem with dual-link DVI but I think it was in a single release of the driver and fixed. Maybe that was 100.14
pe1chl is offline   Reply With Quote
Old 05-08-08, 07:34 AM   #3
JaXXoN
Registered User
 
Join Date: Jul 2005
Location: Munich
Posts: 910
Default Re: Driver swaps odd and even pixels on Chi Mei V562D1-L01 screen

If the problem does even show up in the BIOS, then i assume that
there is some sort of incompatibility between the videocards and the
LCDs. I could imagine that such special devices (like your 56' LCDs) are not
fully in sync with the spec and the miss-behavior might be correctable with a
hand crafted modeline. To better identify the problem, can you please try out
if the problem persists in the BIOS when using an old PCI card (ATI, Matrox,
SiS, whatever). Also, what happens when plugging a KVM in between?
Replacing the DVI cable might also help.

regards

Bernhard
JaXXoN is offline   Reply With Quote
Old 05-08-08, 10:42 AM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Driver swaps odd and even pixels on Chi Mei V562D1-L01 screen

This problem was recently debugged and should be resolved in future NVIDIA Linux/UNIX graphics driver releases.
zander is offline   Reply With Quote
Old 05-08-08, 11:21 AM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Driver swaps odd and even pixels on Chi Mei V562D1-L01 screen

In addition to what Zander said, you can also work around this issue by opening nvidia-settings, unchecking the "force GPU scaling" option on both DFP devices, going to the display configuration page, and changing the refresh rate of both screens from 50Hz to 60Hz.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:34 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.