Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-27-03, 04:16 PM   #1
daborg69
Registered User
 
Join Date: Jul 2003
Posts: 5
Question Nvidia tv-out problem.

Hi,

I have searched throughout the land of google and the net and just can't seem to get a configuration that works for my NVIDIA based video card and tv-out capability. I now have a clean setup and this is the first thing I am trying to get working on the box.

I have successfully installed the Nvidia driver without a problem and I get the Nvidia logo when X tries to start. The GUI is much faster now. So I am trying to get TV-Out working.

I have enabled the twinview settings and tried numerous examples from posts throughout the web. However, none of them quite work.

Basically, I can get video to the tv OR to the monitor, but not at the same time (clone mode). Some configurations (such as the one below) get me a good picture to the tv, but the monitor is completely hosed (it is trying to sync and it cannot) - this locks my computer - or at least sets an undisplayable mode so that I have to power off and try again (ie. cannot switch to non X sessions or backspace out).

This just does not seem like it should be so difficult. I am hoping to determine in the next few days if it is a problem with this particular card or just a configuration problem. If a card problem then I can return and get a different brand. Any recommendations on brands that people have gotten this to work on?

I need tv-out as I am setting up a MythTv box on this computer.

Thanks in advance for any help or guidance.

My Hardware:
Motherboard: Asus A7n8X deluxe
Chip: AMD 2.5 Athalon
Ram: 512 MB
Video Card: Asus V9180 TD with 64 MB ram


Linux: Mandrake 9.1 Release


My XF86Config-4 file:

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5-60.0
VertRefresh 50-70
Usemodes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 78.80 1024 1040 1136 1312 768 769 772 800
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"

Option "TwinView" "true"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768, 800x600; 800x600, 800x600; 640x480, 640x480"
Option "TVStanderd" "NTSC-M"
Option "ConnectedMonitor" "CRT, TV"
Option "TwinViewOrientation" "Clone"
Option "TVOutFormat" "SVIDEO"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Option "Clone" "off"
Screen "screen1"
EndSection



Section "DRI"
Group "video"
Mode 0660
EndSection
daborg69 is offline   Reply With Quote
Old 07-27-03, 06:33 PM   #2
saturnotaku
Apple user. Deal with it.
 
Join Date: Jul 2001
Location: The 'burbs, IL USA
Posts: 12,502
Default

/me runs screaming

http://www.nvnews.net/vbulletin/show...threadid=10030
saturnotaku is offline   Reply With Quote
Old 07-28-03, 02:46 PM   #3
daborg69
Registered User
 
Join Date: Jul 2003
Posts: 5
Default

Ooops. Sorry. I had read that and just made a mistake.
daborg69 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem connecting Pioneer VSX-S300 to Nvidia Ion - flat panel scaling solves it? wild_oscar NVIDIA Linux 3 06-17-12 07:18 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 11:48 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.