Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-03, 03:27 PM   #1
vexer
Registered User
 
Join Date: Apr 2003
Posts: 15
Default AGP support disabled, need help.

I installed the nvidia 4496 driver and ever since I first installed the driver I've had ut and ut2k3 crash on me and crappy framerates.

After updating the driver to 4496, I read the readme, and saw that /proc/driver/nvidia/agp/status tells me the status of my AGP support. Here is the result.

root@TheKeep:/proc/driver/nvidia/agp# cat status
Status: Disabled

NvAGP is set to "1" in XF86Config, dmesg gives me this:
root@TheKeep:/proc/driver/nvidia/agp# dmesg |grep agp
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected Via Apollo Pro KT400 chipset
agpgart: unable to determine aperture size.

Modules.conf

# Nvidia options support
options agpgart agp_try_unsupported=1
options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1
alias char-major-195 nvidia

I'm desperate to get AGP support for this PC!

Please help me! I've had so many problems with the Geforce4 ti4200.


-vexer
vexer is offline   Reply With Quote
Old 07-29-03, 03:50 PM   #2
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

If you've set NvAgp to 1 and it's still loading AGPGART, that would indicate that you have AGPGART compiled into the kernel. Do you? If so, rebuild it as a module and try NVAGP again.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 07-29-03, 05:59 PM   #3
vexer
Registered User
 
Join Date: Apr 2003
Posts: 15
Default

I recompiled my kernel with agpart as a modules, the setup in the last post for XF86config is still the same, and status still displays Disabled.

-vexer
vexer is offline   Reply With Quote
Old 07-29-03, 06:05 PM   #4
alien999999999
Registered User
 
alien999999999's Avatar
 
Join Date: Apr 2003
Location: Belgium
Posts: 218
Send a message via ICQ to alien999999999
Default

and dmesg ?
__________________
Alien is my name and headbiting is my game.
alien999999999 is offline   Reply With Quote
Old 07-29-03, 06:21 PM   #5
vexer
Registered User
 
Join Date: Apr 2003
Posts: 15
Default

Dmesg |grep agp shows nothing since agpgart isn't compiled. I rebuilt my kernel twice, once with agpgart as a Modual and a second time with out agpgart at all.
vexer is offline   Reply With Quote
Old 07-29-03, 06:29 PM   #6
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

You can't use NVIDIA's AGP driver if AGPGART is loaded (or can it unload the module if found?) or compiled in the kernel.

I recently removed AGPGART support b/c I'm having odd problems after running quake3 a few times.

Assuming your X config was setup with NvAGP 1, and you had AGP support and proper drivers enabled in your kernel, you should have been running with NvAGP set to 2 or 3.

Option "NvAgp" "0" ... disables AGP support
Option "NvAgp" "1" ... use NVAGP, if possible
Option "NvAgp" "2" ... use AGPGART, if possible
Option "NvAGP" "3" ... try AGPGART; if that fails, try NVAGP

I disabled kernel AGP support completely, then setup X to use NvAGP 1, and that's worked for me.

I had major problems with this a while ago, so I was pretty surprised to see it work right away this time. :P

Anyway, you might want to disable the kernel's agp completely, then try again. And if you can't get NVIDIA's AGP driver to work (read list of supported devices in the readme?), set NvAGP to 2 or 3 in /etc/X11/XF86Config-4 with the kernel's AGP driver enabled.

---

Doh, guess I'm a slow typer. :P

Guess you can try re-enabling the kernel's AGP stuffs, then using NvAGP 2.
logan is offline   Reply With Quote
Old 07-29-03, 06:39 PM   #7
Andy Mecham
l33t master
 
Join Date: Jul 2002
Location: Santa Clara, CA
Posts: 1,163
Default

A quick note - it will only be enabled if you're in X.

--andy
__________________
Andy Mecham
NVIDIA Corporation
Andy Mecham is offline   Reply With Quote
Old 07-29-03, 06:41 PM   #8
vexer
Registered User
 
Join Date: Apr 2003
Posts: 15
Default

I've completely removed AGP support from the kernel and Have set nvAGP to 1 and 3 and still same result.

Edit:

I've been checking to see if it works while in X using a terminal. I've also exited X and did an rmmod nvidia, and then start X once again so that the X config would automaticly load the driver yet still the same thing..


I'm very discouraged right now..


this sucks

-vexer

Last edited by vexer; 07-29-03 at 06:45 PM.
vexer is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remastered Doom 3 BFG Edition Game Coming with Stereo 3D Support News Archived News Items 0 06-01-12 06:30 AM
R9500 specs sebazve Other Desktop Graphics Cards 15 10-17-02 05:20 AM
Official Detonator 40.xx Feedback Thread pelly NVIDIA Windows Graphics Drivers 299 09-22-02 07:54 AM
Gentoo and agp trouble john36 NVIDIA Linux 2 09-12-02 11:36 PM
X freezes when agp 4x is enabled jinksed NVIDIA Linux 1 08-07-02 05:56 PM

All times are GMT -5. The time now is 08:45 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.