Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-29-08, 05:27 AM   #1
lguerb
Registered User
 
Join Date: Feb 2008
Posts: 10
Default 100.14.19 on 2.6.25

Hello. This is a request for a patch for the driver 100.14.19 to work with the latest 2.6.25 Linux kernel. I need this because every other driver works wrong for me, I already posted in two or three threads about the problem (corrupted ttys, etc.), and since there is no apparent solution to that (not even an answer), I'd need a patch for 100.14.19, the ONLY driver that works somehow fine (still with hang-up problems).

Thanks.
lguerb is offline   Reply With Quote
Old 04-29-08, 07:55 AM   #2
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: 100.14.19 on 2.6.25

I would also need a patch for 169.09, as VT switching is broken in newer drivers.
ambro887 is offline   Reply With Quote
Old 04-29-08, 08:55 AM   #3
drbloed
Registered User
 
Join Date: Feb 2007
Posts: 11
Default Re: 100.14.19 on 2.6.25

Hi folks, i'm having the problem with crashing xsessions with >nvidia-drivers-100.xx
and i already asked Zander in a private message about this.
Just read his answer.

Quote:
Originally Posted by zander
I don't expect these patches to work out-of-the-box with 100.14.19, but 100.14.19 could be updated with some additional work. This driver release is no longer actively maintained, however, and there are no plans to provide patches at this point. Can you elaborate on the X crashes you're seeing with 169.xx?

Thanks,

Quote:
Originally Posted by drbloed
Hi dear Zander,
i have short question about your patches posted for >kernel-2.6.24.x
(-> http://www.nvnews.net/vbulletin/showthread.php?t=110088)

Will one of these work for nvdia-drivers v100.14.19 or will there be a patch for these drivers?

Why do i still use this version? Well, i'm stuck to v100.14.19 because of experiencing X-crashes
when using more than one X-session and some driver version >=169.xx
(there were other users having the same problem, but i didn't find the appropriate thread, sorry for that).

Thanks a lot for your time and answer in advance,
have a nice weekend
Well, i'd like to have this driver working with 2.6.25+ as well,
but i doubt that they'll update those older drivers forever.
drbloed is offline   Reply With Quote
Old 04-29-08, 11:34 AM   #4
NiLuJe
Registered User
 
Join Date: May 2006
Posts: 12
Default Re: 100.14.19 on 2.6.25

Here's one based on the 96.x & 169.x patches from zander (+ workaround for the cache aliasing warnings on x86_64).

The logic for the switch between the defines NV_SET_PAGES_UC_PRESENT / NV_CHANGE_PAGE_ATTR_PRESENT may very well be wrong on a non-2.6.25 kernel, I didn't really test that case...

I'm using it right now (x86_64, gf 6800) without any issues, but YMMV

EDIT (07/18/2008):
* Proper fix for the 'bad caching' warning on x86_64
* nvidia-installer friendly
Attached Files
File Type: txt nvidia-drivers-100.14.19-kernel-2.6.25-compat.txt (22.7 KB, 431 views)

Last edited by NiLuJe; 07-17-08 at 08:13 PM.
NiLuJe is offline   Reply With Quote
Old 04-29-08, 12:01 PM   #5
drbloed
Registered User
 
Join Date: Feb 2007
Posts: 11
Default Re: 100.14.19 on 2.6.25

Well nice, seems to run flawlessly here,
2 users in 2 different sessions are on again without killing X

Thank you!

Perhaps this patch could be reviewed by someone "official" and
then be posted in the sticky thread.
drbloed is offline   Reply With Quote
Old 04-29-08, 02:59 PM   #6
lguerb
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: 100.14.19 on 2.6.25

Definitely, thanks you!!
lguerb is offline   Reply With Quote
Old 04-30-08, 11:59 AM   #7
lguerb
Registered User
 
Join Date: Feb 2008
Posts: 10
Default Re: 100.14.19 on 2.6.25

Well, not so definitely, I need one for x86!! Would it be too hard to change that one?
lguerb is offline   Reply With Quote
Old 05-01-08, 12:25 AM   #8
NiLuJe
Registered User
 
Join Date: May 2006
Posts: 12
Default Re: 100.14.19 on 2.6.25

It should apply cleanly with a bit of sed magic.

Try this one.

EDIT: See previous post.

Last edited by NiLuJe; 07-17-08 at 08:13 PM.
NiLuJe is offline   Reply With Quote

Old 05-13-08, 04:03 PM   #9
AyIi
Registered User
 
Join Date: May 2008
Posts: 2
Default Re: 100.14.19 on 2.6.25

I read this thread right now and would be happy to use this driver, but for me its not possible to patch the driver. It doesnt find the files. So could someone of you upload the x86-version of the patched driver? This would be amazing.
Sorry for my bad english Im from Germany
AyIi is offline   Reply With Quote
Old 06-01-08, 12:44 PM   #10
gfxdrone
Registered User
 
Join Date: Feb 2007
Posts: 74
Default Re: 100.14.19 on 2.6.25

I modified the patches to fit with the other nvidia released patch syntax (like: diff -ru usr/src/nv/os-registry.c usr/src/nv-x86_64-100.14.19-2.6.25/os-registry.c), run from in the unzipped download directory, or like nvidia suggests.

Tested on 32 bit: 100.14.19 and 100.14.23, both worked fine. We needed these for users with non sse cpus and kernel 2.6.25, so thanks for these patches, they work fine, haven't tested the 64 bit but I assume it's fine too.

Thanks for these NiLuJe, any plans on a 2.6.26 version?
gfxdrone is offline   Reply With Quote
Old 06-04-08, 10:19 PM   #11
NiLuJe
Registered User
 
Join Date: May 2006
Posts: 12
Default Re: 100.14.19 on 2.6.25

If I'm still unsatisfied with the latest nvidia drivers when the 2.6.26 kernel comes out of -rc stage, probably. Until then, since I'm not using -rc kernels, count me out, unless someone here really needs to use a -rc kernel.

Sorry about the patch level in my diffs, I use Gentoo, so nvidia's installer is bypassed... I forgot that
NiLuJe is offline   Reply With Quote
Old 07-02-08, 02:35 AM   #12
MamiyaOtaru
Registered User
 
MamiyaOtaru's Avatar
 
Join Date: May 2004
Posts: 45
Default Re: 100.14.19 on 2.6.25

Attached is a patch for 100.14.19 on 2.6.26-rc8. It compiles and runs here, but you'd use it at your own risk obviously. It's a combination of NiLuJe's patch for 2.6.25 and zander's patch to get 173.08 to compile on 2.6.26. Wasn't a ton of fun to get running, so here it is if anyone wants to save themselves the trouble.
Attached Files
File Type: txt 100.14.19for2.6.26.patch.txt (34.0 KB, 294 views)
MamiyaOtaru is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.