Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-23-08, 06:27 PM   #1
Hewitson
Registered User
 
Join Date: Feb 2008
Posts: 6
Default 100.xx and 169.07 drivers locking up when starting X

I've tried both the 100.xx and 169.07 drivers several times on several different kernel versions (all 7.0) and they lock the system up as soon as X is started and require a hard reset.

I'm using a 8600GT with the nvidia agp driver, I have tried the freebsd agpgart as well.

Any suggestions would be greatly appreciated.

Thanks
Hewitson is offline   Reply With Quote
Old 02-24-08, 08:30 AM   #2
Ravna
Registered User
 
Join Date: Mar 2007
Posts: 13
Default Re: 100.xx and 169.07 drivers locking up when starting X

I get the same, but only with the latest driver and Linux compatibility enabled.
Without Linux compat, it takes around 10 min until the box locks up.
I'm just guessing here, but it might have something to do with the latest port of Xorg.
I found that it loads Dri by default and can't be persuaded not to.

However, the patched 100.14.19 port works fine.


.
Ravna is offline   Reply With Quote
Old 02-24-08, 07:08 PM   #3
zebdits
Registered User
 
Join Date: Mar 2007
Posts: 51
Default Re: 100.xx and 169.07 drivers locking up when starting X

Quote:
Originally Posted by Ravna
I found that it loads Dri by default and can't be persuaded not to.
I've noticed that too.
Commenting or removing Load "dri" is a no go.
Add this in Section "Module" of your xorg.conf
Code:
Disable "dri"
zebdits is offline   Reply With Quote
Old 02-24-08, 10:47 PM   #4
Hewitson
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

Hmm it locks up in text mode rather than graphics mode now that I've done that.
Hewitson is offline   Reply With Quote
Old 02-25-08, 11:11 AM   #5
magicite
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

I have the same issue, however I've never actually made it out of text mode. Willing to say duplicate issue as my post.

http://www.nvnews.net/vbulletin/showthread.php?t=108459

Disable dri did nothing for me as well under 6.3 w/ 169.07. Do you have 4 gb of ram like I do Hewitson?
magicite is offline   Reply With Quote
Old 02-26-08, 12:05 AM   #6
Hewitson
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

Yes I do actually.
Hewitson is offline   Reply With Quote
Old 02-26-08, 10:27 AM   #7
magicite
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

Well, I hit the nail in the coffin. If you do have the same problem as me, that's it. took out 2gb chip of ram and it worked like a charm. Remembered reading about this issue some time ago... did not think it was still present.

Can anything be changed to fix this problem of using the nvidia drivers with 4gb of ram?
magicite is offline   Reply With Quote
Old 03-04-08, 06:07 AM   #8
bsdx
Registered User
 
Join Date: Mar 2008
Posts: 1
Default Re: 100.xx and 169.07 drivers locking up when starting X

I hit the same symptoms, did not realize it was freezing because I had too much ram. When I remove 2g out of my 4, it works, but I really want to be able to use at least 3g. I'm already limited to 3200mb by my bios since I'm stuck with 32bit to use the nvidia driver. I had the same problem with a Quadro NVS 290 and a Geforce 6-something (both basic dual dvi cards). I was unable to make it work by telling my kernel to limit memory to 2g, I actually had to remove it. I was going to try the "OS install" mode in my bios but that limits it too far to 256m so I didn't bother. When I set this computer up, I decided to go "the safe route" and stick with the nvidia 32bit driver, and after hours of setup I was dismayed to find that it doesn't even work. Hope it can be fixed somehow, or if unlikely, have someone tell me that it is unlikely so I can make the best of the alternative instead of hoping and waiting. Thanks for any help.

In the meantime I'm giving up rotation, some 2d speed, and display perfection and using the xorg nv driver. Since I just got a new fast desktop, I'd love it if the video driver could keep up. The geforce8 support is considerably better than the geforce6 with the nv driver. My widescreen aspect ratios are correct with dualhead, I could use all 4g of my ram, and I could go 64bit if chances of using the nvidia driver are ruled out. Added some recommended tweaks from the manpage which helps the 2d acceleration some, but at the cost of some image problems:
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"

I wonder if Linux freezes too with 4g on 32bit with this driver? But I'm not going to try it.
bsdx is offline   Reply With Quote

Old 03-04-08, 10:31 AM   #9
magicite
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

It does work bsdx, I came from a gentoo box running 4gb of memory. Was the reason I was surprised the bsd drivers could not work the same.

I have not tried yet with the 169.12 drivers yet though, think I will in a second.

Edit:
Nope, 169.12 doesn't work either. Time to pop out the extra stick again.
magicite is offline   Reply With Quote
Old 03-04-08, 11:57 AM   #10
zBeeble42
Registered User
 
Join Date: Feb 2008
Posts: 40
Default Re: 100.xx and 169.07 drivers locking up when starting X

I have an 8700M (dual, actually) in a laptop with 4G of RAM. FreeBSD ignores about 800 meg of that RAM in 32 bit mode (never tried PAE --- would like to know if that works) but the 169.12 driver works for me (save the constant interrupt storm on one CPU)

I've used the nv driver in 64 bit mode with 4G of ram installed and being used (I have the machine dual-boot FreeBSD 32 and 64 and windoze XP for games). The NV driver is pathetic at 2d (solid window moves suck) and seems to have a bug whereby the pointer change has a race condition and it screws up, hanging X.

The interrupt storm eating one CPU would be more of an issue if this machine didn't have dual-core. I'm not getting rid of my 64 bit partition yet, tho.
zBeeble42 is offline   Reply With Quote
Old 06-21-08, 06:57 AM   #11
Hewitson
Registered User
 
Join Date: Feb 2008
Posts: 6
Default Re: 100.xx and 169.07 drivers locking up when starting X

Absolutely unbelievable that this still has not been fixed. I'll certainly think twice before buying NVIDIA again, thats for sure.

NVIDIA if you can't fix the problem release the source for the drivers so someone who knows what theyre doing can.
Hewitson is offline   Reply With Quote
Old 06-23-08, 12:25 PM   #12
Harvey Pooka
Registered User
 
Join Date: Jan 2004
Posts: 53
Default Re: 100.xx and 169.07 drivers locking up when starting X

Quote:
Originally Posted by Hewitson View Post
Absolutely unbelievable that this still has not been fixed. I'll certainly think twice before buying NVIDIA again, thats for sure.

NVIDIA if you can't fix the problem release the source for the drivers so someone who knows what theyre doing can.
Have you tried/are you able to disable memory remapping in the BIOS? You lose a bit of memory, but at least the driver does not fail/lockup.
Harvey Pooka is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:51 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.