Go Back   nV News Forums > Software Forums > Networking And Security

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-04-08, 10:38 PM   #1
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default This is pissing me off!!

Okay, I have an issue, and I think it's with my network... but I'm not certain. Honestly speaking, I really don't know a whole lot about networking.

I can play most any game online and not have an issue with lag (CS:S, BFME, BFME2, CoD4, etc)... but anytime I try and play C&C3 online, I have major lag issues. It'll drop to less than 1fps I swear. It's really starting to piss me off and I have no idea how to resolve this. I know it's not my computer directly as I can play the skirmish or network games and not have any problem. It plays just fine. But only online is it super slow.

Anybody have any ideas what the issue could be? Any suggestions on different things I might try altering or such? Please!?!?!

Thanks in advance.

EDIT:

It's also laggy when I play over our network... I was wrong above.
Redeemed is offline   Reply With Quote
Old 07-05-08, 01:18 PM   #2
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: This is pissing me off!!

Somebody has got to have some suggestions! Please!?
Redeemed is offline   Reply With Quote
Old 07-05-08, 02:01 PM   #3
Runningman
Registered User
 
Runningman's Avatar
 
Join Date: Feb 2008
Posts: 925
Default Re: This is pissing me off!!

Doesnt CnC have an option for NAT delay in the network options menu? give that a try but this sounds like a netcode issue with the game, why dont you try to reinstall the game and reinstall all the patches to see what happens.
Oh ya, try to add and exculsion in your windows firewall software to see if that helps.
Runningman is offline   Reply With Quote
Old 07-05-08, 05:21 PM   #4
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: This is pissing me off!!

Quote:
Originally Posted by Runningman View Post
Doesnt CnC have an option for NAT delay in the network options menu? give that a try but this sounds like a netcode issue with the game, why dont you try to reinstall the game and reinstall all the patches to see what happens.
Oh ya, try to add and exculsion in your windows firewall software to see if that helps.
I originally had the NAT Delay enable... then disabled it last night when my buddy and I went in online. Didn't make a difference. And there should be an exclusion for the game in the Windows Firewall... I got a prompt the first time I ran the game asking whether the game should be added allowed through the firewall or not. Though I'll double check. If so, I'll try the re-install and see how that goes. Thanks bud.
Redeemed is offline   Reply With Quote
Old 07-05-08, 05:48 PM   #5
CaptNKILL
CUBE
 
CaptNKILL's Avatar
 
Join Date: Jan 2003
Location: PA, USA
Posts: 18,844
Default Re: This is pissing me off!!

So do you mean the actual game framerate (rendering) is dropping? Or you are getting lag spikes?

If its your framerate, its most likely something on your PC or a game bug. I've never heard of anything network related actually decreasing game performance since that should be all up to the CPU and video card.

You may want to try reinstalling your network drivers.

The only other thing I can think of is that since the engine matches the game speed to the framerate (most games aren't like this) that it also matches framerates when you play online. I've heard of some RTS games doing this in the past and if you're playing an opponent with a crappy system, it'd make your game run like ass as well.
__________________
---- Primary Rig ---- CoolerMaster 690 II Advance - Gigabyte GA-EP45-UD3P - Intel Core 2 Quad Q9550 @ 4.0Ghz + Thermalright Ultra 120 Extreme
6GB DDR2 @ 942Mhz 5-5-5-20 1.9v (2x1Gb Wintec AMPX PC2-8500 & 2x2Gb G.Skill PC2-6400) - EVGA Geforce GTX 470 @ 750/1500/1850 (1.050v)
Sparkle Geforce GTS 250 1Gb Low-Profile (Physx) - Crucial RealSSD C300 64Gb SSD - Seagate 7200.12 500Gb SATA - Seagate 7200.10 320Gb SATA
ASUS VW266H 25.5" LCD - OCZ GameXStream 700W PSU - ASUS Xonar DX - Logitech Z-5500 5.1 Surround - Windows 7 Professional x64
---- HTPC ---- Asus M3A78-EM 780G - AMD Athlon X2 5050e 45W @ 2.6Ghz - 2x2GB Kingston PC2-6400 DDR2 - Sparkle 350W PSU
Seagate 7200.10 320Gb SATA - Seagate 7200.10 250Gb SATA - Athenatech A100BB.350 MicroATX Desktop - Creative X-Fi XtremeMusic
CaptNKILL is offline   Reply With Quote
Old 07-05-08, 10:11 PM   #6
Redeemed
Registered User
 
Join Date: May 2005
Posts: 17,982
Default Re: This is pissing me off!!

Quote:
Originally Posted by CaptNKILL View Post
So do you mean the actual game framerate (rendering) is dropping? Or you are getting lag spikes?

If its your framerate, its most likely something on your PC or a game bug. I've never heard of anything network related actually decreasing game performance since that should be all up to the CPU and video card.

You may want to try reinstalling your network drivers.

The only other thing I can think of is that since the engine matches the game speed to the framerate (most games aren't like this) that it also matches framerates when you play online. I've heard of some RTS games doing this in the past and if you're playing an opponent with a crappy system, it'd make your game run like ass as well.
Well, I've never actually had FRAPS running while gaming online, so I'm not sure what the FPS is... but I'll put it this way: it looks like about 3-5fps at its worst. I'm assuming this is lag since it only happens when playing online or over the network.

As for my buddy's rigs, AMD Opteron185 (my old one), 2GB DDR400, eVGA 7900GTX (his first rig), AMD A64 6000+, MSI 8600GTS, 2GB DDR2 800 (his second rig), A64 3700+, 2GB DDR400 RAM, GF7600GT (his third rig). He does have a really old fourth rig, but it plays the game fine since the graphics are literally cranked as low as they can be (except for the resolution, that's maxed). All his rigs are beasty enough to play the game relatively well. So I do doubt that is it. I'm downloading the latest patch now, and will probably get a game in later tonight. Hopefully this solves the problem.
Redeemed is offline   Reply With Quote
Old 07-06-08, 12:53 AM   #7
Runningman
Registered User
 
Runningman's Avatar
 
Join Date: Feb 2008
Posts: 925
Default Re: This is pissing me off!!

ok, im pretty drunk right now, but the question i have is what is the data rate on both of end of the connection, i ask this because CNC is notorerus for data consumtion and has a tendancy to saturate high speed networks...oh, ill get back to this subject tommmorrow..sorry.
Runningman is offline   Reply With Quote
Old 07-07-08, 02:54 AM   #8
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: This is pissing me off!!

LOL

I'm drunk. You know what would be really crazy. If I answered some networking questions! Too arms lads!
crainger is offline   Reply With Quote

Old 07-07-08, 06:47 PM   #9
methimpikehoses
Guest
 
Posts: n/a
Default Re: This is pissing me off!!

  Reply With Quote
Old 07-08-08, 11:37 PM   #10
Runningman
Registered User
 
Runningman's Avatar
 
Join Date: Feb 2008
Posts: 925
Default Re: This is pissing me off!!

LOL, what a jerk!!!
Runningman is offline   Reply With Quote
Old 07-09-08, 12:45 AM   #11
crainger
 
crainger's Avatar
 
Join Date: Aug 2004
Location: Coffs Harbour, NSW, Australia
Posts: 29,559
Send a message via AIM to crainger
Default Re: This is pissing me off!!

Finally sobered up?
crainger is offline   Reply With Quote
Old 07-09-08, 03:23 AM   #12
Runningman
Registered User
 
Runningman's Avatar
 
Join Date: Feb 2008
Posts: 925
Default Re: This is pissing me off!!

Quote:
Originally Posted by crainger View Post
Finally sobered up?
I'm at work, so of coarse not.
Runningman is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.