Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-06-03, 01:14 PM   #1
dlwmech
Registered User
 
Join Date: Jul 2003
Posts: 1
Default (WW) NVIDIA(0): Failed to verify AGP usage

My system is stable and running well.
The problem is 3D acceleration. Nothing I have tried will allow NVIDIA(0) to recognize AGP bridge.
Running Mandrake 9.1, harddrake responds with AMD-761 CPU to AGP Bridge (AGP 4x) but /proc/pci responds PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] AGP Bridge (rev 0).
Any suggestions?
dlwmech is offline   Reply With Quote
Old 08-06-03, 06:06 PM   #2
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

Hm..

I guess just take a look at your /etc/X11/XF86Config-4 file, make sure everything is setup right. Specifically the NvAGP option.

Option "NvAGP" "integer"
Configure AGP support. Integer argument can be one of:
0 : disable agp
1 : use NVIDIA's internal AGP support, if possible
2 : use AGPGART, if possible
3 : use any agp support (try AGPGART, then NVIDIA's AGP)
Please note that NVIDIA's internal AGP support cannot
work if AGPGART is either statically compiled into your
kernel or is built as a module, but loaded into your
kernel (some distributions load AGPGART into the kernel
at boot up). Default: 3 (the default was 1 until after
1.0-1251).

I have the same AGP bridge as you and currently have CONFIG_AGP (agpgart) disabled because I want to try NVIDIA's AGP driver instead, see if it helps with some of my problems.

Prior to this i had CONFIG_AGP and CONFIG_AGP_AMD enabled.

If you have CONFIG_AGP, CONFIG_AGP_AMD enabled in the kernel, you cannot use NVIDIA's AGP driver. So you'd setup /etc/X11/XF86Config-4 to Option "NvAGP" "2" or "3".

If these are disabled or configured as a module, you can use Option NvAGP 1 or 3 to try and use NVIDIA's AGP driver.
logan is offline   Reply With Quote
Old 08-07-03, 03:36 AM   #3
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: Making sure agpgart is disabled

Hi. Could you please give more information about how we can make sure that agpgart support is not included in the kernel. I can configure and recompile the kernel, but at present only know how to use make menuconfig. In what files do I find the options that you mention, and how can I turn them 'off' to see if that solves my (considerable) problems?

Thanks in anticipation,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-07-03, 11:06 AM   #4
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

/usr/src/linux/.config is where you'll find the CONFIG_* options.

Look under 'Character devices' in menuconfig, and you'll see AGP/AGPGART support.

Just make sure are using the right mix of options between the X/NVIDIA configuration and kernel.
logan is offline   Reply With Quote
Old 08-07-03, 11:17 AM   #5
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: AGP config option locations

Hi. I can't find the file you mention. I can find a directory /usr/src/linux-24-x-x/config. Inside are a whole lot of configuration files for different processor architectures, and the options you mention are included therein.

I'm going to try kernel 2.4.20.19-9 tonight and see if that fixes my problems.

Cheers,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-07-03, 11:22 AM   #6
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default

Ah, well if you are using distro-provided kernels, I don't know where they would keep that stuff. I compile my own.

Usually everything is modules, if that's the case then you might not have to do anything with the kernel at all. Just make sure X is configured how you want it and the appropriate modules are loaded or unloaded.
logan is offline   Reply With Quote
Old 08-07-03, 11:26 AM   #7
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: AGP Problems

Hi. The current problem is that I don't know enough about this stuff yet. I have a non-working system. Nobody seems to be able to give me any hints as to what might be wrong. So, at present, I'm just blundering my way through the system making changes, and eventually I hope to fix the problem.

I have had games such as tuxracer working on this machine before, but since I hosed the system (trying to upgrade glibc and not being careful enough), I just can't seem to get ... something ... right.

Cheers,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-07-03, 02:59 PM   #8
guills
Registered User
 
Join Date: Aug 2002
Posts: 28
Default

It's hard to help someone with a system they screwed up already.. but .. to know if you have AGP compiled in the kernel or not, you could try this:

type dmesg | grep AGP

If you see messages about AGPGART loading or a unknown AGP chipset found... you have AGP drivers in your kernel.

If not, I think you should be safe.

Btw, if someone tells you something that looks complicated, and takes a lot of steps, there's prolly a better way to do it. heh
guills is offline   Reply With Quote

Old 08-08-03, 04:05 AM   #9
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: Problems with AGP

Thanks for the reply. I do have some agp support in the kernel, but that is in there on the advice of the README file for the NVIDIA kernel patches. They say (from memory) to apply the patches, run menuconfig, go to character devices->/dev/agpgart (or similar name), make sure that that is included in the kernel (compiled or as a module), and then tick the (NEW) option for NVIDIA chipset support.

My working machine also has messages complaining about agpgart in the output of 'dmesg', but the graphics work on that quite well.

My most recent experiments on the system were on a clean reinstall of rh9, but even after following all the instructions very carefully it doesn't work. On the contrary, for the machine that does work (different mobo), I haven't patched the kernel as per NVIDIA's instructions. But, the machine at home doesn't seem to work with patched or unpatched kernel.

My next experiment is to install a second linux distro onto the machine, choosing one that has a stock kernel to see if it is some sort of conflict between the drivers and the redhat kernel that is causing the problem. I have Mandrake 9.1, but believe that the Mandrake kernel is also non-standard. I'm also considering trying BSD to see what happenbs there. Anyone recommend a distro to try? I can try a number of them.

I think that IRQ settings may be part of the problem. At the moment, I'm leaving the board to allocate IRQs automatically. I have read that it's better to set the bios to say that you don't have a PnP OS, but can't find the option to do so. Unless, this is the option to auto-allocate IRQs.

Any hints greatly appreciated, I'm getting desperate here. At present, the only way forward that I can see is to buy another A7N266-VM board, and replace the Abit with it. This will slow down my processor and memory, but unless I can get the NF7-M working, it still seems a better option.

Thanks in anticipation,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-08-03, 06:48 AM   #10
guills
Registered User
 
Join Date: Aug 2002
Posts: 28
Default

I say you should remove support for AGP completly from your kernel and use NVIDIA's agp driver. I'm pretty sure nforce2 chipsets aren't supported by agpgart anyways, and nvagp works perfectly with it.

For this you need:
Option "NvAgp" "1"
In your X config file.

And you need to make sure AGPGART is not compiled in your kernel. If it is as a module, it should be fine as long as it is _never_ loaded.

Along with nvidia's X driver, this will work. I have a nforce2 chipset working with a ti4200 here this way.

As for the distros... It's the same thing for any of them. Starting from a clean install, to get everything going just:
1. remove AGPGART support
2. install nvidia's drivers with the automatic installer
3. change your X config to use nvidia's driver and NvAGP=1
4. Make sure you remove Load dri and Load GLcore from your X config.
5. Make sure you put Load glx in there.

And it will automagically work
guills is offline   Reply With Quote
Old 08-08-03, 06:45 PM   #11
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Problems continue

Well, it turned out that I didn't know how to recompile the kernel as much as I thought I did. I'd patched and recompiled the kernel, but not installed it.

I'm running a custom kernel now, with agpgart disabled, and the NvAGP set to 1. Starts up the AGP with no errors.

But, my problem remains. I still can't run 3d apps. If I try, at least the app crashes, and usually X crashes as well.

I'm now getting to the point where I am very confident that I haven't just done something wrong, but that there are flaws in the drivers and/or my os.

Next step is to install a different OS and see what happens :-(

Cheers,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
320.17 can't detect video modes on Lenovo laptop tadawson NVIDIA Linux 13 07-14-12 01:40 AM
Regression with 295.33 and GeForce GT 240 maro NVIDIA Linux 16 06-29-12 06:47 PM
Dell Precision M6500 - Nvidia Quadro FX 2800M - Unusable with Gnome3 geaaru NVIDIA Linux 16 06-25-12 07:07 AM
Error messages... HELP!!!! Imperito NVIDIA Linux 3 09-24-02 10:46 PM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 12:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.