Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-08-03, 12:41 AM   #1
Caffeinebot
Caffeinated
 
Join Date: May 2003
Posts: 8
Default Lockups with nvidia

Ok guys, heres the story:
My motherboard doesn't have the "strength" aparantly to run agp in 4x mode for my Nvidia 440 mx card so I have to run it in 2x mode in NVIDIA mode (AGPGART on the other hand manages to lock up)

My problem is generaly solved by:
1- Adding Option "NvAGP" "1" to my XF86config file
2- Changing the source os-registry file to incorporate 2x mode (NVreg_ReqAGPRate 1)
3- while also removing the two leading underscores in the ReqAGPrate.
4 - doing a make install and starting x

Now my problem is that this stoped working after I formated and reinstalled my Linux distro (slackware 9). As soon as I start up X I get up a lockup almost immediatly after running something UI intensive (gimp/mozilla/etc) This isn't related to version as 4363 and 4496 both give me the same problem. But I HAVE gotten 463 to work in the past now my question is also..am i forgetting something?

Doing a cat on /proc/drivers/nvidia/agp/status gives me nvidia running agp 2x on NVIDIA. Switching to AGPGART, again, gives me the same issues.

Thanks in advance
Attached Files
File Type: txt xf86config.txt (14.9 KB, 187 views)
__________________
---
Who will guard the guardians?
Caffeinebot is offline   Reply With Quote
Old 08-08-03, 12:44 AM   #2
Caffeinebot
Caffeinated
 
Join Date: May 2003
Posts: 8
Default Log

And here is my log file, I hope this helps..
Attached Files
File Type: log xfree86.0.log (24.2 KB, 130 views)
__________________
---
Who will guard the guardians?
Caffeinebot is offline   Reply With Quote
Old 08-08-03, 01:38 AM   #3
eno_
Registered User
 
Join Date: Aug 2003
Posts: 1
Default

Hmm. A friend of mine had a very similair problem... I don't think he ever fixed it. Not to give your hopes up.
eno_ is offline   Reply With Quote
Old 08-08-03, 09:36 AM   #4
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: Changing AGP speed to 2x

Hi. Sorry to answer your question with a question, but could you please explain further how you went about changing the AGP speed to 2x? Unfortunately, I don't know where the os_registry file is. I did a find in my linux source for any file called '*registry*', but couldn't find one.

I'd like to give this a go to see if it solves my problems.

Thanks in anticipation,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-08-03, 11:05 AM   #5
Caffeinebot
Caffeinated
 
Join Date: May 2003
Posts: 8
Default

Ok heres a complete outline for what I do..
after a fresh install.
1) Download Nvidia drivers
2) Download kernel source (you may not have to do this)
3) Install kernel source
4) sh Nvidia NVIDIA-Linux-x86-1.0-4496-pkg2.run --extract-only
5) cd NVIDIA-Linux-x86-1.0-4496-pkg2
6) pico /NVIDIA-Linux-x86-1.0-4496-pkg2/usr/src/nv/os-registry.c
7) edit the NVreg_ReqAGPRate to whatever you want to enforce
8) remove the leading underscores at the bottom of the file from __NVreg_ReqAGPRate (not necessary aparantly in 4496)
9) cd NVIDIA-Linux-x86-1.0-4496-pkg2
10) make install

This enforces agp 2x. I hope this helps. If you ever need to refer to this again, check the readme, its all in there :P
__________________
---
Who will guard the guardians?
Caffeinebot is offline   Reply With Quote
Old 08-08-03, 11:11 AM   #6
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: Changing AGP speed

Many thanks. I've saved your post and it is one of the things I'll try this weekend.

Other planned experiments are getting radical. I've found someone running FreeBSD 5.1 with the same mobo (and hence graphics). I've found a spare hdrive, and am burning the BSD disks right now.

Cheers,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-08-03, 11:26 AM   #7
Caffeinebot
Caffeinated
 
Join Date: May 2003
Posts: 8
Default

well good luck still my problem isn't getting solved either
__________________
---
Who will guard the guardians?
Caffeinebot is offline   Reply With Quote
Old 08-08-03, 11:28 AM   #8
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Re: Problems

If I had any clue what your problem is, I'd post immediately. I can sympathise completely with the feeling of there being a major problem and having little idea of even finding out exactly what the cause is.

Good luck,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote

Old 08-08-03, 06:53 PM   #9
Ross Clement
Registered User
 
Join Date: Jul 2003
Location: London, Uk
Posts: 32
Default Can't even change to 2x

Hi. Well, as it turns out, I can't even change my AGP rate to 2x. When I unpack the NVIDIA-Linux-x86-1.0-4496-pkg2, I get a file in ./usr/src/nv/ called os-registry.c. While there is a line:

static int NVreg_ReqAGPRate = 2;

there is no line in that file (or any file unpacked from the 4496-pkg2.run file) with the __NVreg_ReqAGPRate variable. So, I cannot remove the underscores. When I look through the code, I do find a line enabling options, which includes AGPRate:

{ NULL, "ReqAGPRate", &NVreg_ReqAGPRate, 1 },

I enabled that, and did (after compiling) a:

insmod nvidia NVreg_ReqAGPRate=2

This put an option line in my modules.conf:

options nvidia NVreg_ReqAGPRate=2 # force AGP Rate to 2x

But, when I reboot the computer, the AGP rate is still 4!

Looking in the German readme, things look rather strange. E.g. it mentions the aforementioned module option, even though the english README doesn't. Also, it talks about NVdriver, while once again, this isn't mentioned in the english version. Is the german version out of date?

Next step, I suppse, is to try a different OS to see if it is redhat that is causing my problems.

Cheers,

Ross-c
__________________
Life would be perfect if it wasn't for thisone small glitch....
Ross Clement is offline   Reply With Quote
Old 08-08-03, 10:45 PM   #10
Caffeinebot
Caffeinated
 
Join Date: May 2003
Posts: 8
Default

Well, I tried unisntalling and downgrading to other drivers and still no luck. I can't figure out what I'm doing wrong..I'm still trying other ideas, but I don't want to delve into kernel compilations etc, I don't have the know how or the time to study it just yet.
I hope something turns up though..
__________________
---
Who will guard the guardians?
Caffeinebot is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
NVIDIA GeForce GTX 670 brings Kepler on a $399 budget (SlashGear) News GeForce GTX 670 Reviews 0 05-10-12 08:40 AM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
rh7.3 and nvidia vcrispo NVIDIA Linux 11 07-31-02 08:57 PM

All times are GMT -5. The time now is 04:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.