Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-26-08, 04:16 PM   #13
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

Please, try with Opera 9.5 with the canvas test page.

It seems to be the Xorg version with nvidia driver that gives some troubles.
I've got Xorg 7.3

This is not Firefox and Opera but a 2D display setting that generate such of low performance.
Metal3d is offline   Reply With Quote
Old 07-26-08, 04:32 PM   #14
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: Serious performance problem with canvas tag on firefox

This works much better with IPP=2 (tested on 7600 Go)
With IPP=1 its fast in every browser (midori, opera etc) but firefox (3) with IPP=1 too.

btw. IPP=2 seems to couse serve corruption on my system with compiz.
Dragoran is offline   Reply With Quote
Old 07-26-08, 05:50 PM   #15
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

I resolved problem.
Look at this:
http://techbase.kde.org/User:Lemma/KDE4-NVIDIA

What i did:
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1

For users who have the same problem than me, try this

[edit] @Dragoran ok, you have found the solution Could you explain wath this options means ? Thanks

Last edited by Metal3d; 07-26-08 at 06:09 PM. Reason: Saw Dragoran message too late
Metal3d is offline   Reply With Quote
Old 07-27-08, 02:53 AM   #16
pawels133
Registered User
 
pawels133's Avatar
 
Join Date: Mar 2008
Posts: 201
Default Re: Serious performance problem with canvas tag on firefox

With nvidia-settings -a InitialPixmapPlacement=2 option canvas tags are much faster for me (still very slow - 4 blobs and animation is choppy but before animation was much slower with one blob) but other things like scrolling play list in Amarok is noticeably slower. It looks that there's no good solution with those crappy drivers...
__________________
Not everybody can smoke and drink... xd
pawels133 is offline   Reply With Quote
Old 07-27-08, 04:34 AM   #17
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

Strange, for me it is completly opposite.

Maybe it works for some configurations and doesn't work for other.
Metal3d is offline   Reply With Quote
Old 07-27-08, 07:37 AM   #18
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: Serious performance problem with canvas tag on firefox

Quote:
Originally Posted by pawels133 View Post
With nvidia-settings -a InitialPixmapPlacement=2 option canvas tags are much faster for me (still very slow - 4 blobs and animation is choppy but before animation was much slower with one blob) but other things like scrolling play list in Amarok is noticeably slower. It looks that there's no good solution with those crappy drivers...
What version of Amarok are you using? I'm using 1.4.9.1 built against kdelibs 3.5.9 and have no issues. In fact, with IPP=2 I have no slow down anymore with any applications. Firefox for instance fixed certain other issues with the most recent release. AFAIK the only real issues with nVidia drivers (not legacy) is with KDE4 based applications.
Big P is offline   Reply With Quote
Old 07-27-08, 08:18 AM   #19
pawels133
Registered User
 
pawels133's Avatar
 
Join Date: Mar 2008
Posts: 201
Default Re: Serious performance problem with canvas tag on firefox

Quote:
Originally Posted by Big P View Post
What version of Amarok are you using? I'm using 1.4.9.1 built against kdelibs 3.5.9 and have no issues. In fact, with IPP=2 I have no slow down anymore with any applications. Firefox for instance fixed certain other issues with the most recent release. AFAIK the only real issues with nVidia drivers (not legacy) is with KDE4 based applications.
I'm using the same version of Amarok and kdelibs (fully upgraded Arch Linux). I don't have high end PC so maybe that's why I can notice such performance drop:

AMD Duron 1200MHz with SSE, Geforce 6800 XT, 512MB SDRAM, Abit KT7A, the newest nvidia drivers (beta).

Scrolling in Firefox is smoother compared to 169.xx drivers but Firefox interface (File, Edit etc.) is awfully slow (I didn't tried KDE4 with the newest drivers yet).

What I noticed is also huge 3D performance drop in UT2K4 (maybe in other games too) compared to Geforce 2MX 400 and windows (UT2K4 was much smoother on GF2 under windows than on GF6 under Linux!! But this story is for a new thread).
__________________
Not everybody can smoke and drink... xd
pawels133 is offline   Reply With Quote
Old 07-27-08, 02:26 PM   #20
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

I think this options are good for 8xxx and 9xxx series.

On my configuration (8600 GT) this really have increase performances.
Metal3d is offline   Reply With Quote

Old 07-27-08, 03:48 PM   #21
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: Serious performance problem with canvas tag on firefox

Quote:
Originally Posted by Metal3d View Post
I think this options are good for 8xxx and 9xxx series.

On my configuration (8600 GT) this really have increase performances.
Nope. The "nvidia-settings -a InitialPixmapPlacement=2" setting also works on the 7 series. I just used it and my CPU usage on the blobsallad page went from 100% CPU to 7% CPU using a 7950GT.
mooninite is offline   Reply With Quote
Old 07-28-08, 02:51 AM   #22
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

Quote:
Originally Posted by mooninite View Post
Nope. The "nvidia-settings -a InitialPixmapPlacement=2" setting also works on the 7 series. I just used it and my CPU usage on the blobsallad page went from 100% CPU to 7% CPU using a 7950GT.
Exactlly the same here. I saw somewhere there is a PixmapCacheSize option too.

If someone could explain what means IPP and GlyphCahe ?
Metal3d is offline   Reply With Quote
Old 08-06-08, 07:37 AM   #23
Metal3d
Registered User
 
Join Date: Jul 2008
Posts: 11
Default Re: Serious performance problem with canvas tag on firefox

I continue to test Xorg + nvidia, there is the same performance troubles with google gadget for linux http://code.google.com/p/google-gadgets-for-linux/

Even with IPP=2 and glyphcache enabled.

I really think to change graphic card on Linux...
Metal3d is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM
Serious problem! Computer that boots by itself!? DXnfiniteFX General Hardware 18 10-04-02 11:15 PM

All times are GMT -5. The time now is 09:51 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.