Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-26-03, 11:34 PM   #1
ShahShadow
Registered User
 
Join Date: Jul 2003
Location: Atlanta, GA USA
Posts: 2
Send a message via ICQ to ShahShadow Send a message via AIM to ShahShadow Send a message via Yahoo to ShahShadow
Unhappy Red Hat 9 and triple screens

Hola. I have a Red Hat 9 box with:

1) GeForce4 MX420 AGP (single head)
2) PNY Verto GeForce $ MX440SE (dual-head)

and three Sony flat-panels connected (1 17" on the AGP card, 2 15" on the Verto).

When I try to launch X, the driver craps out for some reason and gives me the following.

If anyone can help me with this, I would greatly appreciate it. The lack of triple monitors is keeping me booting back into Windows against my will :-) If you need any more information, please let me know. I was going to begin looking at the source, but I'm not sure if I'll be successful in locating the problem in any realistic time frame. One thing though is that it says "unknown chipset" for my PNY card in the following output. Thanks in advance.

(taken from XFree86.0.log):

XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-3bigmem i686 [ELF]
Build Date: 27 February 2003
Build Host: porky.devel.redhat.com

Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.20-18.9 (bhcompile@porky.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu May 29 07:08:16 EDT 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Jul 26 01:42:56 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Screen "Screen1" (1)
(**) | |-->Monitor "Monitor1"
(**) | |-->Device "Videocard1"
(**) |-->Screen "Screen2" (2)
(**) | |-->Monitor "Monitor2"
(**) | |-->Device "Videocard2"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"

... omitted ...
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV17 [GeForce4 MX 420] rev 163, Mem @ 0xfb000000/24, 0xdc000000/26, 0xe2680000/19, BIOS @ 0xfc9e0000/17
(--) PCI: (2:1:0) nVidia Corporation unknown chipset (0x0322) rev 161, Mem @ 0x28000000/27

(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4363
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NVIDIA XFree86 Driver 1.0-4363 Sat Apr 19 17:49:42 PDT 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(WW) NVIDIA: No matching Device section for instance (BusID PCI:2:1:0) found
(--) Chipset NVIDIA GPU found
(--) Chipset NVIDIA GPU found
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x1fffffff (0x1ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xfeacd000 - 0xfeacdfff (0x1000) MX[b]
[6] -1 0 0xfeace000 - 0xfeacefff (0x1000) MX[b]
[7] -1 0 0xfead0000 - 0xfeadffff (0x10000) MX[b]
[8] -1 0 0xfeae0000 - 0xfeafffff (0x20000) MX[b]
[9] -1 0 0xfeacf000 - 0xfeacffff (0x1000) MX[b]
[10] -1 0 0xfebff400 - 0xfebff4ff (0x100) MX[b]
[11] -1 0 0xfebff800 - 0xfebff9ff (0x200) MX[b]
[12] -1 0 0x20000000 - 0x200003ff (0x400) MX[b]
[13] -1 0 0xfebffc00 - 0xfebfffff (0x400) MX[b]
[14] -1 0 0xf4000000 - 0xf3ffffff (0x0) MX[b]O
[15] -1 0 0xfc9e0000 - 0xfc9fffff (0x20000) MX[b](B)
[16] -1 0 0xe2680000 - 0xe26fffff (0x80000) MX[b](B)
[17] -1 0 0xdc000000 - 0xdfffffff (0x4000000) MX[b](B)
[18] -1 0 0xfb000000 - 0xfbffffff (0x1000000) MX[b](B)
[19] -1 0 0x28000000 - 0x2fffffff (0x8000000) MX[b](B)
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[22] -1 0 0x0000d000 - 0x0000d03f (0x40) IX[b]
[23] -1 0 0x0000d400 - 0x0000d43f (0x40) IX[b]
[24] -1 0 0x0000d480 - 0x0000d483 (0x4) IX[b]
[25] -1 0 0x0000d800 - 0x0000d807 (0x8) IX[b]
[26] -1 0 0x0000d880 - 0x0000d883 (0x4) IX[b]
[27] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[28] -1 0 0x0000d080 - 0x0000d08f (0x10) IX[b]
[29] -1 0 0x0000e080 - 0x0000e0bf (0x40) IX[b]
[30] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[b]
[31] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
[32] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[b]
[33] -1 0 0x0000ec00 - 0x0000ec1f (0x20) IX[b]
[34] -1 0 0x0000e880 - 0x0000e89f (0x20) IX[b]
[35] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[b]
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[b](B)
[1] -1 0 0x00100000 - 0x1fffffff (0x1ff00000) MX[b]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[5] -1 0 0xfeacd000 - 0xfeacdfff (0x1000) MX[b]
[6] -1 0 0xfeace000 - 0xfeacefff (0x1000) MX[b]
[7] -1 0 0xfead0000 - 0xfeadffff (0x10000) MX[b]
[8] -1 0 0xfeae0000 - 0xfeafffff (0x20000) MX[b]
[9] -1 0 0xfeacf000 - 0xfeacffff (0x1000) MX[b]
[10] -1 0 0xfebff400 - 0xfebff4ff (0x100) MX[b]
[11] -1 0 0xfebff800 - 0xfebff9ff (0x200) MX[b]
[12] -1 0 0x20000000 - 0x200003ff (0x400) MX[b]
[13] -1 0 0xfebffc00 - 0xfebfffff (0x400) MX[b]
[14] -1 0 0xf4000000 - 0xf3ffffff (0x0) MX[b]O
[15] -1 0 0xfc9e0000 - 0xfc9fffff (0x20000) MX[b](B)
[16] -1 0 0xe2680000 - 0xe26fffff (0x80000) MX[b](B)
[17] -1 0 0xdc000000 - 0xdfffffff (0x4000000) MX[b](B)
[18] -1 0 0xfb000000 - 0xfbffffff (0x1000000) MX[b](B)
[19] -1 0 0x28000000 - 0x2fffffff (0x8000000) MX[b](B)
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[22] -1 0 0x0000d000 - 0x0000d03f (0x40) IX[b]
[23] -1 0 0x0000d400 - 0x0000d43f (0x40) IX[b]
[24] -1 0 0x0000d480 - 0x0000d483 (0x4) IX[b]
[25] -1 0 0x0000d800 - 0x0000d807 (0x8) IX[b]
[26] -1 0 0x0000d880 - 0x0000d883 (0x4) IX[b]
[27] -1 0 0x0000dc00 - 0x0000dc07 (0x8) IX[b]
[28] -1 0 0x0000d080 - 0x0000d08f (0x10) IX[b]
[29] -1 0 0x0000e080 - 0x0000e0bf (0x40) IX[b]
[30] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[b]
[31] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[b]
[32] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX[b]
[33] -1 0 0x0000ec00 - 0x0000ec1f (0x20) IX[b]
[34] -1 0 0x0000e880 - 0x0000e89f (0x20) IX[b]
[35] -1 0 0x0000e800 - 0x0000e81f (0x20) IX[b]
(EE) Screen 1 deleted because of no matching config section.
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWSave from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWSave from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWRestore from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWRestore from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWUnmapMem from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCloseScreen from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCreateWindow from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbCreateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbGCPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbValidateGC from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbPictureInit from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol vgaHWGetIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!
Symbol fbWinPrivateIndex from module /usr/X11R6/lib/modules/drivers/nvidia_drv.o is unresolved!

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 4. Server aborting


Here's the X config (relevant parts) I'm using:

Section "ServerLayout"
Identifier "Default Layout"
Screen "Screen0"
Screen "Screen1" LeftOf "Screen0"
Screen "Screen2" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama"
EndSection


Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SDM-HS73"
DisplaySize 340 270
HorizSync 28.0 - 65.0
VertRefresh 48.0 - 65.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "SDM-HS53"
HorizSync 28.0 - 65.0
VertRefresh 48.0 - 65.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "Sony"
ModelName "SDM-HS53"
HorizSync 28.0 - 65.0
VertRefresh 48.0 - 65.0
Option "dpms"
EndSection


Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 420 MX"
Option "NvAGP" "1"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 PNY 440 MX"
BusID "PCI:2:1:0"
Screen 1
EndSection

Section "Device"
Identifier "Videocard2"
Driver "nvidia"
VendorName "PNY"
BoardName "NVidia GeForce 4 PNY 440 MX"
BusID "PCI:2:1:0"
Screen 2
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "Videocard2"
Monitor "Monitor2"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 16
SubSection "Display"
Depth 8
Modes "640x480" "800x600" "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerFlags"
Option "Xinerama" "true"
EndSection



__________________
Hemal Hemant Shah
Computer Science
Georgia Institute of Technology
ShahShadow is offline   Reply With Quote
Old 08-05-03, 08:38 PM   #2
linux_gal
Registered User
 
Join Date: Jul 2003
Posts: 3
Default

disable the Screen # in all "Device" sections, that should help.
linux_gal is offline   Reply With Quote
Old 08-11-03, 01:06 PM   #3
ShahShadow
Registered User
 
Join Date: Jul 2003
Location: Atlanta, GA USA
Posts: 2
Send a message via ICQ to ShahShadow Send a message via AIM to ShahShadow Send a message via Yahoo to ShahShadow
Default

Thanks, LinuxGal, but unfortunately, no luck. I remove the Screen numbers, and now, my side panels will briefly come to life and say Out of Scan Range while the center one (hooked up to the 440GX) will show an X cursor and then the entire system will completely lock up.

By the way, my bad, I have a 440GX and a PNY 5200 (dual-head, connected to the side panels).

Now I am at a loss
__________________
Hemal Hemant Shah
Computer Science
Georgia Institute of Technology
ShahShadow is offline   Reply With Quote
Old 08-11-03, 01:10 PM   #4
linux_gal
Registered User
 
Join Date: Jul 2003
Posts: 3
Default

do you have a correct Sync/Refresh info for the monitors ? what if you enable "UseEdidFreqs" "1" in your "Device" sections?
linux_gal is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Triple Head for NVIDIA graphics cards? Lowen Na NVIDIA GeForce 7, 8, And 9 Series 26 08-28-08 01:31 PM

All times are GMT -5. The time now is 09:10 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.