Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-14-08, 03:39 PM   #1
max7
Registered User
 
Join Date: Aug 2008
Posts: 6
Default GForce Go 7600 1650x1080 LCD problem

I have laptop with GForce Go 7600.

In past I used it with second 1024x1024 LCD.

Now I go a new 1650x1080 LCD.

But nvidia driver do not work with it.

nv driver is able to make second LCD work but first (laptops) lcd do not work.
There is no 3d with nv driver.

I have standard nvidia driver that comes with ubuntu 8.04
If I connect old LCD I can use it with old xorg.conf

I have adjusted xorg.conf to work with new bigger screen

Here is one of not working configurations.

I made a lot of attempts to make it work.




Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder3)  Wed Sep 12 14:30:30 PDT 2007

# edit

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
    Load           "v4l"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

	# generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

	# generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       31.5 - 107.5
    VertRefresh     56.0 - 85.0
    Gamma           1
    ModeLine       "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
    ModeLine       "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
    ModeLine       "1280x768@60" 80.1 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
    ModeLine       "1280x720@60" 74.5 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
    ModeLine       "1280x800@60" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Generic CRT Display"
    ModelName      "Monitor 1650x1080"
#    HorizSync       31.5 - 107.5
#    VertRefresh     50.0 - 85.0
#HorizSync 30-70
#VertRefresh 50-160
    Gamma           1
#    ModeLine       "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
#    ModeLine       "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
#    ModeLine       "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
#    ModeLine       "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
    
#    ModeLine "1680x1050@60"  147.14  1680 1784 1968 2256  1050 1051 1054 1087  -HSync +Vsync

#modeline "1680x1050@60" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 +hsync -vsync
#Option "DPMS"
#HorizSync 30-70
#VertRefresh 50-160

  Modeline      "1680x1050"x60.0 146 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync 
  Option       "DPMS"
#  DisplaySize  474 296
  HorizSync    31-83
  VertRefresh  56-75


EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce Go 7600"
EndSection

Section "Device"
    Identifier     "Videocard1"
    Driver         "nvidia"
    BoardName      "nv"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

	# Removed Option "TwinView" "0"
	# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
	# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1280+0"
	# Removed Option "metamodes" "CRT: 1280x1024@60 +1280+0, DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: 640x480@60 +1280+0, DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: 1024x768_60 +1280+0, DFP: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT: 1650x1050_60 +0+0, DFP: 1280x800_60 +1650+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Videocard1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
#        Modes      "1280x1024@60" "1024x768@60" "800x600@60" "640x480@60"
        Modes      "1650x1050@60"
    EndSubSection
EndSection

Is anyone know if that driver supports that resolution?
The LCD was not working on XP until I have updated the driver.
But I had there very old driver. (2 or 3 years old)

Thanks
max7 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.