Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-09-08, 12:24 PM   #1
labby
Registered User
 
Join Date: Mar 2008
Posts: 3
Default Blender 3D freezes with 8-series geforce

Greetings!

I'm having a little problem with Nvidia linux driver (version 169.12 64-bit) and geforce 8600 gt. Using Blender (http://www.blender.org/) with more than one 3d viewport (or in the texture painting mode with just one viewport with textures) sometimes freezes the entire computer for a few seconds with full cpu activity. After a few seconds, the cpu activity returns to normal level and everything works properly for a while. Usually this happens several times per minute, and in worst cases, it works less than a second until it freezes again. This is a very annoying problem that prevents certain 3d modeling applications on workstations that use these display adapters.

I do realize that this sounds like a Blender-related bug, but this seems to happen with the 8-series geforce display adapters only. I discussed this problem with one of the Blender developers, and he asked me to contact Nvidia directly.

Another Blender user verified this problem with a geforce 8800 gts, and I believe that this problem appears with all 8-series geforce display adapters on linux. This problem did not occur on windows, we tried it with a 8800 gts / windows xp with the latest drivers.

7- and 6-series geforce cards on linux with the latest driver do not appear to have this problem either.

If there's a simple configuration tweak or similar workaround, I'd love to hear about it. I've also tried the configuration options that were mentioned in other problems with performance or stability, but none of them fixed this one.


--
Arto Harju
Attached Files
File Type: log nvidia-bug-report.log (136.0 KB, 114 views)
labby is offline   Reply With Quote
Old 03-10-08, 05:30 AM   #2
Ryder08
Registered User
 
Join Date: Nov 2005
Posts: 2
Default Re: Blender 3D freezes with 8-series geforce

Hi,
I'm not the other user Labby is talking about, but I have the same 'problem' with blender & geForce 8600Gt. It's not as bad as him as freezes happens only every 5 minutes or so and for a few seconds, but it happens anyway for me too.

As far as settings goes, I know having forced anti-aliasing in nvidia-settings is a no-go because the blender 3D view become completely black and red when moving objects.

Note : I have not test the new drivers yet.
Note2 : I use Blender 2.44 (where is Blender 2.45 for opensuse ?)
Ryder08 is offline   Reply With Quote
Old 03-10-08, 12:09 PM   #3
ZeroDivide
Registered User
 
Join Date: Sep 2004
Posts: 14
Default Re: Blender 3D freezes with 8-series geforce

I can confirm this problem on my system as well.

geforce 8800 gts 320
blender 2.44 and 2.45
ZeroDivide is offline   Reply With Quote
Old 03-11-08, 04:09 AM   #4
hyfans
Registered User
 
Join Date: Apr 2005
Posts: 75
Default Re: Blender 3D freezes with 8-series geforce

no problem here.

8500GT + 171.06 beta + blender 2.46 RC
hyfans is offline   Reply With Quote
Old 03-11-08, 08:19 AM   #5
labby
Registered User
 
Join Date: Mar 2008
Posts: 3
Default Re: Blender 3D freezes with 8-series geforce

I just installed 171.06 beta driver, and there's no noticeable difference. It still keeps freezing very frequently.

The original problem report wasn't exactly accurate, however. This problem does occur even when there's just one viewport.
labby is offline   Reply With Quote
Old 03-13-08, 02:09 PM   #6
labby
Registered User
 
Join Date: Mar 2008
Posts: 3
Default Re: Blender 3D freezes with 8-series geforce

This problem happens on 32-bit linux as well, I just tried it with the same workstation. I wasn't able to trigger this bug with any other application, so this could be a bug in Blender's opengl code afterall.
labby is offline   Reply With Quote
Old 04-15-08, 11:33 AM   #7
lile
Registered User
 
Join Date: Apr 2008
Posts: 1
Default Re: Blender 3D freezes with 8-series geforce

I have exactly the same problem here

Open Suse 10.3

cpu intel core 2 quad q6600
Open Suse 10.3
Xorg 7.2

NVIDIA nx8800GT
drivers 169.12 or 170.06 , 64 bits

both blender 2.45, and 2.46RC, x86-64


I have posted it to blender bugs tracker :http://projects.blender.org/tracker/..._id=9&atid=231

According to blender developpers, it sounds more like a driver issue than blender GL code.

I hope nvidia guys can do something about it...I'm very happy with this card, excepted for blender, which I use daily for my work. This bug makes it real hard to use actually....


I don't know if both issues are due to the same, but I also have this strange behaviour :

http://projects.blender.org/tracker/..._id=9&atid=231


my 2 cents...
lile is offline   Reply With Quote
Old 04-16-08, 08:43 AM   #8
ChojinDSL
Registered User
 
Join Date: May 2005
Posts: 2
Default Re: Blender 3D freezes with 8-series geforce

Just wanted to confirm that I'm experiencing the same problems.

My Specs:

Gentoo Linux Kernel 2.6.24
2xGeforce 8600GT PCI-E GPUs
Blender 2.45.
Intel Q6600 Quad Core CPU
8GB Ram.

I have tried the current stable NVidia driver as well as the beta driver. The issue persists in both. I have tried messing around with my Xorg.conf and disabling SLI among other things, so far nothing seems to work.
ChojinDSL is offline   Reply With Quote

Old 04-17-08, 11:13 AM   #9
slikdigit
Registered User
 
Join Date: May 2004
Posts: 2
Default Re: Blender 3D freezes with 8-series geforce

I can confirm that I have the same problem on ubuntu hardy. I used to not have the problem with the driver that came with ubuntu gutsy, but it happened on all later versions of the driver.
currently I'm on hardy, and have the bug. Driver version 169.12.1.14
Ubuntu Hardy, Kernel 2.6.24
Quadro FX 570M, 64 Bit Intel dual core CPU, 4 Gig Ram
I believe the gutsy driver I was using was nvidia-glx-new 1.0.9755, which did not cause the problem.
slikdigit is offline   Reply With Quote
Old 08-16-08, 04:25 PM   #10
danieru
Registered User
 
Join Date: Aug 2008
Posts: 1
Default problem fixed in 173.14.12

Hey,
Thanks for the posts. I was having the same problem. I have a GeForce 8400 GS. I installed the latest nvidia driver 173.14.12 and the problem (as of yet) seems to be resolved!
I had trouble trying to install the driver straight from the .run file I got from the nvidia website, but was able to install it easy enough with an app called 'envy'. which will download and install the latest ati/nvidia drivers for you. great little app! just do a search in the ubuntu repository and installing the envy gtk will probably install everything you need. I stumbled across a reference to envy here, and am quite glad I just tried envy before following that huge list of manual steps on the same page!

Cheers

PS. I'm on ubuntu 8.04
danieru is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce 2 freezes system under Direct3D Matthius NVIDIA GeForce 7, 8, And 9 Series 20 06-05-12 02:46 AM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
(PR) Palit Releases New GeForce Series: GeForce GT 630, GT 620 and GT 610 News Archived News Items 0 05-16-12 03:30 AM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 04:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.