Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-05-08, 11:06 AM   #1
Uraeus
Registered User
 
Join Date: Feb 2006
Posts: 8
Default Funky colors with xvideo and 173.14.05

I am running FC9 on my laptop with a GeForce 8400M G card. Using the latest 173.14.05 drivers everything seem to work, except that when playing video using XV instead of Ximage it looks like Blu and Red gets mixed up. Anyone else seing this and it is this a known issue?

Attaching the nvidia script output and a png with a screenshot of the issue.
Attached Thumbnails
Click image for larger version

Name:	nvidia-bug-example.png
Views:	162
Size:	79.7 KB
ID:	31778  
Attached Files
File Type: log nvidia-bug-report.log (114.2 KB, 246 views)
Uraeus is offline   Reply With Quote
Old 06-05-08, 11:29 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Funky colors with xvideo and 173.14.05

I see your screenshot is from mplayer, but have you run Totem, by any chance? http://nvnews.net/vbulletin/showthre...ighlight=totem
AaronP is offline   Reply With Quote
Old 06-06-08, 06:01 AM   #3
Uraeus
Registered User
 
Join Date: Feb 2006
Posts: 8
Default Re: Funky colors with xvideo and 173.14.05

Hi,
Yeah, I was actually testing first with a GStreamer based video-conferencing application (empathy) when I noticed the issue. I attached Totem screenshot with the same blue/red issue here.
Attached Thumbnails
Click image for larger version

Name:	totem-nvidia-blue.jpg
Views:	121
Size:	77.9 KB
ID:	31787  
Uraeus is offline   Reply With Quote
Old 06-06-08, 06:07 AM   #4
Uraeus
Registered User
 
Join Date: Feb 2006
Posts: 8
Default Re: Funky colors with xvideo and 173.14.05

Sorry, read your response to quickly. So yes I had run Totem before and I checked out the thread you posted. Reading the Totem maintainers response in:
http://bugzilla.gnome.org/show_bug.cgi?id=306621

It seems he claims this is a bug in the nvidia driver though and not in Totem.
Uraeus is offline   Reply With Quote
Old 06-06-08, 06:22 AM   #5
memeyou
Registered User
 
Join Date: May 2008
Posts: 74
Default Re: Funky colors with xvideo and 173.14.05

I got this issues the moment I tried F9 - same video driver. So how is this an nvidia issue? Anyway, I just disable xv in totem using gstream-properties and all was well, sorta.
memeyou is offline   Reply With Quote
Old 06-06-08, 10:12 AM   #6
Uraeus
Registered User
 
Join Date: Feb 2006
Posts: 8
Default Re: Funky colors with xvideo and 173.14.05

Honestly I do not who is to blame anymore after reading through the discussions about the issue. Get the feeling that the specification for Xv is a bit underspecified and thus open to interpretation in a range of ways

The thing I do now remember having this issue also with FC8 back in the day, but after altering the hue setting in Totem it of course goes away until the next time you reinstall like I did for FC9
Uraeus is offline   Reply With Quote
Old 06-06-08, 10:33 AM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Funky colors with xvideo and 173.14.05

Quote:
Originally Posted by Uraeus View Post
It seems he claims this is a bug in the nvidia driver though and not in Totem.
It's not, though. The behavior of the hue attribute is the same as it was when NV17 was brand-new, and I'm not about to change it now. All of the drivers I looked at use 0 as the default hue value, and in addition to that, there's a XV_SET_DEFAULTS attribute they can use to reset the defaults.
AaronP is offline   Reply With Quote
Old 08-18-08, 08:12 AM   #8
nullack
Registered User
 
Join Date: Oct 2007
Posts: 74
Default Re: Funky colors with xvideo and 173.14.05

So Aaron were now still at a quandry between you, Gstreamer and Totem. Please refer to:

http://bugzilla.gnome.org/show_bug.cgi?id=306621

Us users are suffering because groups within the stack have been passing blame around since 2005 as to who's at fault and what needs to be done. Can I please, please encourage you to get in contact with the other groups and come to some sort of agreement?

Many thanks
nullack is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:29 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.