Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-22-08, 10:04 AM   #1
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Thumbs down 177.68 with xinerama on is still screwy in dual screen

Using Fedora 9 on a thumb drive for testing.

The good thing about 177.68 is that it now successfully starts X, where an earlier version 177.x wouldn't.

While it appears to work with a single screen, turning on xinerama and running dual screens becomes weird. Some applications simply will not start at all in dual screen, but run fine in single screen mode.

In particular, I can't open "gnome-terminal" in dual screen mode. It simply spins a while then does nothing. Normally I'd open a terminal and execute the app from a command line to see the errors, but I can't open a terminal window.
oldguy is offline   Reply With Quote
Old 08-22-08, 10:07 AM   #2
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: 177.68 with xinerama on is still screwy in dual screen

Quote:
Originally Posted by oldguy View Post
Using Fedora 9 on a thumb drive for testing.

The good thing about 177.68 is that it now successfully starts X, where an earlier version 177.x wouldn't.

While it appears to work with a single screen, turning on xinerama and running dual screens becomes weird. Some applications simply will not start at all in dual screen, but run fine in single screen mode.

In particular, I can't open "gnome-terminal" in dual screen mode. It simply spins a while then does nothing. Normally I'd open a terminal and execute the app from a command line to see the errors, but I can't open a terminal window.
In gnome, press alt+f2, you should get a run terminal. Type xterm, press enter. Type gnome-terminal, press enter. What happens?

Also, a bug report would be handy.
Fackamato is offline   Reply With Quote
Old 08-22-08, 01:13 PM   #3
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: 177.68 with xinerama on is still screwy in dual screen

Quote:
Originally Posted by Fackamato View Post
In gnome, press alt+f2, you should get a run terminal. Type xterm, press enter. Type gnome-terminal, press enter. What happens?

Also, a bug report would be handy.
Thanks! Fortunately xterm does open. From xterm window, I get the following:

gnome-terminal
The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 114 error_code 8 request_code 78 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

gnome-system-monitor
The program 'gnome-system-monitor' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 196 error_code 3 request_code 18 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I've attached (hopefully) the nvidia-bug-report.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (33.3 KB, 100 views)
oldguy is offline   Reply With Quote
Old 08-22-08, 03:05 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 177.68 with xinerama on is still screwy in dual screen

xserver 1.4.99.901 has problems with visual consolidation in Xinerama. Try disabling GLX or upgrading to xserver 1.4.99.905. The driver was supposed to print a warning, but it looks like it didn't for some reason.
AaronP is offline   Reply With Quote
Old 08-25-08, 01:21 PM   #5
oldguy
Registered User
 
Join Date: Dec 2007
Posts: 39
Default Re: 177.68 with xinerama on is still screwy in dual screen

Quote:
Originally Posted by AaronP View Post
xserver 1.4.99.901 has problems with visual consolidation in Xinerama. Try disabling GLX or upgrading to xserver 1.4.99.905. The driver was supposed to print a warning, but it looks like it didn't for some reason.
I did an update to new everything in Fedora 9 and tried it again.

The good news is that I can now open terminal windows in dual screen xinerama.

This is great progress, but attempting to open a few other apps still gives me problems. I tried "gparted", "qtparted", and "hwbrowser" with the following results:

----------------------------

/usr/bin/gparted
No protocol specified
(gpartedbin:3508): Gtk-WARNING **: cannot open display: :0.0
[abcd@localhost ~]$ man gparted
[abcd@localhost ~]$ sudo /usr/bin/gparted /dev/sda
No protocol specified

(gpartedbin:3564): Gtk-WARNING **: cannot open display: :0.0

[abcd@localhost ~]$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/luks-sda2
3.6G 2.7G 849M 77% /
/dev/sda1 198M 19M 170M 10% /boot
tmpfs 1013M 12K 1013M 1% /dev/shm
gvfs-fuse-daemon 3.6G 2.7G 849M 77% /home/abcd/.gvfs

[abcd@localhost ~]$ sudo hwbrowser
No protocol specified
Traceback (most recent call last):
File "/usr/share/hwbrowser/DeviceList.py", line 48, in <module>
import gtk
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in <module>
_init()
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _init
_gtk.init_check()
RuntimeError: could not open display
No protocol specified
Traceback (most recent call last):
File "/usr/share/hwbrowser/DeviceList.py", line 72, in <module>
import gtk
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 79, in <module>
_init()
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 67, in _init
_gtk.init_check()
RuntimeError: could not open display

[abcd@localhost ~]$ qtparted
No protocol specified
qtparted: cannot connect to X server :0.0

-----------------------------------

Here is the new nvidia-bug-report:
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (31.6 KB, 96 views)
oldguy is offline   Reply With Quote
Old 08-25-08, 03:43 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 177.68 with xinerama on is still screwy in dual screen

Quote:
Originally Posted by Xorg.0.log
AUDIT: Mon Aug 25 10:59:59 2008: 2580 X: client 30 rejected from local host ( uid=0 gid=0 pid=3397 )
AUDIT: Mon Aug 25 11:00:17 2008: 2580 X: client 30 rejected from local host ( uid=0 gid=0 pid=3421 )
AUDIT: Mon Aug 25 11:01:08 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3473 )
AUDIT: Mon Aug 25 11:01:46 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3504 )
AUDIT: Mon Aug 25 11:01:46 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3508 )
AUDIT: Mon Aug 25 11:02:39 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3560 )
AUDIT: Mon Aug 25 11:02:39 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3564 )
AUDIT: Mon Aug 25 11:03:06 2008: 2580 X: client 31 rejected from local host ( uid=0 gid=0 pid=3591 )
AUDIT: Mon Aug 25 11:03:06 2008: 2580 X: client 30 rejected from local host ( uid=0 gid=0 pid=3590 )
AUDIT: Mon Aug 25 11:04:01 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3629 )
AUDIT: Mon Aug 25 11:04:01 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3633 )
AUDIT: Mon Aug 25 11:04:01 2008: 2580 X: client 29 rejected from local host ( uid=0 gid=0 pid=3632 )
AUDIT: Mon Aug 25 11:04:46 2008: 2580 X: client 30 rejected from local host ( uid=0 gid=0 pid=3666 )
AUDIT: Mon Aug 25 11:05:15 2008: 2580 X: client 30 rejected from local host ( uid=0 gid=0 pid=3692 )
Looks like your X authentication is messed up. It's odd that the server thinks the uid is 0. Are these programs setuid root? If so, you might need to set XAUTHORITY=/home/abcd/.Xauthority or something. I'd suggest seeking help from the Fedora forums.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.