Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-26-08, 06:45 PM   #1
Txema
Registered User
 
Join Date: Aug 2008
Posts: 50
Default [177.*] Xchat with transparent background crashes

I've just tried to open xchat, and i've got this error message:

Code:
The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadImplementation (server does not implement operation)'.
  (Details: serial 18443 error_code 17 request_code 147 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Then i installed version 173.14.05 (i had this version before upgrading to the beta driver), and it worked perfectly, then it came to my mind that i had enabled the transparent background in xchat, so i reinstalled the beta driver 177.68 and disabled the transparent background in ~/.xchat2/xchat.conf (text_transparent = 0), and it worked magically.

If you need more information just ask for it
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (28.3 KB, 95 views)
Txema is offline   Reply With Quote
Old 08-27-08, 01:41 PM   #2
Txema
Registered User
 
Join Date: Aug 2008
Posts: 50
Default Re: [177.*] Xchat with transparent background crashes

Can anyone reproduce this?
Txema is offline   Reply With Quote
Old 08-27-08, 01:51 PM   #3
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: [177.*] Xchat with transparent background crashes

Yep, exactly the same for me.
Big P is offline   Reply With Quote
Old 08-27-08, 03:02 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: [177.*] Xchat with transparent background crashes

Congratulations, you guys seem to have found the first known casualty of the AllowSHMPixmaps option. This is a bug in xchat (or one of the toolkits it uses). Note that it fails with EXA as well, since EXA doesn't allow SHM pixmaps either.
AaronP is offline   Reply With Quote
Old 08-27-08, 03:34 PM   #5
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: [177.*] Xchat with transparent background crashes

Adam Jackson informed me that he fixed this problem in xchat a while ago, but that the patch hasn't yet been accepted upstream.

See http://cvs.fedoraproject.org/viewvc/...h?revision=1.3
AaronP is offline   Reply With Quote
Old 08-29-08, 02:06 PM   #6
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: [177.*] Xchat with transparent background crashes

Cheers, patch works fine.
Big P is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.