Go Back   nV News Forums > Linux Support Forums > General Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-15-03, 02:36 PM   #1
whit
Registered User
 
Join Date: Aug 2003
Location: VT
Posts: 11
Default unresolved symbols in nvaudio.o

# insmod nvaudio.o
nvaudio.o: unresolved symbol ac97_set_adc_rate_R895c54b6
nvaudio.o: unresolved symbol ac97_probe_codec_R83a75e83
nvaudio.o: unresolved symbol ac97_set_dac_rate_R9120062b

I've rebuilt my (from tar) vanilla 2.4.21 kernel several times, running mrproper in between builds, rebuilding the modules from NVIDIA_nforce-1.0-0261.tar.gz each time, and I always get this precise set of errors, making nvaudio unusable. The NIC works, but the the audio and AGP support in 0261 don't (the latter causes kernel compile failure if enabled - I've posted separately on that).

Anyway, is there some workaround to this one? I'm using gcc version 3.2.3, if that makes a difference - but of course this is the main target version of gcc for kernel development, so I hope nVidia isn't counting on people still using gcc 2.

I also hope nVidia is moving towards releasing as much of its driver code as it possibly can under the GPL, so that community development can get it mature enough avoid the problems so many of us here seem to be running into.

Also, is there supposed to be specific nVidia ide support? I don't see that option in the stock kernel, although I've seen it mentioned here in passing.

Thanks,
Whit
whit is offline   Reply With Quote
Old 08-15-03, 04:03 PM   #2
whit
Registered User
 
Join Date: Aug 2003
Location: VT
Posts: 11
Default The solution to this one

I'd like to thank Vinod Gopalakrishnakurup at nVidia, who responded superhumanly fast to my bug report on this.

It turns out that under Sound Cards in the Linux kernel menu, "Intel ICH (i8xx), SiS 7012, NVidia nForce Audio or AMD 768/811x" has to be selected and installed as a module. Failing to select it at all gives the problem I reported; installing it in the kernel creates an insmod and interrupt error problem, since the nVidia module doesn't check to see if the kernel already supports the features it needs - the standard thing is for modules to look at the kernel first.

I had expected the distributed nVidia module to be self-sufficient - didn't realize it depended on another kernel module already being there. Hopefully this will be noted in the install instructions in the future?

Whit
whit is offline   Reply With Quote
Old 08-17-03, 04:46 PM   #3
Bodhi
Registered User
 
Join Date: Aug 2003
Posts: 8
Default

I'd like to recommend alsa, just compile the alsa-driver package for your system and load the snd-intel8x0 module, you can also load snd-pcm-oss if you want oss compat.
Bodhi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat 7.3 + Geforce 2MX -> unresolved symbol even if recompilation with SYSINCLUDE cool_nm NVIDIA Linux 8 10-13-02 05:57 PM
Redhat 8 + Nvidia 3123 + tarball src rpms = wtf?? caustic NVIDIA Linux 8 10-09-02 09:56 PM
Installing nForce drivers on Debian 3.0 Doink NVIDIA Linux 4 09-14-02 09:34 PM
Linux 2.4.19 unresolved symbols... wallsaroundme NVIDIA Linux 3 08-10-02 09:24 PM

All times are GMT -5. The time now is 09:24 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.