Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-18-03, 02:33 AM   #1
dreamerv3
Geforce 3 ti 500
 
Join Date: Dec 2002
Location: Washington DC
Posts: 27
Default Why does Red hat 9 wait 4 minutes before start up of X?

My comp:

Athlon 1700xp (1400mhz)
Redhat 9(shrike)
Kernel 2.4.20-x
Nvidia geforce 3 ti 500
512mb ram
GNOME Desktop
no gui mods or kernel upgrades since installing RHL9


The computer just sits there for 4 minutes with a blank screen and I'm forced to wait!

Then the nvidia splash screen pops up and then the login screen comes up and boom everything works fine.

Logging out is a royal pain it effectively forces a 4 minute wait everytime I log out to log back in.

Whats the deal is it the drivers or the config of my x11 or gnome desktop?

Anyone got a clue?

Andy can you offer any insight here I'm sure you've gotten this problem from others, I've seen posting of this but no reply, whats the deal?

Edit()
{
Here is my XFree file!

//*******************XFREE*******************

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
#Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "GDM-4011P"
DisplaySize 380 290
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 3 (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

//****************END XFREE****************

}

Last edited by dreamerv3; 08-18-03 at 02:46 AM.
dreamerv3 is offline   Reply With Quote
Old 08-18-03, 10:30 PM   #2
dreamerv3
Geforce 3 ti 500
 
Join Date: Dec 2002
Location: Washington DC
Posts: 27
Default

Are there any faqa or other information about this particular issue?

Have I asked a question to which there is a simple and obvious answer?

Anyone?
dreamerv3 is offline   Reply With Quote
Old 08-19-03, 06:02 AM   #3
mtrr
Registered User
 
Join Date: Jul 2002
Location: Germany
Posts: 234
Send a message via ICQ to mtrr
Default

some people had the same problem, just search the forum,
I think there is even something in the readme. the topic
was something like "x takes a long time to start"


cheers
mtrr is offline   Reply With Quote
Old 08-19-03, 02:31 PM   #4
enemyofthestate
Registered User
 
Join Date: Jan 2003
Posts: 3
Default

Check IgnoreDisplayDevices options. I helped troubleshoot a laptop with a similar poblem and the solution was to add IgnoreDisplayDevices "tv" to the Config. It goes in the Monitor section I think.
enemyofthestate is offline   Reply With Quote
Old 08-19-03, 05:39 PM   #5
mtrr
Registered User
 
Join Date: Jul 2002
Location: Germany
Posts: 234
Send a message via ICQ to mtrr
Default

Device Section


cheers
mtrr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 12:25 PM
red hat distros gadido NVIDIA Linux 3 09-02-02 05:17 PM
Red Hat Linux and Dell Inspiron 8200 haridamineni NVIDIA Linux 3 08-27-02 12:37 PM
Source RPMS for GCC3.2 - Red Hat 8.0? chrisw01 NVIDIA Linux 4 08-21-02 08:17 AM
nVidia drivers + Red Hat Linux 7.3 Error404 NVIDIA Linux 17 08-16-02 11:34 AM

All times are GMT -5. The time now is 10:37 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.