Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-20-08, 03:19 PM   #1
sheytan
Registered User
 
Join Date: Sep 2008
Posts: 7
Default KDE4's Blur plugin problem

THIS IS TO NVIDIA LINUX DRIVER DEVELOPERS:
Hi, I found today that blur plugin in kde4 causes problems with performance and makes black screen when swtiching virtual desktop or using dekstop grind plugin. When i turned it off my KDE runs much much faster with compositing effects. I'm not sure if it's Nvidia's driver problem or Kwin's, but i'm reporting about it here and on kde's bugs site.
sheytan is offline   Reply With Quote
Old 09-20-08, 03:49 PM   #2
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: KDE4's Blur plugin problem

Please provide a nvidia bug report created after the problem occured, and give more detailed information on how to reproduce (versions and steps)

Fuchs
NvFuchs is offline   Reply With Quote
Old 09-20-08, 04:13 PM   #3
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: KDE4's Blur plugin problem

Yeah there is something weird with blur. It also causes the entire screen to shift up 1 pixel (but not the mouse pointer of course). I don't have any non-nVidia machines so I can't compare...
xorbe is offline   Reply With Quote
Old 09-21-08, 05:57 AM   #4
sheytan
Registered User
 
Join Date: Sep 2008
Posts: 7
Default Re: KDE4's Blur plugin problem

That bug is known on bugs.kde.org. I'm using the latest beta drivers. Xorg.conf configuerd using nvidia-xconfig, added some lines like this:

Code:
Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForec 7600GS"
    Option         "RenderAccel" "true"
    Option         "AddARGBGLXVisuals" "true"
    Option         "AllowSHMPixmaps" "0"
EndSection
and:
Code:
Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    Option "PixmapCacheSize" "20000000"
    Option "AllowSHMPixmaps" "0"
    SubSection     "Display"
        Modes      "default"
    EndSubSection
    [...]
EndSection
After xserver started i did:
Code:
nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1
All efects works fine. Just blur makes a crapy lines on desktop and a black screen when switching virtual desk. Even scalling the konsole window when blur is on makes it slooooow.
sheytan is offline   Reply With Quote
Old 09-21-08, 06:49 AM   #5
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: KDE4's Blur plugin problem

Quote:
Originally Posted by NvFuchs View Post
Please provide a nvidia bug report created after the problem occured
No further comment.
NvFuchs is offline   Reply With Quote
Old 09-21-08, 07:07 AM   #6
sheytan
Registered User
 
Join Date: Sep 2008
Posts: 7
Default Re: KDE4's Blur plugin problem

where i can fint it? What report do you mean?
sheytan is offline   Reply With Quote
Old 09-21-08, 07:29 AM   #7
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: KDE4's Blur plugin problem

http://nvnews.net/vbulletin/showthread.php?t=46678

This one. As the thread title suggests, you should read this first when you have a problem.

A nvidia bug report is a plain text file created with the nvidia-bug-report.sh script, containing lots of usefull information (module versions, full Xorg configuration and log, device information, logs of nvidia related errors ...) which helps nvidia to reproduce and solve your problem.

Fuchs
NvFuchs is offline   Reply With Quote
Old 09-21-08, 07:41 AM   #8
sheytan
Registered User
 
Join Date: Sep 2008
Posts: 7
Default Re: KDE4's Blur plugin problem

http://www.sendspace.com/file/nvsyuv here you are.
sheytan is offline   Reply With Quote

Old 09-21-08, 10:29 AM   #9
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: KDE4's Blur plugin problem

Errr, please just attach the log file to a post here, even if you have to gzip it first. Do not send people to a site that they can't actually download your file from without first waiting in a queue, or spending money.

Adam
adamk75 is offline   Reply With Quote
Old 09-21-08, 01:39 PM   #10
sheytan
Registered User
 
Join Date: Sep 2008
Posts: 7
Default Re: KDE4's Blur plugin problem

nvidia-bug-report.log
sheytan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Post working out problem with 40.xx trying to work problem out, ONLY system specs b5fan NVIDIA Windows Graphics Drivers 11 10-19-02 09:17 AM
nv30 problem rumor bob747b Rumor Mill 37 10-10-02 03:14 PM
Geforce 4 Go and X-Server Problem with shutdown rapljenovic NVIDIA Linux 2 08-30-02 10:11 AM
RH7.2 (2.4.9-34) install + src.rpm problem FlyingDutchMan NVIDIA Linux 3 08-08-02 09:04 AM
Nvidia Go on laptop, black border within XFree86 problem raxip NVIDIA Linux 3 07-31-02 10:58 AM

All times are GMT -5. The time now is 05:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.