Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-20-03, 07:37 PM   #1
prtsoft
NVIDIA MX 200
 
Join Date: Jan 2003
Posts: 4
Default OpenGL not working

When ever I try to use a GL game like wolfenstine, ot tuxcart, or tuxracer, they all kill with errors.
Wolf-ET:

ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/Paul/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 4/4/4 Color bits, 16 depth, 0 stencil display.
NV: could not get NV card info (Invalid argument)
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 144
Minor opcode of failed request: 5
Serial number of failed request: 36
ERROR: couldn't create font (glGenLists)
GL_RENDERER: (null)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: Q_strncpyz: NULL src

Tuxracer:

Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

NV: could not get NV card info (Invalid argument)
*** tuxracer error: Couldn't initialize video: Could not create GL context (Success)
Attached Files
File Type: txt xf86config.txt (3.1 KB, 160 views)
prtsoft is offline   Reply With Quote
Old 08-21-03, 05:52 AM   #2
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default DGA?

I check the init of my ET... I don't have a DGA mouse or so... get rid of the DGA extension xfree module!
I give you my XF86Config module section to show you how to disable the dga module
Section "Module"
Load "dbe"
Load "record"
SubSection "extmod"
Option "omit XFree86-DGA"
EndSubSection
Load "glx"
EndSection

BTW... if you still have troubles, don't forget to give us also your xfree log file!
XoD is offline   Reply With Quote
Old 08-21-03, 07:28 AM   #3
prtsoft
NVIDIA MX 200
 
Join Date: Jan 2003
Posts: 4
Default

Ok, I changed that and no go, I run tuxracer, and get the same errors as b4:

Tux Racer 0.61 -- a Sunspire Studios Production (http://www.sunspirestudios.com)
(c) 1999-2000 Jasmin F. Patry <jfpatry@sunspirestudios.com>
"Tux Racer" is a trademark of Jasmin F. Patry
Tux Racer comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to redistribute it under certain conditions.
See http://www.gnu.org/copyleft/gpl.html for details.

Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
*** tuxracer error: Couldn't initialize video: Couldn't find matching GLX visual (Success)

Wolf-ET:

ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/Paul/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsyste


Below is my Xfree86.0.log
Attached Files
File Type: log xfree86.0.log (26.4 KB, 208 views)
prtsoft is offline   Reply With Quote
Old 08-21-03, 08:02 AM   #4
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default GLX not properly loaded

You xfree log tells us that your GLX extension is not loaded properly.
Here is MY xfree log section dealing with the nvidia GLX extension loading:
LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.4496
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1

Then you have to check out presence and type(mesa glx or nvidia glx) of /usr/X11R6/lib/modules/extensions/libglx.so
XoD is offline   Reply With Quote
Old 08-21-03, 08:02 AM   #5
mtrr
Registered User
 
Join Date: Jul 2002
Location: Germany
Posts: 234
Send a message via ICQ to mtrr
Default

two things:

use the latest driver if possible, and make a system update
if you'd looked into your logs a little you would have seen
that on your own.

and I don't know why DGA should be deactivated


cheers
mtrr is offline   Reply With Quote
Old 08-21-03, 08:25 AM   #6
prtsoft
NVIDIA MX 200
 
Join Date: Jan 2003
Posts: 4
Default

OK, I checked, that file exists, but it is a symlink to the old driver, 4363, how to i change it to point to 4496?
prtsoft is offline   Reply With Quote
Old 08-21-03, 08:25 AM   #7
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default DGA or not DGA?

Do you know in more details to the relationship between DGA and the nvidia driver?(I know DRI is useless with those driver, and I'm lazy investigating that right now...).
XoD is offline   Reply With Quote
Old 08-21-03, 08:28 AM   #8
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Check out ALL symlinks

You have to check that all symlinks!
Looks like your driver installation is... stuffed!
XoD is offline   Reply With Quote

Old 08-21-03, 08:49 AM   #9
prtsoft
NVIDIA MX 200
 
Join Date: Jan 2003
Posts: 4
Default Re: Check out ALL symlinks

Quote:
Originally posted by XoD
You have to check that all symlinks!
Looks like your driver installation is... stuffed!
OK, but how do i change them?

BTW:

I had this working, before i copied my old HD over to my new one, now after it is copied, it's doing this...
prtsoft is offline   Reply With Quote
Old 08-21-03, 09:54 AM   #10
XoD
Registered User
 
XoD's Avatar
 
Join Date: Aug 2003
Location: Paris - France
Posts: 101
Default Brute force...

Download the installation binary from nvidia web site and re-install it... brutally...
It should copy the right file and create the right symbolic links.
XoD is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenGL book Airstrip1 Software Development 2 08-12-12 08:55 AM
Nvidia 302.17 OpenGL not working 6200 PCI Archmbc NVIDIA Linux 1 06-18-12 11:23 AM
Major WineX prob... I think it has to do with the vidcard... Linewbie NVIDIA Linux 20 10-09-02 09:58 PM
Option "NvAGP" "0" causes crash w/ OpenGL. mujtaba NVIDIA Linux 5 08-25-02 12:16 PM
Slow OpenGL on 7.3 kl899 NVIDIA Linux 1 08-04-02 07:58 PM

All times are GMT -5. The time now is 03:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.