Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-26-08, 08:34 PM   #1
logan
Registered User
 
Join Date: Aug 2002
Posts: 492
Default black images in 177.x

I mentioned this in the 177.76 OUT !! topic, but never saw a response. By default, Firefox automatically scales down images larger than the viewable area, and they're coming up (mostly) black for me on the first load. I don't know when this started, but 177.70 is when I first noticed it. I've also seen this on smaller inline images, possibly when the width/height attributes don't match the original image size.

http://scr3.golem.de/screenshots/060.../crysis_05.jpg
http://static.computergames.ro/cg/as.../crysis068.jpg
Attached Files
File Type: gz nvidia-bug-report.log.gz (28.5 KB, 79 views)
logan is offline   Reply With Quote
Old 09-26-08, 10:28 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: black images in 177.x

Thanks. Oddly, I can reproduce this problem with both the nvidia and nv drivers, but not with vesa. I'll look into what's going on.
AaronP is offline   Reply With Quote
Old 09-27-08, 11:21 AM   #3
OliW
Registered User
 
Join Date: Sep 2008
Posts: 25
Default Re: black images in 177.x

I'm also getting this when compiz is enabled... I also get poor refreshing in some GTK+ and Qt apps (eg menu entries stay selected even when you mouse-off). Scrolling or forcing a whole-screen refresh (eg initing desktop cube) forces a redraw and everything looks okay again.

I use nvidia-settings -a InitialPixmapPlacement=2 -a GlyphCache=1, but I'm not sure if that's an issue =\

It's only reared its head the last couple of versions.
OliW is offline   Reply With Quote
Old 09-27-08, 12:32 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: black images in 177.x

OliW,
Your problem sounds like an unrelated issue that's caused by a design limitation in the Damage X extension. The problem is that the X server sends Damage events before it has even told the driver to render anything. If the composite manager acts on that information before the rendering has actually happened, it can get stale pixels. It's possible that recent versions of the driver perturbed the timing just enough to make you start running into it.
AaronP is offline   Reply With Quote
Old 09-29-08, 06:45 AM   #5
OliW
Registered User
 
Join Date: Sep 2008
Posts: 25
Default Re: black images in 177.x

Is there a fix for this Aaron? It's not making the system unusable but it's pretty annoying when I can still see old text in editors.

Having a look around the forums, there are a couple of other people that seem to have the same or similar refresh issues but none of the ones I've seen have had an answer on how to fix it.
OliW is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD FX-8120 Black Edition CPU Review (with Asus M5A99X EVO) News Archived News Items 0 06-21-12 08:30 AM
Black Mesa Invites You To Look At Its Bowels News Archived News Items 1 06-12-12 01:05 AM
What Happened To Black Mesa: Source? Part Two News Archived News Items 0 05-10-12 07:47 AM
10 Years of Aqua Satellite's Incredible Images of Earth From Space News Archived News Items 0 05-08-12 07:10 AM
Pre-Purchase Now: Call of Duty®: Black Ops II News Archived News Items 0 05-05-12 02:00 AM

All times are GMT -5. The time now is 04:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.