Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-13-08, 11:58 PM   #1
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Monitor won't go to sleep properly with 9500GT

I am running intrepid alpha6 64bit, and nvidia driver 177.80
I'm using an Asus nvidia EN9500GT PCI-E discrete graphics card. My monitor is a Hanns.G HG281D LCD panel with HDMI and D-SUB inputs.
The graphics card has dvi, hdmi, and d-sub outputs. My monitor only goes to sleep properly when I use the dsub connection. When I connect my monitor to the HDMI or DVI ouputs of the graphics card, the monitor does not go to sleep properly. Instead, the monitor shows a "No Signal Input" message, but I guess it's not a complete loss of signal, because the monitor does not go to sleep.
If I disconnect the cable or turn off the computer then the monitor goes to sleep. I have tried "xset dpms force standby/suspend/off" and they all have the same effect (monitor's own "signal loss" message screen, but monitor never actually goes to sleep).

Some interesting points: Using the "nv" driver does not have this
problem (sleep works properly over both DVI and HDMI connection).

Using a different discrete graphics card (EVGA nvidia 8400GS) I don't have this problem
with either "nv" or nvidia drivers.

I am not using twinview or xinerama, just a single connection to a
single monitor. I also tried disabling compiz, using different window managers, but no luck.

It's also strange that all 3 commands "xset dpms force standby/suspend/off" have the exact same behavior. I'm guessing all 3 options result in the exact same thing done by the nvidia driver.
Some variation would be welcome here, I wish one of the options did what the "nv" driver does
and put my monitor to sleep.
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.6 KB, 141 views)
sordna is offline   Reply With Quote
Old 10-14-08, 11:20 AM   #2
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

I am having the same problem with a 8500GT with Debian Lenny 32-bit, kernel 2.6.26.3
and driver 177.80. Although it is not specific to 177.80; I found the same issues with
all the 169.xx, 173.xx and other 177.xx. The monitor is a Viewsonic LCD VX2835wm.
the Xorg log shows the DPMS is detected and activated. The EDID is probed and the
corrrect mode seems to be chosen.

I am running nearly the same setup with different card (a 5700LE), with no problem
sleeping, etc.

In addition, I found the following odd circumstances: if I use a Samsung 19", there is
no problem. If I let the driver probe the Samsung for EDID and then replug the Viewsonic,
the monitor then sleeps (of course the mode lines are wrong, etc.).

Xorg.0.log is attached.

Any suggestions would be greatly appreciated. I have no idea what else to try . . .
mdweinberg is offline   Reply With Quote
Old 10-14-08, 01:53 PM   #3
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

The attachment failed (because of size?) here is the bug report again, gzipped.
Attached Files
File Type: gz nvidia-bug-report.log.gz (92.9 KB, 142 views)
mdweinberg is offline   Reply With Quote
Old 10-14-08, 08:44 PM   #4
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

Your post about EDID gave me an idea:
I just tried: Option "UseEDID" "False"
and it had a terribly low resolution (also lost HDMI audio) but the monitor can sleep!

I also tried what's documented as equivalent settings to UseEDID False:
Option "UseEDIDFreqs" "False"
Option "UseEDIDDpi" "False"
Option "ModeValidation" "NoEdidModes"
which gave me the same terrible resolution, but the monitor could not sleep.

So, it is something to do with EDID (other than the above 3 individual options),
like the driver misunderstands the monitor's powersave modes or something,
and tries to do a wrong one.

NVIDIA folks, is there an EDID-related option to disable the powersave detection piece
only? Alternatively (or additionally) can you please look into this and fix it in an upcoming
driver release?
sordna is offline   Reply With Quote
Old 10-14-08, 11:39 PM   #5
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Is it possible that the driver is not parsing the EDID block correctly? I unloaded the edid.bin using the
nvidia-settings util and parsed it with parse-edid. It seems to indicate that my monitor is reporting
itself as "dpms off" capable:

parse-edid: parse-edid version 1.4.1
parse-edid: EDID checksum passed.

# EDID version 1 revision 3
Section "Monitor"
# Block type: 2:0 3:ff
# Block type: 2:0 3:fd
# Block type: 2:0 3:fc
Identifier "VX2835wm"
VendorName "VSC"
ModelName "VX2835wm"
# Block type: 2:0 3:ff
# Block type: 2:0 3:fd
HorizSync 30-82
VertRefresh 50-76
# Max dot clock (video bandwidth) 150 MHz
# Block type: 2:0 3:fc
# DPMS capabilities: Active off:yes Suspend:no Standby:no

Mode "1920x1200" # vfreq 59.950Hz, hfreq 74.038kHz
DotClock 154.000000
HTimings 1920 1968 2000 2080
VTimings 1200 1203 1209 1235
Flags "-HSync" "+VSync"
EndMode
# Block type: 2:0 3:ff
# Block type: 2:0 3:fd
# Block type: 2:0 3:fc
EndSection

I wonder if some inconsitency is causing confusion?
mdweinberg is offline   Reply With Quote
Old 10-15-08, 10:34 AM   #6
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Yes, I recalled that I can check the DFP parsing by setting the verbosity level (in this case I set
it to 10). The driver reports that "off" is an active DPMS mode. I repeated and corroborate all
of your UseEDID and etc. tests. In addition, I tried to shut off all EDID probing and set the freqs
and modeline myself. However, the driver rejects the native resolution mode saying that that no
DFP timing is available to check it. I would think there would be a way to provide the necessary
info . . . what am I missing?
mdweinberg is offline   Reply With Quote
Old 10-15-08, 12:15 PM   #7
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by mdweinberg View Post
Yes, I recalled that I can check the DFP parsing by setting the verbosity level (in this case I set
it to 10). The driver reports that "off" is an active DPMS mode. I repeated and corroborate all
of your UseEDID and etc. tests. In addition, I tried to shut off all EDID probing and set the freqs
and modeline myself. However, the driver rejects the native resolution mode saying that that no
DFP timing is available to check it. I would think there would be a way to provide the necessary
info . . . what am I missing?
I disabled edid (see on my thread), I left click on the desktop wallpaper on KDE3 => configure desktop => display => power control, then I set the sleep time.

Here the monitor sleep properly with DPMS checked on sax2
marchetto is offline   Reply With Quote
Old 10-15-08, 12:33 PM   #8
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

I tried that earlier. All the modes are then rejected by the internal driver mode of 640x480
or 800x600. There seems to be no way to manually specify the native resolution of the
panel without EDID.
mdweinberg is offline   Reply With Quote

Old 10-15-08, 02:53 PM   #9
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by mdweinberg View Post
I tried that earlier. All the modes are then rejected by the internal driver mode of 640x480
or 800x600. There seems to be no way to manually specify the native resolution of the
panel without EDID.
You can force it, but it involves adding a modeline, for my 1920x1200 LCD monitor this modeline (got from http://ubuntuforums.org/archive/index.php/t-401556.html) works:
Modeline "1920x1200_60.00" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +Hsync -Vsync
Unfortunately tools like gtf or http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
were unable to give me a Modeline with a 154Mhz pixel clock at 60Hz that my monitor needs.

Apart from the mode line, to force a resolution without EDID you also need to add stuff like:
Option "ModeValidation" "NoMaxPClkCheck"
Option "ExactModeTimingsDVI" "True"
Modes "1920x1200"
Option "ModeValidation" "string"

Another option you may or may not need to force a resolution is:
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Let me know if you are able to force your resolution with the above options.
Look here for more info:
http://us.download.nvidia.com/XFree8...ModeValidation

By the way, I'm working on editing my EDID file and changing the DPMS values.
It's very promising.
Please use nvidia-settings -> aquire EDID and attach the generated edid.bin files for both your monitors.
I can take the power setting from one edid file and put it on the other.
sordna is offline   Reply With Quote
Old 10-15-08, 10:18 PM   #10
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

NVIDIA folks, I narrowed down the problem to the HDMI audio!
If I modify the EDID and zero out one or two bytes from the 2nd 128byte block
to get the HDMI audio disabled (I discovered the relevant byte offsets it via trial and error)
then the monitor goes to sleep. Since we are observing the issue in 2 different monitors, it looks
like a driver issue.
Possibly, the solution is: upon initiating powersave, before shutting off the video signal,
the driver should should shut off the SPDIF audio signal. Upon ending the powersave,
the driver should enable the SPDIF audio signal after the video signal is restored.

I am available to try a development driver to test this for you.

I have attached a tarfile that includes the original and modified edid files for my monitor (includes hex editor (actually vim) text dumps to see the difference).

Please respond.

Thanks,
sordna
Attached Files
File Type: gz hg281d-edids.tar.gz (948 Bytes, 165 views)
sordna is offline   Reply With Quote
Old 10-16-08, 10:02 AM   #11
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by sordna View Post
You can force it, but it involves adding a modeline, for my 1920x1200 LCD monitor this modeline (got from http://ubuntuforums.org/archive/index.php/t-401556.html) works:
Modeline "1920x1200_60.00" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 +Hsync -Vsync
Unfortunately tools like gtf or http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
were unable to give me a Modeline with a 154Mhz pixel clock at 60Hz that my monitor needs.

Apart from the mode line, to force a resolution without EDID you also need to add stuff like:
Option "ModeValidation" "NoMaxPClkCheck"
Option "ExactModeTimingsDVI" "True"
Modes "1920x1200"
Option "ModeValidation" "string"

Another option you may or may not need to force a resolution is:
Option "ModeValidation" "NoDFPNativeResolutionCheck"

Let me know if you are able to force your resolution with the above options.
Look here for more info:
http://us.download.nvidia.com/XFree8...ModeValidation

By the way, I'm working on editing my EDID file and changing the DPMS values.
It's very promising.
Please use nvidia-settings -> aquire EDID and attach the generated edid.bin files for both your monitors.
I can take the power setting from one edid file and put it on the other.
Thanks!!!! That works for me. Sleep is back.

I did not know about the ExactModeTimingsDVI and that was my problem.

BTW, I got out my hexeditor and made the same changes to my edid.bin and used CustomEDID to
try it. But that did not seem to make a difference.
mdweinberg is offline   Reply With Quote
Old 10-16-08, 10:11 AM   #12
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by sordna View Post
By the way, I'm working on editing my EDID file and changing the DPMS values.
It's very promising.
Please use nvidia-settings -> aquire EDID and attach the generated edid.bin files for both your monitors.
I can take the power setting from one edid file and put it on the other.
I dumped the edid.bin from both monitors and they are identical. So it seems that the driver + hardware
combo also matters, not just the edid. FYI, here is the edid from the viewsonic montor.
Attached Files
File Type: gz edid.bin.gz (229 Bytes, 148 views)
mdweinberg is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.