Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-16-08, 10:24 AM   #13
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by sordna View Post
NVIDIA folks, I narrowed down the problem to the HDMI audio!
If I modify the EDID and zero out one or two bytes from the 2nd 128byte block
to get the HDMI audio disabled (I discovered the relevant byte offsets it via trial and error)
then the monitor goes to sleep. Since we are observing the issue in 2 different monitors, it looks
like a driver issue.
Possibly, the solution is: upon initiating powersave, before shutting off the video signal,
the driver should should shut off the SPDIF audio signal. Upon ending the powersave,
the driver should enable the SPDIF audio signal after the video signal is restored.

I am available to try a development driver to test this for you.

I have attached a tarfile that includes the original and modified edid files for my monitor (includes hex editor (actually vim) text dumps to see the difference).

Please respond.

Thanks,
sordna
Interesting!! I'll mention a possibly related observation. The Viewsonic VX2835wm has a separate
audio input which I have tried to use and I'm using DVI->HDMI. When the edid is enabled, the
audio on the Viewsonic VX2835wm does not work. With UseEDID false, the audio works. I had
assumed that this was an intrinsic "feature" of using DVI->HDMI at the hardware level in the monitor.
Apparently the NVidia <==> Monitor interaction is a bit deeper. Is the audio being intentionally or
accidentally disabled?
mdweinberg is offline   Reply With Quote
Old 10-16-08, 10:44 AM   #14
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

My guess is: if the EDID reports HDMI audio, then the driver enables it (and apparently the monitor disables the analog audio input).

I think nvidia-settings should provide an option to enable/disable HDMI audio, so users can choose.

Anyway, please attach the viewsonic's edid.bin and I can modify it to disable the HDMI audio,
update the checksum, and attach it back to you. It will be a good test.
You can then tell xorg to load that one, instead of pull it from the monitor:
Option "CustomEDID" "DFP-1:/etc/X11/edid.bin"
sordna is offline   Reply With Quote
Old 10-16-08, 12:35 PM   #15
mdweinberg
Registered User
 
Join Date: Oct 2008
Posts: 9
Default Re: Monitor won't go to sleep properly with 9500GT

Actually, I just went ahead and made the edits myself, zero out the same bytes that you did,
updating the checksum, and using CustomEDID. It works like a charm!!

You seem to have nailed the problem!!

Last edited by mdweinberg; 10-16-08 at 01:09 PM. Reason: Additional information
mdweinberg is offline   Reply With Quote
Old 10-16-08, 03:59 PM   #16
sordna
Registered User
 
Join Date: Oct 2008
Posts: 10
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by mdweinberg View Post
Actually, I just went ahead and made the edits myself, zero out the same bytes that you did,
updating the checksum, and using CustomEDID. It works like a charm!!

You seem to have nailed the problem!!
Thanks. Only problem for me is I want to keep my HDMI audio working.
Anyway, the next step is for an NVIDIA engineer to pick up this issue in the driver,
hopefully soon. We've provided lots of good info/testing for them in this thread,
not sure what else we can do to grab a developer's attention.
sordna is offline   Reply With Quote
Old 10-28-08, 05:40 PM   #17
kanttu
Registered User
 
Join Date: Sep 2006
Posts: 16
Default Re: Monitor won't go to sleep properly with 9500GT

You're my heroes of today since this fixed by problem which was bad colors and minor image corruption: http://www.nvnews.net/vbulletin/show....php?p=1825207

kanttu is offline   Reply With Quote
Old 01-08-09, 07:46 AM   #18
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Monitor won't go to sleep properly with 9500GT

My monitor now won't sleep!!!
I updated to SuSE 11.1 with kde4.

It's a nvidia driver bug I think... or not?
marchetto is offline   Reply With Quote
Old 01-12-09, 06:22 AM   #19
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Monitor won't go to sleep properly with 9500GT

Quote:
Originally Posted by sordna View Post
My guess is: if the EDID reports HDMI audio, then the driver enables it (and apparently the monitor disables the analog audio input).

I think nvidia-settings should provide an option to enable/disable HDMI audio, so users can choose.

Anyway, please attach the viewsonic's edid.bin and I can modify it to disable the HDMI audio,
update the checksum, and attach it back to you. It will be a good test.
You can then tell xorg to load that one, instead of pull it from the monitor:
Option "CustomEDID" "DFP-1:/etc/X11/edid.bin"
I've got an LCD Samsung T200 monitor I can't understand what's DFP, is DFP right for me?
marchetto is offline   Reply With Quote
Old 02-01-09, 09:15 AM   #20
Rogues32
Registered User
 
Join Date: Feb 2009
Posts: 1
Default Re: Monitor won't go to sleep properly with 9500GT

I've needed this for quite some time now. I have a Hanns G HG281DJB that won't go to sleep when I turn off the laptop (HP 9535nr with Nvidia GeForce 8600M GS) it's attached to via HDMI. Sounds like disabling HDMI audio in the EDID is the solution. I've go

Unfortunately, I just discovered what EDID is today. Don't have an editor, found a few free readers. Would be really glad if you guys could give me directions on how to edit it.
Rogues32 is offline   Reply With Quote

Old 03-03-09, 03:15 PM   #21
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Monitor won't go to sleep properly with 9500GT

Now with 180.35 it goes to sleep, but it takes about 10 seconds to get back when I move the mouse...
marchetto is offline   Reply With Quote
Old 04-26-10, 09:01 PM   #22
tvynr
Registered User
 
Join Date: Apr 2010
Posts: 1
Default Re: Monitor won't go to sleep properly with 9500GT

+1 for this! Just fixed the GeForce 210 I recently bought to replace a GeForce 7300. The 7300 didn't have this problem but the 210 did. For those curious, here are the steps I used:

1. Use nvidia-settings to extract the EDIDs for the monitor. (Acquire EDID button in the section about your monitor under GPU N.)
2. Open nvidia-settings using your favorite hex editor.
3. In position 0x18 (decimal position 24), you will likely find that the first three bits of the value there are zero. (Mine was 0x0a.) Change them to ones. (In my case, 0xea.)
4. Save the edid.bin somewhere like /etc/X11/fixed-edid.bin
5. Add the following to the Devices section of your /etc/X11/xorg.conf:

Code:
Option         "CustomEDID" "/etc/X11/fixed-edid.bin"
Restart your X server and everything should be go. Wikipedia has a good reference on the EDID binary format here: http://en.wikipedia.org/wiki/EDID

Warning: if you don't understand any of the steps above, learn about things like hex editing and binary before you try to execute them. I have no idea what would happen if you forced the driver to use a messed up EDID binary.

Thanks again!
tvynr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:45 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.