Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-31-02, 07:14 AM   #1
krow
Registered User
 
Join Date: Aug 2002
Posts: 5
Question Can't get FSAA to work

Hi
I've got the NVidia driver working, but FSAA won't work. I set the environment variable with "export __GL_FSAA_MODE=4", and check it by typing "env", but when I run a game there's no antialiasing.

Hardware: GeForce4 Ti4400
Software: Debian Woody
Linux 2.4.19
NVidia driver 1.0-2960
Tux Racer 0.61-6
Unreal Tournament 436
(no more 3D games in Linux yet)

Both the games work nicely with hardware acceleration, but they don't antialias.
Can anyone help? Thanks in advance.
krow is offline   Reply With Quote
Old 08-31-02, 02:54 PM   #2
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

I hope you understand how environment variables work. When you change an environment variable on linux the changed variable is only valid for the current shell you are using and all its clients.

So for example you set an environment variable in a gnome terminal. Then you launch an app from a different terminal or using a shortcut. In these two cases both apps don't know about those variables.

When you would start an app in the same terminal in which you set the variable it would work fine.

There are two good places to put nvidia environment variables like __GL_FSAA_MODE in. You can put it in your .bashrc. Then those variables will be set for each bash shell you launch.

Or another option would be to use a startup script to start a game. Then you can add those environment variables to the startup script. After you quit the app the variable is unset. Using this you can use different settings for different games.
Thunderbird is offline   Reply With Quote
Old 09-01-02, 06:44 AM   #3
krow
Registered User
 
Join Date: Aug 2002
Posts: 5
Default

I've already tried setting the environment variable in /etc/profile, and in a shell script which I use to launch the game:

#!/bin/bash
export __GL_FSAA_MODE=4
/usr/local/games/ut/ut

Is there anything else that I might be doing wrong?
krow is offline   Reply With Quote
Old 09-01-02, 08:25 AM   #4
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default

I would set the game at 640x480 and then compare with and without. At this resolution you should see the difference.
Thunderbird is offline   Reply With Quote
Old 09-01-02, 02:53 PM   #5
krow
Registered User
 
Join Date: Aug 2002
Posts: 5
Default

Here are cropped screenshots of Unreal Tournament to demonstrate the problem.
Top: Linux, setting 4x antialiasing with the environment variable (software described in my first post)
Bottom: Windows, setting 4x antialiasing with the NVidia system tray applet (WinME, NVidia driver 30.82, UT 436, OpenGL)

I'm probably just making some stupid mistake... I'm sure I'm setting the environment variable properly though.

Oh, btw, both those shots are from the same computer.

Attached Thumbnails
Click image for larger version

Name:	ut-shots.png
Views:	559
Size:	66.6 KB
ID:	196  

Last edited by krow; 09-15-02 at 02:50 PM.
krow is offline   Reply With Quote
Old 09-15-02, 02:31 PM   #6
krow
Registered User
 
Join Date: Aug 2002
Posts: 5
Cool It works

I just recompiled the kernel to add some unrelated drivers. After recompliling the kernel I needed to reinstall the NVidia kernel driver. I had already tried reinstalling the kernel driver, but that didn't help.

Today I accidentally reinstalled the NVidia GLX kernel as well as the kernel driver, and now FSAA has started working!

Unfortunately I have no idea how to recreate the problem :-/

anyway, here's a screenshot of 4x antialiased tux racer to celebrate

Attached Thumbnails
Click image for larger version

Name:	tux_sshot_0.png
Views:	510
Size:	85.2 KB
ID:	253  

Last edited by krow; 09-15-02 at 03:42 PM.
krow is offline   Reply With Quote
Old 09-17-02, 08:03 AM   #7
krow
Registered User
 
Join Date: Aug 2002
Posts: 5
Default

Sorry about all this spam, but today I upgraded my xlibmesa3 package, and fsaa stopped again. Reinstalling the NVidia GLX driver fixed it. So, I must have broken the GLX driver by installing new distribution packages and failing to reinstall the NVidia driver.
krow is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keep up the good work NVIDIA! cheechr1 NVIDIA Linux 3 11-06-12 12:18 AM
Ask Stack: What is the best way to divide work between developers? News Archived News Items 0 06-10-12 02:10 AM
295.40 Does not Work Had to downgrade to 295.33 Archmbc NVIDIA Linux 4 05-03-12 02:38 PM
do 3d glasses really work? Gator General Hardware 19 12-30-02 04:39 AM
FSAA not working with 2.4.18-10 and 1.0-3123 perryd NVIDIA Linux 5 09-20-02 10:22 PM

All times are GMT -5. The time now is 07:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.