Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-14-08, 12:55 PM   #1
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default mplayer vdpau

Well I had some time and compiled mplayer with the given script but I get the following:

VDec: vo config request - 1280 x 720 (preferred colorspace: VC1 ADVANCED VDPAU acceleration)
VDec: using VC1 ADVANCED VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 VC1 ADVANCED VDPAU acceleration [zoom]
Error at libvo/vo_vdpau.c:637

and mplayer crashes. Is this because of my gcc version 4.3.2 ?
gbil is offline   Reply With Quote
Old 11-14-08, 01:03 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: mplayer vdpau

Possibly. I had poor luck with Debian's gcc-4.3.2 when I experimented with mplayer/vdpau on my system at home yesterday. I found gcc-3.4.6 worked better. I'm told that gcc-4.3.2 has worked well for others, though. Note that mplayer/vdpau are still early development versions, so it's possible that the error you're seeing is a bug/limitation.
zander is offline   Reply With Quote
Old 11-14-08, 01:11 PM   #3
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: mplayer vdpau

Certain clips still have trouble playing (i.e. H.264 videos above level 4.1). Did you try the example videos from the README? Those are known to work at least in certain cases.

Quote:
Example Movie Clips:
MPEG: http://inventaaustralia.zftp.com.nyu...3MBPS30sec.mpg
./mplayer -vo vdpau -vc ffmpeg12vdpau MPEGIO3MBPS30sec.mpg

H.264: http://samples.mplayerhq.hu.nyud.net...4/PAFF/Grey.ts
./mplayer -vo vdpau -vc ffh264vdpau Grey.ts
http://samples.mplayerhq.hu.nyud.net...1500kbits.h264
./mplayer -vo vdpau -vc ffh264vdpau nature_704x576_25Hz_1500kbits.h264

WMV3: http://download.microsoft.com.nyud.n..._Caves_720.exe
(use `unzip` to extract the .exe)
./mplayer -vo vdpau -vc ffwmv3vdpau Amazing_Caves_720.wmv

VC-1: http://samples.mplayerhq.hu.nyud.net..._51_15Mbps.wmv
./mplayer -vo vdpau -vc ffvc1vdpau FlightSimX_720p60_51_15Mbps.wmv
Plagman is offline   Reply With Quote
Old 11-14-08, 01:20 PM   #4
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: mplayer vdpau

Quote:
Originally Posted by Plagman View Post
Certain clips still have trouble playing (i.e. H.264 videos above level 4.1). Did you try the example videos from the README? Those are known to work at least in certain cases.
Tried VC1 and WMV samples, same result.

Could it also be that I use twinview ?

EDIT: Nope, same thing without twinview. Possibly a compiler or bug in the code I guess.
gbil is offline   Reply With Quote
Old 11-14-08, 01:24 PM   #5
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: mplayer vdpau

What's your GPU?
Plagman is offline   Reply With Quote
Old 11-14-08, 01:25 PM   #6
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: mplayer vdpau

Quote:
Originally Posted by gbil View Post
Tried VC1 and WMV samples, same result.

Could it also be that I use twinview ?
Try MPEG-1/2 or H264.

The patch marks VC1 and WMV3 "status buggy" while H264 and MPEG-1/2 as "status working" in codecs.conf (might be a reason behind that )
Dragoran is offline   Reply With Quote
Old 11-14-08, 01:41 PM   #7
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: mplayer vdpau

Quote:
Originally Posted by Dragoran View Post
Try MPEG-1/2 or H264.

The patch marks VC1 and WMV3 "status buggy" while H264 and MPEG-1/2 as "status working" in codecs.conf (might be a reason behind that )
Yep that was the problem, MPEG and H264 played fine.

First impressions:

MPEG: - normal mplayer with xv output used about 10% cpu
- mplayer with vdpau and relative coded used about 3% cpu

H264: - normal mplayer used about 66% cpu
- mplayer with vpdau used *just* 10% !!!!!!!!!!!!

That's a hell of a difference! Can't wait to see the patches in mainline mplayer


BTW, I have 2 x 8800GT 512MB cards.
gbil is offline   Reply With Quote
Old 11-14-08, 01:52 PM   #8
Plagman
NVIDIA Corporation
 
Plagman's Avatar
 
Join Date: Sep 2007
Posts: 254
Default Re: mplayer vdpau

Your GPUs don't support VC-1/WMV3 playback; from the sticky:

Quote:
VC-1 support in NVIDIA's VDPAU implementation currently requires GeForce
9300 GS, GeForce 9200M GS, GeForce 9300M GS, or GeForce 9300M GS.
Plagman is offline   Reply With Quote

Old 11-14-08, 01:53 PM   #9
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: mplayer vdpau

Quote:
Originally Posted by Plagman View Post
Your GPUs don't support VC-1/WMV3 playback; from the sticky:
Somehow I missed that !!!
gbil is offline   Reply With Quote
Old 11-14-08, 02:01 PM   #10
jcornwall
Registered User
 
Join Date: Aug 2007
Location: Austin, TX
Posts: 120
Default Re: mplayer vdpau

The 8800 GTX isn't supported?

It's not even that old.
jcornwall is offline   Reply With Quote
Old 11-14-08, 02:20 PM   #11
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: mplayer vdpau

Unfortunately, the original (G80 based) GeForce 8800 GTX does not have the necessary video hardware.
zander is offline   Reply With Quote
Old 11-14-08, 02:23 PM   #12
txf
Registered User
 
Join Date: Feb 2008
Posts: 272
Default Re: mplayer vdpau

Quote:
Originally Posted by jcornwall View Post
The 8800 GTX isn't supported?

It's not even that old.
Isn't that card the very first 8 series to come out? That card does not have a hardware purevideoHD decoder, which is probably why it isn't on that list.
txf is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 12:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.