Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-15-08, 07:32 PM   #1
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Acer AX1200, with GeForce 8200.

Ubuntu 8.10

In debug I have also installed the latest alsa (18a) and nvidia drivers (180.16).

Video works like a champ. I can't get a sound out of it under Ubuntu to save my life.

Audio over HDMI works fine under Windows Vista.

aplay -l yields

Quote:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
alsamixer shows


-Master
-Headphones
-PCM
-Front
-Front Mic
-Front Mic Boost
-Surround
-Center
-Lfe
-Line
-Mic
-Mic Boost
-IEC958
-IEC958 D

I am _not_ a unix expert.. but was able to do the above compiles, installs... very happily will follow directions, small words & steps appreciated. It is very possible I botched something during the alsa/nvidia driver upgrades, but they both seem to work at least as well as the previous versions.

nvidia log attached.

I've read several other threads here and elsewhere of related issues, but cannot get it to work. There are at least 2 threads about this on the alsa-users mailing list. I guess partly I don't know how to isolate the problem to which piece of the chain.

Any help is much appreciated.

Mike
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.2 KB, 160 views)
zim2dive is offline   Reply With Quote
Old 12-16-08, 03:11 AM   #2
magho
Registered User
 
Join Date: Dec 2005
Posts: 13
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Hmm, that should have worked. Are you sure the new alsa kernel modules are loaded? What do you get from:
cat /proc/asound/version
?
magho is offline   Reply With Quote
Old 12-16-08, 06:13 AM   #3
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Quote:
Originally Posted by magho View Post
Hmm, that should have worked. Are you sure the new alsa kernel modules are loaded?
I freely admit I'm not 100% sure of anything at this point
Quote:
What do you get from:
cat /proc/asound/version
?
I get

Quote:
~$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.18a.
Compiled on Dec 15 2008 for kernel 2.6.27-9-generic (SMP).
zim2dive is offline   Reply With Quote
Old 12-16-08, 07:38 AM   #4
magho
Registered User
 
Join Date: Dec 2005
Posts: 13
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Ok, this seems like something for the Alsa mailing list. What do you get from:
lspci
in terms of nvidia chips? I have MCP78S.
magho is offline   Reply With Quote
Old 12-16-08, 07:57 AM   #5
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Quote:
Originally Posted by magho View Post
Ok, this seems like something for the Alsa mailing list. What do you get from:
lspci
in terms of nvidia chips? I have MCP78S.
00:00.0 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a2)
00:01.0 ISA bridge: nVidia Corporation MCP78S [GeForce 8200] LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP78S [GeForce 8200] SMBus (rev a1)
00:01.2 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:01.3 Co-processor: nVidia Corporation MCP78S [GeForce 8200] Co-Processor (rev a2)
00:01.4 RAM memory: nVidia Corporation MCP78S [GeForce 8200] Memory Controller (rev a1)
00:02.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:04.0 USB Controller: nVidia Corporation MCP78S [GeForce 8200] OHCI USB 1.1 Controller (rev a1)
00:04.1 USB Controller: nVidia Corporation MCP78S [GeForce 8200] EHCI USB 2.0 Controller (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP78S [GeForce 8200] IDE (rev a1)
00:07.0 Audio device: nVidia Corporation Realtek ALC1200 8-Channel High Definition Audio Codec (rev a1)
00:08.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Bridge (rev a1)
00:09.0 SATA controller: nVidia Corporation MCP78S [GeForce 8200] AHCI Controller (rev a2)
00:0a.0 Ethernet controller: nVidia Corporation MCP78S [GeForce 8200] Ethernet (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:12.0 PCI bridge: nVidia Corporation MCP78S [GeForce 8200] PCI Express Bridge (rev a1)
00:13.0 PCI bridge: nVidia Corporation Device 077a (rev a1)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation GeForce 8200 (rev a2)
04:00.0 Network controller: RaLink Device 0781
05:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. Device 3403
zim2dive is offline   Reply With Quote
Old 12-16-08, 08:30 AM   #6
magho
Registered User
 
Join Date: Dec 2005
Posts: 13
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Same chipset as I have, same distribution, same kernel, same alsa kernel modules.... I'm lost here. You "should" get the HDMI device with aplay -l.
magho is offline   Reply With Quote
Old 12-16-08, 09:12 AM   #7
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

Quote:
Originally Posted by magho View Post
Same chipset as I have, same distribution, same kernel, same alsa kernel modules.... I'm lost here. You "should" get the HDMI device with aplay -l.
So I should have a Device 2 (or 3) ?

You also upgraded your alsa and nvidia drivers from the base install?

thanks,
Mike
zim2dive is offline   Reply With Quote
Old 12-16-08, 09:29 AM   #8
magho
Registered User
 
Join Date: Dec 2005
Posts: 13
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

You should have:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

I installed from ftp://ftp.alsa-project.org/pub/drive....0.18a.tar.bz2 and ftp://download.nvidia.com/XFree86/Li...80.16-pkg1.run on top of standard ubuntu 8.10.
magho is offline   Reply With Quote

Old 12-16-08, 11:15 AM   #9
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: No HDMI audio, GeForce 8200, Acer AX1200, 180.16

somehow your 18a is better than the 18a I installed ?!!?!?

anyway I now get
Quote:
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
Now to figure out how to make this the default audio path (or if I have to specify to every tool)

many thanks!!
zim2dive is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
Nvidia GeForce 301.42 WHQL drivers DSC NVIDIA Windows Graphics Drivers 5 05-29-12 10:12 PM
HDMI audio ELD weirdness RockHound NVIDIA Linux 0 05-11-12 03:45 AM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 10:21 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.