Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-18-08, 09:14 PM   #1
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Installation issue: 32bit libs in 64bit sytem

I get the following warnings while installing the driver (180.16):

WARNING: Unable to restore symbolic link /usr/lib/libGL.so -> libGL.so.1 (File exists).
WARNING: Unable to restore symbolic link /usr/lib/libGL.so.1 -> libGL.so.1.2 (File exists).

When the installer exits there are no /usr/lib/libGL.*
So I have to reinstall Mesa-32bit again to restore the files.


Anybody knows the cause of this? Can it be solved manually? How the nvidia-installer creates 32bit libraries out of 64bit ones? I can't see 32 bit files bundled with the installer.
DeiF is offline   Reply With Quote
Old 12-18-08, 11:58 PM   #2
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Installation issue: 32bit libs in 64bit sytem

DeiF,

Which file did you use to install? You need to use NVIDIA-Linux-x86_64-180.16-pkg2.run (note "pkg2" not "pkg1" or "pkg0")
Stephen Warren is offline   Reply With Quote
Old 12-19-08, 06:35 AM   #3
DeiF
Registered User
 
Join Date: Oct 2008
Posts: 114
Default Re: Installation issue: 32bit libs in 64bit sytem

Ok, thanks, that solved the problem. I always thought that the only difference between pkg0, pkg1, pkg2, etc. was different precompiled kernel modules.
DeiF is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.