Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-19-08, 10:44 AM   #1
jegjessing
Registered User
 
Join Date: Nov 2008
Posts: 2
Default NVidia 8800 GTX and openSUSE 11.1

Hi. After installing openSuSE 11.1 X crashes after a random period of time. But I can be sure that it crashes, if composite is enabled that is.
I mentioned this on bugs.opensuse.org, but they told me to file a request at nvidia, so here I am.
Since I do not use Gnome, I dont know if the problem is here too, but the problem is definetivelly when using KDE.
I have set all the options recomended by various threads, but no luck
I'm using 180.08 at the moment. But the same problem exists in 177,80 and 173.14.15

Thanks in advance
Just read the READ THIS... thingy. Will attach a log as soon as I crash :-)
jegjessing is offline   Reply With Quote
Old 11-27-08, 02:35 AM   #2
jegjessing
Registered User
 
Join Date: Nov 2008
Posts: 2
Default Re: NVidia 8800 GTX and openSUSE 11.1

I just installed opensuse 11.1-RC1 nd can reproduce the error each time I rightclick on the desktop and select Desktop Setting. And then Theme.
Had to compress the loggfile using bzip2 because filesize was > 100k hope its ok?
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (38.6 KB, 184 views)
jegjessing is offline   Reply With Quote
Old 12-22-08, 12:04 AM   #3
vanRijn
Registered User
 
Join Date: Oct 2007
Posts: 9
Default Re: NVidia 8800 GTX and openSUSE 11.1

Just wanted to say that I'm seeing this now too and it is _supremely_ irritating. I just installed OpenSUSE 11.1 and KDE 4.2/trunk packages and am seeing the same thing with X crashing hard randomly and regularly. Also, for some reason, X takes a REALLY long time to restart using nVidia's drivers and kdm ends up timing out and failing hard when I logout. Has anyone figured out what's going on here?
vanRijn is offline   Reply With Quote
Old 12-22-08, 01:44 PM   #4
sshaw
Registered User
 
Join Date: Jan 2005
Posts: 3
Default Re: NVidia 8800 GTX and openSUSE 11.1

Are you running compiz? I've heard, noticed, that some compiz plugins are causing hard locked and X crashes. I just upgraded to cyberorb's git repo rpms and haven't seen any crashes. I do get really bad repainting issues with compiz and nvidia. I'm using the current stable drivers as suspend is break in the current alpha drivers.
sshaw is offline   Reply With Quote
Old 12-22-08, 06:05 PM   #5
vanRijn
Registered User
 
Join Date: Oct 2007
Posts: 9
Default Re: NVidia 8800 GTX and openSUSE 11.1

Quote:
Originally Posted by sshaw View Post
Are you running compiz? I've heard, noticed, that some compiz plugins are causing hard locked and X crashes. I just upgraded to cyberorb's git repo rpms and haven't seen any crashes. I do get really bad repainting issues with compiz and nvidia. I'm using the current stable drivers as suspend is break in the current alpha drivers.
Hi sshaw, no, I'm not using compiz. This is happening to me using KDE4.
vanRijn is offline   Reply With Quote
Old 12-22-08, 07:02 PM   #6
conky
Registered User
 
Join Date: Nov 2007
Posts: 70
Default Re: NVidia 8800 GTX and openSUSE 11.1

Turn BackingStore off in your xorg.conf. I was having crashes in kde4.1 with it turned on. Turning it off fixed my problems. I'm currently running KDE 4.2 beta 2 with driver 180.16 and have no problems.
conky is offline   Reply With Quote
Old 12-22-08, 07:28 PM   #7
vanRijn
Registered User
 
Join Date: Oct 2007
Posts: 9
Default Re: NVidia 8800 GTX and openSUSE 11.1

@conky: awesome, thank you!!! Actually, I've updated to KDE 4.2 beta2 again (with trepidation, I might add), and I left my xorg.conf alone, just as sax configured it, instead of using my xorg.conf that I used with OpenSUSE 11.0, and things seem exTREMEly fast and stable. I think I'm going to leave things as they are now unless I need to change them. FWIW, here's what I was using with 11.0 and KDE 4.2 beta2 and it was working fine:

Quote:
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "RenderAccel" "True"
Option "UseEdidFreqs" "False"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP, CRT"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "DamageEvents" "True"
Option "TripleBuffer" "True"
Option "UseEvents" "True"
Option "FlatPanelProperties" "DFP: Scaling = Centered; CRT: Scaling =
Centered, Dithering = Enabled"
Option "OnDemandVBlankInterrupts" "True"
Option "PixmapCacheSize" "2000000"
Option "AllowSHMPixmaps" "False"
Option "BackingStore" "True"
Option "metamodes" "CRT: 1680x1050 +0+0, DFP: 1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
At some point during the last year, I added most of those in trying to get nVidia's driver to behave better with KDE4. Maybe now not only are some of them not necessary, but maybe some of them actually cause xorg to crash??
vanRijn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.