Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-23-08, 12:23 AM   #1
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default 180.18 can't work on ubuntu 8.10

OS: ubunut 8.10
Thinkpad T61 nvidia Quadro nvs 140m
Code:
$sudo /etc/init.d/gdm stop
$sudo nvidia-installer --uninstall
$sudo sh  NVIDIA-Linux-x86-180.18-pkg1.run 
$sudo reboot
startup error:
Quote:
5852 5561
xinit /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe with-gdm -- /usr/bin/X :0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

X: warning; process set to priority -1 instead of requested priority 0

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux blackiron-laptop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686
Build Date: 24 October 2008 08:00:16AM
xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Tue Dec 23 13:59:22 2008
(++) Using config file: "/etc/X11/xorg.conf.failsafe"
error setting MTRR (base = 0xd1000000, size = 0x00e00000, type = 1) Invalid argument (22)
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(EE) No input driver/identifier specified (ignoring)
(EE) config/hal: NewInputDeviceRequest failed
5852 5561
Xorg.0.log
Quote:
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Attached Files
File Type: zip nvidia-bug-report.log.zip (36.3 KB, 104 views)
blackiron is offline   Reply With Quote
Old 12-23-08, 12:33 AM   #2
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: 180.18 can't work on ubuntu 8.10

Like your log says, you still have the old kernel module 173.14.12 in the way. If it was installed the ubuntu way, the nvidia-installer probably won't remove it and you have to use your package manager.
ledoc is offline   Reply With Quote
Old 12-23-08, 12:36 AM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 180.18 can't work on ubuntu 8.10

Your xorg.conf.failsafe file is using 'Driver "vesa"'. That won't work with NVIDIA's GLX extension.

Why are you using xorg.conf.failsafe instead of xorg.conf? Either way, whatever file you use should use 'Driver "nvidia"'.
Stephen Warren is offline   Reply With Quote
Old 12-23-08, 12:42 AM   #4
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: 180.18 can't work on ubuntu 8.10

Quote:
Originally Posted by ledoc View Post
Like your log says, you still have the old kernel module 173.14.12 in the way. If it was installed the ubuntu way, the nvidia-installer probably won't remove it and you have to use your package manager.
My last version is 180.16. But it work very well!

There is not any info about 173.14.12 in my package manager .

Thank you very much.
blackiron is offline   Reply With Quote
Old 12-23-08, 01:01 AM   #5
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: 180.18 can't work on ubuntu 8.10

Quote:
Originally Posted by Stephen Warren View Post
Your xorg.conf.failsafe file is using 'Driver "vesa"'. That won't work with NVIDIA's GLX extension.

Why are you using xorg.conf.failsafe instead of xorg.conf? Either way, whatever file you use should use 'Driver "nvidia"'.
Thanks a lots!

The file "xorg.conf.failsafe" is generated by OS,not me.

I have rewrited xorg.conf.failsafe to use "Driver" "nvidia",but The result is the same.

In my view,system use the file xorg.failsafe just after using "xorg.conf" failure
blackiron is offline   Reply With Quote
Old 12-23-08, 01:34 AM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.18 can't work on ubuntu 8.10

xorg.conf.failsafe is generated by BulletProofX when your regular xorg.conf doesn't work for some reason. You'll need to get the log files from the failed attempt to start the server with the real xorg.conf.
AaronP is offline   Reply With Quote
Old 12-23-08, 01:52 AM   #7
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: 180.18 can't work on ubuntu 8.10

Quote:
Originally Posted by AaronP View Post
xorg.conf.failsafe is generated by BulletProofX when your regular xorg.conf doesn't work for some reason. You'll need to get the log files from the failed attempt to start the server with the real xorg.conf.
Thank you!

Is the log file not xorg.0.log?
blackiron is offline   Reply With Quote
Old 12-23-08, 01:55 AM   #8
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 180.18 can't work on ubuntu 8.10

No, the X server run by BulletProofX replaced the log generated by the failed attempt with the correct xorg.conf. It should still exist as /var/log/Xorg.0.log.old.
AaronP is offline   Reply With Quote

Old 12-23-08, 02:48 AM   #9
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: 180.18 can't work on ubuntu 8.10

Quote:
Originally Posted by AaronP View Post
No, the X server run by BulletProofX replaced the log generated by the failed attempt with the correct xorg.conf. It should still exist as /var/log/Xorg.0.log.old.
Following is content in "/var/log/Xorg.0.log.old" about nvidia.Is that enough?
Quote:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Thank you for your help!
blackiron is offline   Reply With Quote
Old 12-23-08, 04:59 AM   #10
blackiron
Registered User
 
Join Date: Dec 2008
Posts: 17
Default Re: 180.18 can't work on ubuntu 8.10

down to 180.16!

There are not files "/dev/nvidia0" and "/dev/nvidiactl" after installing 180.18. But there they are for 180.16.

I have to down to 180.16.
blackiron is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVidia 96.xx.xx & 173.xx.xx Legacy drivers donít work in Ubuntu 12.04 PenguinPower NVIDIA Linux 93 09-08-12 01:49 AM
Getting Ubuntu 12.04LTS to work with 173.14.35?? m0dcm NVIDIA Linux 0 06-23-12 11:42 AM
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 04:20 PM
Canonical partners with Microsoft to support Ubuntu on Azure News Latest Tech And Game Headlines 0 06-08-12 05:20 AM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Latest Tech And Game Headlines 0 05-28-12 02:20 PM

All times are GMT -5. The time now is 01:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.