Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-18-08, 12:09 AM   #1
TimeGoneBy
Registered User
 
Join Date: Dec 2008
Posts: 5
Default 96.43.09 ubuntu intrepid text corruption

Hi, in this pc I have an old geforce 2 mx 200 pci card. I just installed Ubuntu 8.10 and the nv driver works flawlessly, but I would like 3d acceleration, so I enabled restricted driver. This installed the 96.43.09 driver for me, and it was enabled successfully. However, all text is garbled. It kinda looks like someone smeared it with a sharpie. I am attaching a screenshot to show what is going on. I am also attaching the nvidia-bug-report.log file.

Log File
Screenshot

Has anyone discovered a fix? I've played around with settings for a while, and I've discovered that the command "nvidia-settings -a InitialPixmapPlacement=0" fixes the text for every program except wine programs (I run productivity stuff, not games). However, I have to retype it every bootup because it doesnt seem to save the setting. I appreciate any help.

Edit: The screenshot is png format. I didnt put an extension on it i guess :/ but it does open in any image viewer.
TimeGoneBy is offline   Reply With Quote
Old 12-18-08, 12:26 AM   #2
alienexplorers
Registered User
 
alienexplorers's Avatar
 
Join Date: Feb 2007
Location: Hershey, PA, USA
Posts: 139
Default Re: 96.43.09 ubuntu intrepid text corruption

Try adding this line to your xorg.conf file:
Quote:
Option "RenderAccel" "False"
__________________
AMD K6-III 450 | 512 MB Mem | Dual 40 MB drives | Geforce FX5200 | Viewsonic VA703B monitor
alienexplorers is offline   Reply With Quote
Old 12-18-08, 08:22 PM   #3
TimeGoneBy
Registered User
 
Join Date: Dec 2008
Posts: 5
Default Re: 96.43.09 ubuntu intrepid text corruption

Thank you for a quick response.

Your idea was a good one, but it didn't affect the problem that I'm having. To be honest, I havent really touched the xorg.conf file until now. I'll go ahead and post the contents of this file, just in case someone has another idea of how I can tweak it to possibly fix the problem.

xorg.conf:

Quote:
Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "RenderAccel" "False"
EndSection
TimeGoneBy is offline   Reply With Quote
Old 12-21-08, 05:56 AM   #4
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Re: 96.43.09 ubuntu intrepid text corruption

For what it's worth, I'm seeing the same problem on Fedora 10 with

kmod-nvidia-96xx-96.43.09-1.fc10.5.i686
kmod-nvidia-96xx-2.6.27.5-117.fc10.i686-96.43.09-1.fc10.5.i686
xorg-x11-drv-nvidia-96xx-96.43.09-3.fc10.i386
xorg-x11-drv-nvidia-96xx-libs-96.43.09-3.fc10.i386
kernel-2.6.27.5-117.fc10.i686

01:00.0 VGA compatible controller: nVidia Corporation NV25GL [Quadro4 750 XGL] (rev a3)

You could probably put the settings command in the X startup scripts to avoid giving it manually every time. I don't have physical access to our 96xx machines right now, so I can't test whether the command works for me.
Gemini is offline   Reply With Quote
Old 12-21-08, 08:45 AM   #5
Gemini
Registered User
 
Join Date: May 2003
Location: Finland
Posts: 19
Default Re: 96.43.09 ubuntu intrepid text corruption

I tested the 'nvidia-settings -a InitialPixmapPlacement=0' workaround, and it does work for me on Fedora 10 and NV25GL [Quadro4 750 XGL]. On Fedora (not sure about the file organization on Ubuntu) you can create a file in

/etc/X11/xinit/xinitrc.d/

and put the command in it, and the script will be run at X startup and the setting will be made automatically for all users.
Gemini is offline   Reply With Quote
Old 12-23-08, 11:49 PM   #6
TimeGoneBy
Registered User
 
Join Date: Dec 2008
Posts: 5
Default Re: 96.43.09 ubuntu intrepid text corruption

Thats a good idea; I could just add the command to a startup script, so that I dont have to type it in every bootup. Although I've just been using the nv driver because I get text corruption in wine apps no matter what I do. Nothing will fix this it seems. Its good to know that my hardware/software configuration isn't the only one facing this issue. So, I think I'll send an email to bugs@nvidia.com or whatever that address was. I doubt they work much on legacy stuff nowdays, and I dont use that machine much, but its an annoying bug nonetheless and should be fixed.

By the way, my machine is dell dimension 2600 with 1gb ram, 2.66ghz, sblive 5.1, and geforce2mx 200 pci.
TimeGoneBy is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:04 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.