Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-05-09, 01:25 AM   #1
gberry
Registered User
 
Join Date: Jan 2009
Posts: 2
Default Ctrl+Alt-Fn (n=1...6) not working

Hi,
I'm using the 2.6.18 kernel on debian linux along with the 180.06 beta driver and a GeForce 7800 GS AGP card. Problem is nothing happens when I press the Ctrl+Alt+F1...F6 key combination. I'm supposed to get a virtual terminal but I get nothing, even with the recommended drivers (e.g. 177.82). I'm using the latest bios on a ASUS P4C800E-Deluxe MoBo. I have tried a different keyboard, but get the same results. I've also tried the debian driver and again no joy. Please help. I've attached the log file.
Attached Files
File Type: log nvidia-bug-report.log (129.2 KB, 74 views)
gberry is offline   Reply With Quote
Old 01-05-09, 01:29 AM   #2
Kirurgs
Registered User
 
Join Date: Jul 2007
Posts: 165
Default Re: Ctrl+Alt-Fn (n=1...6) not working

Rather funny question, but still, how do U think video card driver affects Your keyboard shortcuts or laptop special buttons?
__________________
** Laptop T500: C2D 2.53Ghz, 4Gb RAM, Radeon Mobility HD3650, ArchLinux x86_64, Gnome, custom 2.6.35.7, Catalyst 10.10...
** Homebrew router/media server: Intel Celeron 1.2GHz 256Mb RAM, Intel Integrated Video, ArchLinux i686, no GUI, 2.6.33.4
** Homebrew desktop: AMD Phenom X4 9950 Black Edition, 4Gb RAM, integrated Radeon HD3300 + discrete Radeon 4850 512M, Windows 7 Ultimate (for games), ArchLinux i686, Gnome, 2.6.29, catalyst 9.4... (this now just rocks in lunix, really! )
Kirurgs is offline   Reply With Quote
Old 01-05-09, 02:33 AM   #3
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: Ctrl+Alt-Fn (n=1...6) not working

i think he means he get only a blicking cursor and no terminal. I've the same issue and also various people i know have it. Randomly it *seems* to work. Right now most of the time if i want to update the drivers (since about last stable) I've to restart in a runlevel which doesn't start x
weltall is offline   Reply With Quote
Old 01-05-09, 03:02 AM   #4
gberry
Registered User
 
Join Date: Jan 2009
Posts: 2
Default Re: Ctrl+Alt-Fn (n=1...6) not working

Hi,
Thanks for writing! Actually, its just like I said: I press the right keys and nothing happens. Nothing. I'm still looking at the same window.
gberry
gberry is offline   Reply With Quote
Old 01-05-09, 03:32 AM   #5
Kirurgs
Registered User
 
Join Date: Jul 2007
Posts: 165
Default Re: Ctrl+Alt-Fn (n=1...6) not working

The case with blinking cursor is a problem with framebuffer then I had the same crap when tested debian or ubuntu.
Try adding vga=ask to kernel parameters and then choose some 640x480 or try other variants, this might help...

For original poster, sorry, but I have no idea, as I personally didn't have this kind of issue in my whole linux experience and various distros...

P.S. And please, be as more specific as can before posting an issue, because everyone understand your problem exactly as you wrote it...
__________________
** Laptop T500: C2D 2.53Ghz, 4Gb RAM, Radeon Mobility HD3650, ArchLinux x86_64, Gnome, custom 2.6.35.7, Catalyst 10.10...
** Homebrew router/media server: Intel Celeron 1.2GHz 256Mb RAM, Intel Integrated Video, ArchLinux i686, no GUI, 2.6.33.4
** Homebrew desktop: AMD Phenom X4 9950 Black Edition, 4Gb RAM, integrated Radeon HD3300 + discrete Radeon 4850 512M, Windows 7 Ultimate (for games), ArchLinux i686, Gnome, 2.6.29, catalyst 9.4... (this now just rocks in lunix, really! )
Kirurgs is offline   Reply With Quote
Old 01-05-09, 07:59 AM   #6
sambo57u
Registered User
 
Join Date: Jan 2006
Posts: 52
Default Re: Ctrl+Alt-Fn (n=1...6) not working

I have the same problem on my T61 with NVS 140M. Two issues:

1. ctrl-alt-backspace restarts X and ends with black screen. The login screen
never comes back. Non functioning keyboard. Reboot.

2. Switching with ctrl+alt+fn also results in black screen and non functioning
keyboard. Reboot.

Using Fedora 9 and KDE/KDM with driver 180.18.

The exact same setup works on my desktop machine with NVS 290.
sambo57u is offline   Reply With Quote
Old 01-05-09, 08:18 AM   #7
busbus
Registered User
 
Join Date: Nov 2008
Posts: 24
Default Re: Ctrl+Alt-Fn (n=1...6) not working

have this issue as well. zepto nexus a 15 notebook, 9600gt, all drivers since 173.14 including beta drivers.
the framebuffer stays black after terminating x, while keyboard works (you can blind-restart x from console). and i cant switch terminals with ctrl-alt-fn, although this might be a keymapping issue with the wm, which i seriously doubt since the same wm config worked fine on my old notebook.

there are some posts which say a combination of uvesafb and nvidia driver should fix this, but i didnt have the time yet to fiddle arround with it.
busbus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tony Hawk devs working on Call of Duty News Gaming Headlines 0 06-15-12 10:30 AM
RH7.3, 3123, was working, now it isn't phips NVIDIA Linux 2 10-03-02 02:08 PM
Nvidia 3123 not working on Mandrake 8.2 UP with Geforce 440 MMX tariqf NVIDIA Linux 1 09-17-02 08:22 AM
TV-out not working nomatter what driver.. Dr_Gigolo NVIDIA Windows Graphics Drivers 11 09-11-02 11:11 AM
How do I get Dual Head working? Heath NVIDIA Linux 1 08-22-02 12:44 PM

All times are GMT -5. The time now is 01:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.