Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-08-08, 07:21 AM   #1
amews_aj
Registered User
 
Join Date: Nov 2008
Posts: 3
Lightbulb HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Hi,

I have been trying to fix the problems with the beta driver 96.43.09, and finally managed to get it working.
I thought I would just upload this HOWTO:

This solves the graphics problems in both openoffice and wine when using this beta driver in ubuntu 8.10

1. Install the driver from synaptic (96.43.09 has been released in the package manager):
Use the synaptic package manager or do:
Code:
sudo apt-get install nvidia-glx-96
from terminal.
2. Update the xorg.conf
Code:
sudo gedit /etc/X11/xorg.conf
Make it look like this:
Code:
Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30.0 - 110.0
    VertRefresh 50.0 - 150.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "AllowGLXWithComposite" "True"
    Option "AddARGBGLXVisuals" "True"
    SubSection "Display"
        Depth 24
        Modes "1600x1200" "1280x800" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enabled"
EndSection
You can manually add more resolutions to this line:
Modes "1600x1200" "1280x800" "1024x768" "800x600" "640x480"

3. Go to System > Preferences > Appearence > Fonts
Select Subpixel

Using wine?
Create a txt (settings.txt) file in fx your home folder containing this:
Code:
[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideWithRender"="N"
Go to a terminal window and write:
Code:
regedit settings.txt
Remember to reboot your system after installing the driver.

Hope this works for you too

PS: Of course there will be a driver update that fixes the problem itself, but for now, this seems to be working just fine.

Last edited by amews_aj; 11-08-08 at 07:30 AM. Reason: Code was corrected
amews_aj is offline   Reply With Quote
Old 11-15-08, 03:29 AM   #2
kaerdon
Registered User
 
Join Date: Nov 2008
Posts: 4
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

thank you very much, it works fine for wine!
kaerdon is offline   Reply With Quote
Old 11-18-08, 03:45 AM   #3
luk1don
Registered User
 
luk1don's Avatar
 
Join Date: Nov 2008
Posts: 55
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

And what about another applications, e.g. Kadu, Qt 3 Configuration? Have you got any idea?

I have it! I upload here my solution for this beta driver (96.43.09). This works in a whole system!

Viz. we edit xorg.conf (in folder /etc/X11).
In section "Device" we add line:

Option "RenderAccel" "0"

Thats all! We can turn on graphics effects and all programs have fonts!

Last edited by luk1don; 11-20-08 at 02:52 PM.
luk1don is offline   Reply With Quote
Old 11-22-08, 07:55 PM   #4
harrypotel
Registered User
 
Join Date: Nov 2008
Posts: 1
Talking Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Quote:
Originally Posted by luk1don View Post
And what about another applications, e.g. Kadu, Qt 3 Configuration? Have you got any idea?

I have it! I upload here my solution for this beta driver (96.43.09). This works in a whole system!

Viz. we edit xorg.conf (in folder /etc/X11).
In section "Device" we add line:

Option "RenderAccel" "0"

Thats all! We can turn on graphics effects and all programs have fonts!
Dude, you're a genius!!! It worked perfectly. I've been trying to fix this issue for more than a month now and it's finally working.

Thanks a lot!
harrypotel is offline   Reply With Quote
Old 11-22-08, 08:31 PM   #5
mkrisch
Registered User
 
Join Date: Nov 2008
Posts: 1
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

is anyone seeing lock-ups with this in opengl games? i'm running an older Geforce4 Ti 4400 and getting lock ups in Extreme Tux Racer, sdljump, supertux 2, etc....

i'd done the standard install, and since added the additional Option "AddARGBGLXVisuals" "True" line, disabled FSAA, disabled Compiz... none of those seem to make a difference.

thoughts or other things to try?

compiz itself works fine, btw. only noticed the lockups when i started to try out some accelerated games which i installed from the intrepid multiverse and universe repositories.
mkrisch is offline   Reply With Quote
Old 12-20-08, 11:14 AM   #6
dad
Registered User
 
Join Date: Dec 2008
Location: Spb, Russia
Posts: 4
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Quote:
Originally Posted by mkrisch View Post
is anyone seeing lock-ups with this in opengl games? i'm running an older Geforce4 Ti 4400 and getting lock ups in Extreme Tux Racer, sdljump, supertux 2, etc....

i'd done the standard install, and since added the additional Option "AddARGBGLXVisuals" "True" line, disabled FSAA, disabled Compiz... none of those seem to make a difference.

thoughts or other things to try?

compiz itself works fine, btw. only noticed the lockups when i started to try out some accelerated games which i installed from the intrepid multiverse and universe repositories.
I see random hard lock-ups with these[and maybe previous also] legacy drivers on my AGP 7600GS with 2.6.27.7 kernel[Slackware 12.2 distro]. Sometimes[rarely - once in several hours, maybe even days] my pc locks completely[Magic SysRq doesn't help - have to use reset button] even not while running OpenGL games, but just during usual work in X in 2D only. I'm not 100% sure it's nvidia driver's fault. Now I'm testing nouveau driver and had no lockups yet...I used legacy drivers because old games, such as doom3 for example, are completelely messed up if I use 1xx series drivers on my hardware...

mkrisch
You can try, if you have windows, run some OpenGL apps there and wait for lock-ups.

PS: Tried with "NvAGP" "0" - no luck :-( Still see freezes/lockups. Running glxgears continuously seems to increase lockup probability.

Last edited by dad; 12-23-08 at 12:52 PM.
dad is offline   Reply With Quote
Old 01-03-09, 05:36 AM   #7
athanagor
Registered User
 
Join Date: Dec 2008
Posts: 4
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Quote:
Originally Posted by amews_aj View Post
Hi,

I have been trying to fix the problems with the beta driver 96.43.09, and finally managed to get it working.
I thought I would just upload this HOWTO:

This solves the graphics problems in both openoffice and wine when using this beta driver in ubuntu 8.10

1. Install the driver from synaptic (96.43.09 has been released in the package manager):
Use the synaptic package manager or do:
Code:
sudo apt-get install nvidia-glx-96
from terminal.
2. ... Look at my solution !!!

[FOR UGLY KDE ???]
3. Go to System > Preferences > Appearence > Fonts
Select Subpixel

Using wine?
Create a txt (settings.txt) file in fx your home folder containing this:
Code:
[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
"ClientSideWithRender"="N"
Go to a terminal window and write:
Code:
regedit settings.txt
Remember to reboot your system after installing the driver.

Hope this works for you too

PS: Of course there will be a driver update that fixes the problem itself, but for now, this seems to be working just fine.
Hello together,
I use Arch-Linux with xorg 7.4-1 and tried the above Configuration. But it still left me with that font problem.

I changed the xorg.conf file as followes:

Code:
Section "Extensions"
	Option "Composite" "Disable"
	... YOUR OPTIONS ...
EndSection


Section "Device"
	Identifier	"NVidia"
	Driver		"nvidia"
	Option		"RandRRotation"			"1"
#This may help ???
	Option		"ConstantDPI"			"FALSE"
#Sorry, but this could be bad ideas.
#Specialy: Usage of Composite and GLX together.
#	Option		"AllowGLXWithComposite"	"True"
#	Option		"AddARGBGLXVisuals"		"True"
#	Option		"RenderAccel"			"0"
EndSection
On my system, this works fine.
Maybe also on yours.

Hope it helps and happy new year to all,
athanagor.
athanagor is offline   Reply With Quote
Old 01-04-09, 03:56 PM   #8
pi4630
Registered User
 
Join Date: Jan 2009
Location: Brunico (BZ), IT
Posts: 3
Send a message via Skype™ to pi4630
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Hi,

I've tried everything of the posted proposals, but nothing worked fine for me. I have a nvidia GeForce 4200 Ti 128 MB. The last try I did was with this config:

Code:
Section "Monitor"
	Identifier	"Configured Monitor"
	VendorName	"Philips"
	ModelName	"190B7"
	HorizSync	30.0 - 83.0
    	VertRefresh	56.0 - 76.0
    	#Option		"DPMS"	
EndSection

Section "Device"
    Identifier	"Configured Video Device"
    Driver	"nvidia"
    VendorName	"NVIDIA Corporation"
    Option	"RenderAccel"	"0"
    Option	"ConstantDPI"	"FALSE"
EndSection


Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
 	Option		"AllowGLXWithComposite" "True"
	Option		"AddARGBGLXVisuals" "True"
	SubSection "Display"
		Depth 24
        	Modes "1280x1024" "1024x768" "800x600"
    	EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection

Section "Module"
	Load	"glx"
EndSection
Is it possibile to use an older driver using Synaptic?

Thanks!
pi4630 is offline   Reply With Quote

Old 01-05-09, 10:54 AM   #9
athanagor
Registered User
 
Join Date: Dec 2008
Posts: 4
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Quote:
Originally Posted by pi4630 View Post
Hi,

I've tried everything of the posted proposals, but nothing worked fine for me. I have a nvidia GeForce 4200 Ti 128 MB. The last try I did was with this config:

Code:
Section "Monitor"
	Identifier	"Configured Monitor"
	VendorName	"Philips"
	ModelName	"190B7"
	HorizSync	30.0 - 83.0
    	VertRefresh	56.0 - 76.0
    	#Option		"DPMS"	
EndSection

Section "Device"
    Identifier	"Configured Video Device"
    Driver	"nvidia"
    VendorName	"NVIDIA Corporation"
    Option	"RenderAccel"	"0"
    Option	"ConstantDPI"	"FALSE"
EndSection


Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	DefaultDepth	24
 	Option		"AllowGLXWithComposite" "True"
	Option		"AddARGBGLXVisuals" "True"
	SubSection "Display"
		Depth 24
        	Modes "1280x1024" "1024x768" "800x600"
    	EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection

Section "Module"
	Load	"glx"
EndSection
Is it possibile to use an older driver using Synaptic?

Thanks!
Hello,
maybe you should set:

Option "Composite" "Enable" TO Option "Composite" "Disable"

AND

Option "AllowGLXWithComposite" "True" <-- set to "False"
Option "AddARGBGLXVisuals" "True" <-- set to "False"

AND

Option "RenderAccel" "0" <-- set to "1"

You may also comment out or delete those lines.

Hope it helps!
athanagor is offline   Reply With Quote
Old 01-05-09, 01:02 PM   #10
pi4630
Registered User
 
Join Date: Jan 2009
Location: Brunico (BZ), IT
Posts: 3
Send a message via Skype™ to pi4630
Default Re: HOWTO: 96.43.09, graphics fully working in Ubuntu 8.10

Quote:
Originally Posted by athanagor View Post
Hello,
maybe you should set:

Option "Composite" "Enable" TO Option "Composite" "Disable"

AND

Option "AllowGLXWithComposite" "True" <-- set to "False"
Option "AddARGBGLXVisuals" "True" <-- set to "False"

AND

Option "RenderAccel" "0" <-- set to "1"

You may also comment out or delete those lines.

Hope it helps!
Hi,

unfortunately, it didn't

bye
~p
pi4630 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 04:31 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.