Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-03-09, 01:14 PM   #1
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Xorg process uses lots of CPU

top

3171 root 20 0 1065m 112m 4308 S 26 5.6 47:21.25 Xorg


I'm not doing anything special in this moment, but my Xorg process won't go below 20% now is on 26%, I think there's something wrong, I'm running an Intel Core 2 Duo E8400, with a 9500GT and latest beta driver installed.
Compiz and latest kde4.

How can I optimize this?
marchetto is offline   Reply With Quote
Old 01-04-09, 05:56 AM   #2
Rudd-O
Registered User
 
Join Date: Dec 2008
Posts: 21
Default Re: Xorg process uses lots of CPU

Check your dmesg, if you find NVRM Xid errors, you might also notice Xorg is pegging the CPU, I get this all the time with the latest beta driver and I have to restart X, and sometimes even reboot, to fix the issue.

Quote:
Originally Posted by marchetto View Post
top

3171 root 20 0 1065m 112m 4308 S 26 5.6 47:21.25 Xorg


I'm not doing anything special in this moment, but my Xorg process won't go below 20% now is on 26%, I think there's something wrong, I'm running an Intel Core 2 Duo E8400, with a 9500GT and latest beta driver installed.
Compiz and latest kde4.

How can I optimize this?
Rudd-O is offline   Reply With Quote
Old 01-08-09, 06:59 AM   #3
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: Xorg process uses lots of CPU

I've got no NVRM Xid errors in my dmesg.
Xorg process ever takes 20% of my system... it's really strange and I think that's a too high percentage for this capable CPU
marchetto is offline   Reply With Quote
Old 01-08-09, 07:14 AM   #4
gbil
Registered User
 
Join Date: Mar 2006
Posts: 272
Default Re: Xorg process uses lots of CPU

Quote:
Originally Posted by marchetto View Post
I've got no NVRM Xid errors in my dmesg.
Xorg process ever takes 20% of my system... it's really strange and I think that's a too high percentage for this capable CPU
Many times Xorg cpu utilization doesn't represent the real xorg processes but another program that uses xorg. Try to check what other programs are running - background processes of kde for example - and kill them.
gbil is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM
Pentium 4 aka Prescott at 0.09 TSMC -=DVS=- CPUs, Motherboards And Memory 12 08-15-02 10:47 PM

All times are GMT -5. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.