Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-08-09, 10:43 AM   #1
djsmeg
Registered User
 
Join Date: Nov 2005
Posts: 4
Default WoW issues- especially since upgrade

Hi,
So I've been an avid WoW on Linux fan for a while. My old Graphics Card (a GF7950x2 thingy with 2 GPUs) ran WoW nicely, and everything was hunky dory for the longest time. Then Wrath of the Lich King hit and I've been having problems running WoW under Linux since. A recent upgrade to a GTX260 card has exacerbated the previous problems to the point the game is now completely unplayable under Linux.

The symptoms are that WoW will chug along happily (with graphics performance about equivalent to Windoze !), then caused generally by a rapid movement (such as turning at speed, or zoning to another zone) there will be massive graphical corruption (giant triangles all over the screen) followed shortly thereafter by WoW erroring out. If I hook up gdb, it appears there's a segfault happening, but it's in spurious places. The one sane error I seem to get regularly is a double free problem in libGLcore.so, which is why I am posting here. Sadly I have yet to capture the double free error.

Note that WoW works fine under Windoze, with the NVIDIA drivers. Sadly, I have windoze very very much...

Thoughts?
djsmeg is offline   Reply With Quote
Old 01-08-09, 10:47 AM   #2
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: WoW issues- especially since upgrade

Post a bug report and some extra information such as what version of wine you are using etc. Myself, I play wow regularly using the latest drivers with the latest wine release and have never had any issues (other than when wine runs out of memory during raids/wintergrasp - but this is a known wine issue).
Big P is offline   Reply With Quote
Old 01-08-09, 11:19 AM   #3
djsmeg
Registered User
 
Join Date: Nov 2005
Posts: 4
Default Re: WoW issues- especially since upgrade

Quote:
Originally Posted by Big P View Post
Post a bug report and some extra information such as what version of wine you are using etc. Myself, I play wow regularly using the latest drivers with the latest wine release and have never had any issues (other than when wine runs out of memory during raids/wintergrasp - but this is a known wine issue).
What does that look like exactly? Would it manifest as a WoW crash potentially?

I'm running wine 1.11 at the moment.

I'll generate a bug report. Just need to read how to do that. Though getting a useful backtrace from the crash itself, not so much. No debug symbols
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (41.1 KB, 65 views)

Last edited by djsmeg; 01-08-09 at 11:24 AM. Reason: Attaching bug report file
djsmeg is offline   Reply With Quote
Old 01-08-09, 01:07 PM   #4
mrn
Registered User
 
Join Date: Dec 2004
Posts: 254
Default Re: WoW issues- especially since upgrade

http://www.nvnews.net/vbulletin/showthread.php?t=120856

can it be this one?
mrn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Podcast: SCINET Derives 100 Teraflops from InfiniBand Upgrade News Archived News Items 0 06-17-12 02:00 AM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
Mandrake 9.0 upgrade - x crashes gozilla NVIDIA Linux 2 09-27-02 10:04 AM
Mandrake 8.2 + Nvidia ti4400 - Issues endothermal NVIDIA Linux 3 09-20-02 02:33 PM
To upgrade, or not to upgrade... jnd3 Microsoft Windows XP And Vista 18 09-13-02 11:09 AM

All times are GMT -5. The time now is 06:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.