Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-15-09, 07:51 AM   #1
raddy
Registered User
 
Join Date: Jan 2009
Posts: 4
Question [Bug] Random contents displayed upon KDM Startup in 180.22 driver

Hello Everybody

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?

Is there a work-around?

Last edited by raddy; 01-18-09 at 06:30 AM.
raddy is offline   Reply With Quote
Old 01-15-09, 03:58 PM   #2
tonz
Registered User
 
Join Date: Feb 2006
Posts: 3
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

Quote:
Originally Posted by raddy View Post

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?
same here on a desktop with 8600GT. Additionally after a random amount of time opengl applications (e.g. the opengl screensaver) start to stutter. If I restart them they run fine again for a while.

Cheers,
tonz
tonz is offline   Reply With Quote
Old 01-15-09, 04:53 PM   #3
elsewhere
Registered User
 
Join Date: Jul 2007
Posts: 8
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

I had that problem with the 180.xx drivers and openSUSE 11.0/11.1. Graphical artifacts and "ghost" images of previously rendered images. It would happen at KDM startup, and then when KDE was loading. Never lasted more than a second or so.

Bizarrely, it only happened when using the openSUSE-branding theme for KDM in KDE4. When I replaced that with the upstream-branding (basically the default KDM theme that ships with KDE4), it stopped happening.

Never happened with the previous drivers and openSUSE, and yet only happens with the openSUSE theme, so I'm not sure where the fault may lie.

Cheers,
KV
elsewhere is offline   Reply With Quote
Old 01-15-09, 08:33 PM   #4
xin44
Registered User
 
Join Date: Dec 2006
Posts: 72
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

...same for me, and when corruption comes, all the corrupt areas are fill in with those graphical artifact.
xin44 is offline   Reply With Quote
Old 01-15-09, 11:02 PM   #5
raddy
Registered User
 
Join Date: Jan 2009
Posts: 4
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

As of my knowledge this issue occurs because of the updated nVidia driver uses InitialPixmapPlacement=2 instead of 1 i think.

This "2" option places X pixmaps in your GPU's video memory instead of the traditional system memory.

Is anybody able to revert the changes?
raddy is offline   Reply With Quote
Old 01-16-09, 06:43 PM   #6
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

I tested with KDE 4.1.96 on Fedora 10 and every time I log in, I can see this random content on my second monitor. On the first monitor I can see the splash screen of kde, but on the second monitor (with TwinView) either just some random colors or parts of Images that still seem to be present in video memory (e.g. the desktop from before a reboot) are displayed.

I'm not sure if it is a bug in nvidia driver or kde, but it seems as if the video memory is not initialized correctly before usage.
Lysius is offline   Reply With Quote
Old 01-18-09, 05:48 AM   #7
clarious
Registered User
 
Join Date: Jan 2009
Posts: 39
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

I also have problems that are related to this.

I run compiz with --loose-binding for better performance, if I don't enable indirect-rendering (thing has to pass to X server before go to screen) then windows won't automatically redraw on my screen until I pass my mouse on it, running it with indirect rendering solve this problem but compiz developers don't recommend doing this.

I hope this will get fixed in the next version together with suspend/resume problem.
clarious is offline   Reply With Quote
Old 01-18-09, 06:15 AM   #8
Tigerw
Registered User
 
Join Date: Jan 2006
Posts: 2
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

I have the same problem with 9800GTX+.
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (40.9 KB, 81 views)

Last edited by Tigerw; 01-19-09 at 06:21 AM.
Tigerw is offline   Reply With Quote

Old 01-18-09, 09:21 AM   #9
kriko
openSuSE11
 
kriko's Avatar
 
Join Date: Aug 2005
Location: Europe, Slovenia, Koper
Posts: 515
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

Same here with 7600GT
kriko is offline   Reply With Quote
Old 01-18-09, 12:07 PM   #10
Lysius
Registered User
 
Join Date: Oct 2008
Posts: 98
Default Re: Random contents displayed upon KDM Startup in 180.22 driver

Quote:
Originally Posted by clarious View Post
I also have problems that are related to this.
Are you sure that your problems are related to uninitialized video memory?
Lysius is offline   Reply With Quote
Old 01-18-09, 12:15 PM   #11
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: [Bug] Random contents displayed upon KDM Startup in 180.22 driver

Quote:
Originally Posted by raddy View Post
Hello Everybody

I am using Nvidia 9300GS equipped laptop.
Upon KDM Startup in OpenSUSE 11.1 instead of black, Random contents gets displayed briefly.

Anybody else experiencing this issue?

Is there a work-around?
+1!

http://sl1pkn07.no-ip.com/imagenes/dscf4267.jpg

with 9300GS. with 7950GX2 not occur this
sl1pkn07 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:49 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.