Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-24-08, 06:17 AM   #1
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default vdpau and compiz ?

Hello,

since 180.18 nvidia-drivers and mplayer-vdpau-3263604.tar.bz2 I can play x264 files using vdpau which is very good if I don't use compiz.

With compiz, it use more CPU than what it use with ffmpeg.

Maybe my config isn't good ?

If someone know how to fix it I would be very happy !!!
Attached Files
File Type: bz2 xorg.conf.bz2 (5.1 KB, 127 views)

Last edited by Gregoire.Favre; 01-16-09 at 03:55 AM. Reason: title had "nvdpau" which was wrong
Gregoire.Favre is offline   Reply With Quote
Old 01-16-09, 03:58 AM   #2
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: nvdpau and compiz ?

And the fault wasn't gentoo wrapper but mine :
I used to start compiz with an "exec fusion-icon" in my .xinitrc, starting it with "exec compiz-manager" just start it with the right option (in my case without the stupid --indirect-rendering).

Thank to Stephen Warren I can now use VDPAU with alsmost no CPU need under compiz.
Gregoire.Favre is offline   Reply With Quote
Old 01-16-09, 07:11 AM   #3
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: nvdpau and compiz ?

Quote:
Originally Posted by Gregoire.Favre View Post
And the fault wasn't gentoo wrapper but mine :
I used to start compiz with an "exec fusion-icon" in my .xinitrc, starting it with "exec compiz-manager" just start it with the right option (in my case without the stupid --indirect-rendering).

Thank to Stephen Warren I can now use VDPAU with alsmost no CPU need under compiz.
You can, of course, disable indirect rendering in fusion-icon.

Adam
adamk75 is offline   Reply With Quote
Old 01-16-09, 08:39 AM   #4
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: vdpau and compiz ?

Quote:
Originally Posted by adamk75 View Post
You can, of course, disable indirect rendering in fusion-icon.

Adam
If you say so, but it took me quiete a long time to figure that out, and I didn't find the config files for fusion icon, the default (at least on gentoo) is not vdpau suited, so compiz-manager is a better and easyer choice for me (if you know how to set fusion-icon right, that would be interesting).
Gregoire.Favre is offline   Reply With Quote
Old 01-18-09, 01:48 AM   #5
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: nvdpau and compiz ?

Quote:
Originally Posted by Gregoire.Favre View Post
And the fault wasn't gentoo wrapper but mine :
I used to start compiz with an "exec fusion-icon" in my .xinitrc, starting it with "exec compiz-manager" just start it with the right option (in my case without the stupid --indirect-rendering).

Thank to Stephen Warren I can now use VDPAU with alsmost no CPU need under compiz.
Compiz doesn't use indirect rendering on my system and yet running compiz + vdpau = 100% CPU. What else did you do?
mooninite is offline   Reply With Quote
Old 01-18-09, 10:39 AM   #6
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: nvdpau and compiz ?

I also disabled composite.
Gregoire.Favre is offline   Reply With Quote
Old 01-18-09, 10:41 AM   #7
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: nvdpau and compiz ?

Quote:
Originally Posted by Gregoire.Favre View Post
I also disabled composite.
what? If you disable composite compiz won't work at al..
Dragoran is offline   Reply With Quote
Old 01-19-09, 07:23 AM   #8
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: nvdpau and compiz ?

Here's my xorg.conf which works fine here ;-)
Attached Files
File Type: bz2 xorg.conf.bz2 (1.8 KB, 160 views)
Gregoire.Favre is offline   Reply With Quote

Old 01-19-09, 07:30 AM   #9
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: nvdpau and compiz ?

Nowhere in your xorg.conf file are you disabling composite.

And you can enable and disable indirect rendering in fusion-icon by right clicking on the icon, going to "compiz options" and hitting the check box for indirect rendering.

Adam
adamk75 is offline   Reply With Quote
Old 01-19-09, 07:39 AM   #10
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: nvdpau and compiz ?

Oh my bad then, I don't know which icon you refer too, if you mean ccsm command it might be it (I don't have any icon on my system), I shall try again fusion-icon then ;-)

Thanks.
Gregoire.Favre is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:11 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.