Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-08, 03:18 PM   #1
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default [180.08] X doesn't load and locks up system

With driver 180.06 and 180.08, I can no longer start X. The screen stays black when the login manager should appear, and I can't switch to terminal or kill it with ctrl+alt+backspace. After a few second my laptop fan starts running at full speed. I managed to reboot it with sysrq, and I'm attaching the X log and nvidia messages in kernel log.
I'm using a Toshiba laptop with Quadro NVS 130M.
Attached Files
File Type: log nvidia-bug-xlog.log (9.2 KB, 121 views)
File Type: log nvidia-bug-dmesg.log (396 Bytes, 123 views)
File Type: bz2 nvidia-bug-report.log.bz2 (30.5 KB, 107 views)
ambro887 is offline   Reply With Quote
Old 11-19-08, 11:28 AM   #2
thewonderer57
Registered User
 
Join Date: Nov 2008
Posts: 26
Default Re: [180.08] X doesn't load and locks up system

I second that. -

I have exactly the same problem. X server doesn't load (no mouse...) then my graphics card's fan goes at full speed. I have left this 20 minutes - needless to say it won't be booting the X server. This is with both 18006 and 180.08

I'm using 9500GT
180.08 64bit version

Is this a known bug?
thewonderer57 is offline   Reply With Quote
Old 12-03-08, 11:43 AM   #3
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: [180.08] X doesn't load and locks up system

This is still an issue in driver 180.11.
I should note that the beta driver works on my PC which has 8800GTX.
ambro887 is offline   Reply With Quote
Old 12-14-08, 03:41 AM   #4
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: [180.08] X doesn't load and locks up system

This is still an issue in driver 180.16.
I noticed that the beta driver will load fine if the working 177.82 driver has been running previously (of course after reloading the kernel module), but will fail on cold boot. So I guess there is some problem with initialization.
ambro887 is offline   Reply With Quote
Old 12-17-08, 06:38 PM   #5
CmdrFirewalker
Registered User
 
CmdrFirewalker's Avatar
 
Join Date: Jun 2007
Location: Dresden, Germany
Posts: 5
Send a message via ICQ to CmdrFirewalker
Default Re: [180.08] X doesn't load and locks up system

I can replicate the problem with 180.08 and 180.16 on a vanilla kernel (2.6.27.8) and the ubuntu hardy kernel (2.6.24-22-generic) both 32bit with a 9800GT DeviceID 0x0605.

http://www.techpowerup.com/gpuz/2sg9c/
Attached Files
File Type: zip nvidia-bug-report.zip (30.9 KB, 99 views)
__________________
-=Just walking into hostile fire=-
CmdrFirewalker is offline   Reply With Quote
Old 12-23-08, 02:23 PM   #6
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: [180.08] X doesn't load and locks up system

This is still an issue in driver 180.18.
ambro887 is offline   Reply With Quote
Old 01-08-09, 04:54 PM   #7
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: [180.08] X doesn't load and locks up system

This is still an issue in driver 180.22.
Please fix this, as the driver generally works better (no freezes, KDE4 works faster). Obviously there's some initialization missing.
ambro887 is offline   Reply With Quote
Old 01-27-09, 06:18 PM   #8
ambro887
Registered User
 
Join Date: Nov 2007
Posts: 31
Default Re: [180.08] X doesn't load and locks up system

Seems to be fixed in driver 180.25. Thank you!
ambro887 is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:22 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.