Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-24-09, 08:16 AM   #1
Gigonua
Registered User
 
Join Date: Jan 2009
Location: Florida
Posts: 4
Default "Type 1" error when installing Nvida driver

I am new to the forum but I have been looking through posts for several days and I have found lots of helpful posts. I am having trouble installing the linux drivers for my NVIDIA GeForce 8800 GTS graphics card on Linux Mint 6 "Felicia". The installation goes fine but when I restart my computer I get an error that says:

(EE) Failed to load module "type1" (module does not exist, 0)
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(EE) Screen(s) found, but none have a usable configuration.

I have tried and tried, I have scanned the internet, I have tried using envyNG, I have tried manual installs and i have tried different versions of the NVIDA linux drivers. I keep getting this same error message. I have reinstalled Linux Mint 3 times now lol.

I have a relatively new quad-core computer with 2 300GB hard drives. I set up partitions and I am running Vista on my first hard drive and Windows 7 and Linux Mint on my second hard drive.

I am am only using 1 monitor: HPw2007 1680x1050 -60Hz I think my monitor is 23 inches wide.

After i get the error message, I have the option to switch to low resolution mode. This does not work for me. My screen goes Black! The only option that works for me is to reconfigure my settings and use the default. This brings me back to my desktop running on the 2D nv graphics card.

This is my Xorg.0.log

X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux gigonua-desktop 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686
Build Date: 24 October 2008 08:00:16AM
xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 22 22:32:30 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) No Layout section. Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Configured Monitor"
(**) | |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) No FontPath specified. Using compiled-in default.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/X11/misc,
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/75dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
/usr/share/fonts/X11/75dpi,
/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Loader magic: 0x81d9a40
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0@1:0:0) nVidia Corporation G80 [GeForce 8800 GTS] rev 162, Mem @ 0xfa000000/0, 0xd0000000/0, 0xf8000000/0, I/O @ 0x0000df00/0, BIOS @ 0x????????/131072
(--) PCI: (0@2:0:0) Conexant Systems, Inc. CX23418 Single-Chip MPEG-2 Encoder with Integrated Analog Video/Broadcast Audio Decoder rev 0, Mem @ 0xe8000000/0
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
(II) "extmod" will be loaded by default.
(II) "dbe" will be loaded by default.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "freetype" will be loaded by default.
(II) "record" will be loaded by default.
(II) "dri" will be loaded by default.
(II) LoadModule: "glx"

(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module 177.80 Wed Oct 1 15:06:06 PDT 2008
(II) Loading extension GLX
(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "freetype"

(II) Loading /usr/lib/xorg/modules//fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.5.2, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.6
(II) Loading font FreeType
(II) LoadModule: "record"

(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension RECORD
(II) LoadModule: "dri"

(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org Server Extension, version 1.1
(II) Loading extension XFree86-DRI
(II) LoadModule: "nvidia"

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver 177.80 Wed Oct 1 14:45:01 PDT 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"

(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"

(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.5.2, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Creating default Display subsection in Screen section
"Default Screen" for depth/fbbpp 24/32
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

I also get a GLX extension error:
X.Org X Server 1.5.2
Release Date: 10 October 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
Current Operating System: Linux gigonua-desktop 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686
Build Date: 24 October 2008 08:00:16AM
xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Thu Jan 22 22:32:32 2009
(++) Using config file: "/etc/X11/xorg.conf.failsafe"
error setting MTRR (base = 0xf9000000, size = 0x00e00000, type = 1) Invalid argument (22)
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
6493 6277

Sorry if this post is a little long and thank you in advance.
Gigonua is offline   Reply With Quote
Old 01-24-09, 11:34 AM   #2
hash87
Registered User
 
Join Date: Dec 2008
Posts: 6
Default Re: "Type 1" error when installing Nvida driver

Have you tried to remove

Load "type1"

from your Module section in xorg.conf?
hash87 is offline   Reply With Quote
Old 01-24-09, 12:04 PM   #3
Gibbs
Registered User
 
Join Date: Jan 2009
Posts: 2
Default Re: "Type 1" error when installing Nvida driver

Quote:
Originally Posted by hash87 View Post
Have you tried to remove

Load "type1"

from your Module section in xorg.conf?
I have the same problem as him. Removing that does stop that error but it doesn't stop the "failed to initialize NVIDIA" error...
Gibbs is offline   Reply With Quote
Old 01-25-09, 08:28 AM   #4
Gigonua
Registered User
 
Join Date: Jan 2009
Location: Florida
Posts: 4
Default Re: "Type 1" error when installing Nvida driver

I am dual booting operating systems. Could the fact that im running linux off of the second partition on my second hard-drive have anything to do with this problem?
Gigonua is offline   Reply With Quote
Old 01-25-09, 09:07 AM   #5
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: "Type 1" error when installing Nvida driver

Quote:
Originally Posted by Gigonua View Post
I am dual booting operating systems. Could the fact that im running linux off of the second partition on my second hard-drive have anything to do with this problem?
No.

Please check this sticky thread: http://nvnews.net/vbulletin/showthread.php?t=46678

Specifically the part about creating a bug report.

Adam
adamk75 is offline   Reply With Quote
Old 01-25-09, 05:36 PM   #6
Gigonua
Registered User
 
Join Date: Jan 2009
Location: Florida
Posts: 4
Default Re: "Type 1" error when installing Nvida driver

I attached my Nvidia log as a .bz2 file.
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (32.7 KB, 88 views)
Gigonua is offline   Reply With Quote
Old 01-25-09, 07:55 PM   #7
alienexplorers
Registered User
 
alienexplorers's Avatar
 
Join Date: Feb 2007
Location: Hershey, PA, USA
Posts: 139
Default Re: "Type 1" error when installing Nvida driver

Have you tried using the following options in xorg.conf under the Screen section:
Quote:
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "RenderAccel" "False"

Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "AllowGLXWithComposite" "True"
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1280x1024 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
__________________
AMD K6-III 450 | 512 MB Mem | Dual 40 MB drives | Geforce FX5200 | Viewsonic VA703B monitor
alienexplorers is offline   Reply With Quote
Old 01-31-09, 08:58 AM   #8
Gigonua
Registered User
 
Join Date: Jan 2009
Location: Florida
Posts: 4
Default Re: "Type 1" error when installing Nvida driver

I have been trying to edit my xorg.conf like the previous post suggested but I am having trouble. When I hit ctrl+alt+F3 to get to the terminal after getting the "type 1" error on start up, I just get a black screen. I have tried sudo gedit /etc/X11/xorg.conf while in my desktop with the nv driver but all that comes up is a short log that does not tell me what I am looking for.
Gigonua is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
WINDOWS 8 RELEASE PREVIEW ACCEPTS INSTALLING WINDOWS 7 DRIVER 301.42 News Archived News Items 0 06-01-12 06:30 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 09:49 AM

All times are GMT -5. The time now is 11:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.