Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-28-09, 04:57 AM   #37
jusst
Registered User
 
Join Date: Mar 2006
Posts: 99
Default Re: Xine vdpau announcement

The CPU has no influence on VDPAU performance. The deinterlacing is done in the GPU Shader Units so it just depends on the GPU.
Still your GPU should be capable of doing temporal... Is the GPU running in some power save mode maybe?
jusst is offline   Reply With Quote
Old 01-28-09, 07:54 AM   #38
ciaccom
Registered User
 
Join Date: Jan 2009
Posts: 13
Default Re: Xine vdpau announcement

Quote:
Originally Posted by jusst View Post
The CPU has no influence on VDPAU performance. The deinterlacing is done in the GPU Shader Units so it just depends on the GPU.
thanks for clarification! some people think, it's AMD-CPU dependend and HyperTransport must be fast enough (like HT3 with K10 CPUs) to address memory.

Quote:
Originally Posted by jusst View Post
Still your GPU should be capable of doing temporal... Is the GPU running in some power save mode maybe?
hmm? i have to check this! now i've made one adaption in my xorg.conf (in device-section --> Option RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"). this should drive the GPU to "maximal performance". i have to reboot/reload X and nvidia-modules in the evenening. At the moment i'm getting:
------------------
nvidia-settings -c :0.0 -q GPUPerfModes -t
perf=0, nvclock=550, memclock=350

nvidia-settings -c :0.0 -q GPUCurrentPerfMode -t
1
nvidia-settings -c :0.0 -q GPUCurrentPerfLevel -t
0
nvidia-settings -c :0.0 -q GPUCurrentClockFreqs -t
550,350
------------------

hmm - i'm not a specialist, but the Geforce 9400GT shoult have 1350 MHz unified shader clock! here i recnognize a value of 350 (but maybe this is something else?)

thanks for driving me in the right direction
ciaccom is offline   Reply With Quote
Old 01-28-09, 08:03 AM   #39
jusst
Registered User
 
Join Date: Mar 2006
Posts: 99
Default Re: Xine vdpau announcement

For onboard graphics chipset the memory performance is very relevant... For dedicated cards the work will be going on the graphics card memory anyway.
jusst is offline   Reply With Quote
Old 01-31-09, 11:37 AM   #40
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

Does xine-vdpau select the correct codec on its own? I know mplayer requires me to set -vc ffh264enc (for example). I can't get miro to use vdpau with --xine-driver=vdpau and I'm wondering if it needs the codec specified somewhere or something.
ggking7 is offline   Reply With Quote
Old 01-31-09, 11:56 AM   #41
mlampard
Registered User
 
Join Date: Apr 2006
Location: South Australia
Posts: 30
Default Re: Xine vdpau announcement

Quote:
Originally Posted by ggking7 View Post
Does xine-vdpau select the correct codec on its own?
Yes, as long as vdpau videoout is selected, xine will prefer the vdpau codecs without further intervention.

To force Xine to output via vdpau, run xine -V vdpau

Cheers.
mlampard is offline   Reply With Quote
Old 02-03-09, 10:54 AM   #42
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

'xine' is using vdpau no problem, but I think miro is not selecting the vdpau codecs, even when using vdpau for videout. Is that possible? I'd like to go to the miro devs with good information.

I'm using miro-2.0-rc2 (which is a massive step up from 1.2.8) like this:

miro --set xine-driver=vdpau

and the terminal output confirms vdpau is set and used, but playback is not accelerated.

http://planet.getmiro.com
ggking7 is offline   Reply With Quote
Old 02-04-09, 02:25 AM   #43
jusst
Registered User
 
Join Date: Mar 2006
Posts: 99
Default Re: Xine vdpau announcement

It might be possible that miro either selects the codecs manually from the code or at least overrides the default xine priority options respectively the ones you set in .xine/config.
You should really ask miro developers about this. They can surely answer your question.
jusst is offline   Reply With Quote
Old 02-04-09, 06:42 AM   #44
G3R
Registered User
 
Join Date: May 2008
Posts: 5
Default Re: Xine vdpau announcement

I can't see the beginning of this video:
http://screencasters.heathenx.org/po...26/0/ep082.avi

8600GT
G3R is offline   Reply With Quote

Old 02-05-09, 05:28 AM   #45
mlampard
Registered User
 
Join Date: Apr 2006
Location: South Australia
Posts: 30
Default Re: Xine vdpau announcement

Quote:
Originally Posted by ggking7 View Post
I'm using miro-2.0-rc2 (which is a massive step up from 1.2.8) like this:
miro --set xine-driver=vdpau
and the terminal output confirms vdpau is set and used, but playback is not accelerated.
It appears that miro 2.0+ has an override that forces the use of XV by default. To switch it off it needs something like --set xine-xvhack=false (untested).
mlampard is offline   Reply With Quote
Old 02-05-09, 09:51 AM   #46
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

Thanks mlampard, I tried that with the same results. miro terminal output confirms I am using vdpau for videout.

What are the names of the xine vdpau codecs? I'll try to hack it in.

No response from the miro devs yet:

http://getsatisfaction.com/participa...turefoundation
ggking7 is offline   Reply With Quote
Old 02-05-09, 10:05 AM   #47
mlampard
Registered User
 
Join Date: Apr 2006
Location: South Australia
Posts: 30
Default Re: Xine vdpau announcement

Quote:
Originally Posted by ggking7 View Post
What are the names of the xine vdpau codecs? I'll try to hack it in.
vdpau_h264
vdpau_mpeg12
vdpau_vc1
mlampard is offline   Reply With Quote
Old 02-05-09, 10:47 AM   #48
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

Should I edit this?

MIMETYPES_EXT_MAP = {
'video/quicktime': ['.mov'],
'video/mpeg': ['.mpeg', '.mpg', '.m2v'],
'video/mp4': ['.mp4', '.m4v'],
'video/mpeg4': ['.mp4', '.m4v'],
'video/flv': ['.flv'],
'video/x-flv': ['.flv'],
'video/x-ms-wmv': ['.wmv'],
'video/x-msvideo': ['.avi'],
'video/x-matroska': ['.mkv'],
'application/ogg': ['.ogg'],
'video/ogg': ['.ogv'],

'audio/mpeg': ['.mp3'],
'audio/mp4': ['.m4a'],
'audio/x-ms-wma': ['.wma'],
'audio/x-matroska': ['.mka'],

'application/x-bittorrent': ['.torrent']
}
ggking7 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM

All times are GMT -5. The time now is 04:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.