Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-24-08, 12:10 PM   #1
dsugar100
Registered User
 
Join Date: Dec 2008
Posts: 3
Send a message via AIM to dsugar100 Send a message via MSN to dsugar100
Default Multiple nVidia cards - crash X on start

I have two nVidia cards - a Quadro FX 570 and GeForce4 MX 4000.
I just upgraded from Fedora 8 to Fedora 10. On Fedora 8 i was using the nvidia kmod-nvidia-2.6.26.6-49 (173.14) driver (installed through rpmfusion) for the Quadro FX 570 and the 'nv' driver for the GeForce4. That was working ok.

After upgrading to Fedora 10, the same configuration crashing during startup of X. Of course the different video cards want different drivers. The GeForce4 needs the legacy 96.43.07 version and Quadro FX needs the latest 177.82 version.

If I try to install both versions from rpmfusion it complains they conflict. I was hoping not to have to install both from source, but will if I have to. Will they conflict? Will the both be 'nvidia' drivers or are they different names?

I have tried other drivers with no luck for the GeForce4 video card. The nv and nouveau drivers crash during start of X. The vesa driver doesn't seem to be able to drive the card. X seems to think the video card is there, but the screen never goes out of low power mode.

Any suggestions? Do I need to get a new video card? I'm currently driving 3 monitors - 2 off the Quardo and 1 off the GeForce4.

I have attached my xorg.conf.

Thanks
Attached Files
File Type: txt xorg.txt (2.4 KB, 111 views)
dsugar100 is offline   Reply With Quote
Old 12-25-08, 03:36 AM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 704
Default Re: Multiple nVidia cards - crash X on start

It's not possible to run two NVIDIA driver versions simultaneously.

Please, attach a copy of an nvidia-bug-report.log file, which can be generated with the `nvidia-bug-report.sh`.

You can also attach Xorg.0.log after X.org server has crashed for you.

Last edited by artem; 12-25-08 at 03:56 AM. Reason: nvidia-bug-report
artem is offline   Reply With Quote
Old 12-29-08, 07:26 AM   #3
dsugar100
Registered User
 
Join Date: Dec 2008
Posts: 3
Send a message via AIM to dsugar100 Send a message via MSN to dsugar100
Default Re: Multiple nVidia cards - crash X on start

I have attached the Xorg.0.log and the nvidia-bug-report.log.

With a quick look at the files it seems the nvidia driver is trying to load for the GeForce4 video card. I'm not sure how to force it not to.

Suggestions?
Thanks
Attached Files
File Type: log Xorg.0.log (29.0 KB, 75 views)
File Type: log nvidia-bug-report.log (131.9 KB, 90 views)
dsugar100 is offline   Reply With Quote
Old 12-29-08, 10:11 AM   #4
rapsure
Registered User
 
Join Date: Oct 2008
Posts: 47
Default Re: Multiple nVidia cards - crash X on start

Your current setup might work if you use the 96.xx.xx driver. Then you'll need two nVidia card entries in the xorg.conf file.
rapsure is offline   Reply With Quote
Old 02-02-09, 09:50 AM   #5
dsugar100
Registered User
 
Join Date: Dec 2008
Posts: 3
Send a message via AIM to dsugar100 Send a message via MSN to dsugar100
Default Re: Multiple nVidia cards - crash X on start

I'm finally getting back to this. I have been pretty busy at work and getting the video card back up hasn't been a priority. Anyway, I installed the nVidia 96.xx.xx driver from rpmfusion and it only drives the GeForce 4000 video card. It doesn't work with the Quadro FX. I have attached my current xorg.conf and log files.

I think it would be best to use the nvidia driver for the Quadro FX and then something like the vesa or other stock fedora driver for the GeForce 4000. But I can't seem to make that work.

Any suggested would be appreciated.
Attached Files
File Type: log Xorg.0.log (13.2 KB, 82 views)
File Type: txt xorg.conf.txt (2.6 KB, 118 views)
dsugar100 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
UEFI + nvidia blob = nvidia blob crash puchuu NVIDIA Linux 11 05-12-12 02:14 PM
Rumor regarding lack of 680 availability ViN86 Rumor Mill 6 05-09-12 04:48 PM
Multiple OpenGL applications and NVidia gbrauer NVIDIA Linux 7 09-01-02 04:47 PM

All times are GMT -5. The time now is 10:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.