Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-25-09, 04:27 PM   #25
sPOiDar
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Problems with 9300M GS on Sony Vaio Z11

Not sure how the windows driver relates to the linux problem being discussed here?
sPOiDar is offline   Reply With Quote
Old 01-25-09, 05:16 PM   #26
frankbartoli
Registered User
 
Join Date: Nov 2008
Posts: 5
Default Re: Problems with 9300M GS on Sony Vaio Z11

yes your are right but after i've found this:
http://forum.notebookreview.com/show...=342947&page=3
Sorg have compiled the new nvidia driver 185.20 (WITH PHYSX INCLUSED) and intel driver for vaio z11 and he explain about "added manual video card switch through dialog by another way - patching nvsvc.dll. It will preserve correct card information in system tray."
Perhaps we are approaching to the solution? Could it be usefull for linux?
bye
frankbartoli is offline   Reply With Quote
Old 01-25-09, 05:23 PM   #27
frankbartoli
Registered User
 
Join Date: Nov 2008
Posts: 5
Default Re: Problems with 9300M GS on Sony Vaio Z11

In fact im using this new driver in vista and i can switch between the two cards also with an icon in taskbar. Great!
frankbartoli is offline   Reply With Quote
Old 01-31-09, 05:23 AM   #28
gbin
Registered User
 
Join Date: Jan 2009
Posts: 8
Question Re: Problems with 9300M GS on Sony Vaio Z11

It looks like it is an nvidia technology on top on centrino 2. It is clearly advertised here :
http://www.nvidia.com/object/io_1221136906708.html

Nvidia, can we have any insight of what you are doing on the software side to do the switch?

Anything that could help us activate one or the other graphic card from within linux ?

Thanks for your feedback.
gbin is offline   Reply With Quote
Old 01-31-09, 05:29 AM   #29
sPOiDar
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Problems with 9300M GS on Sony Vaio Z11

Can't hurt to ask I guess, but I wouldn't hold your breath.
sPOiDar is offline   Reply With Quote
Old 02-01-09, 04:38 PM   #30
gbin
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Problems with 9300M GS on Sony Vaio Z11

Quote:
Originally Posted by sPOiDar View Post
Can't hurt to ask I guess, but I wouldn't hold your breath.
If Nvidia considers this anything like an intellectual property and won't release any clue about it :
Perhaps, somebody can install a kernel debugger under Vista, trigger the switch with a breakpoint in the handler to see what are the actions on the hardware to activate one mode or the other before reinitializing the GUI ?

GB.
gbin is offline   Reply With Quote
Old 02-01-09, 04:53 PM   #31
sPOiDar
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Problems with 9300M GS on Sony Vaio Z11

Quote:
Originally Posted by gbin View Post
Perhaps, somebody can install a kernel debugger under Vista, trigger the switch with a breakpoint in the handler to see what are the actions on the hardware to activate one mode or the other before reinitializing the GUI ?

GB.
I tried, but my vista crashes pretty hard with the debug kernel. The XP process might actually be the more useful one, since X has absolutely no prospects for hot-switching of graphics drivers in the near future. If we could hit whatever BIOS calls or registers XP does when booting, we'd be able to get the Insyde BIOS to present only the currently switched card at boot time, which would force the nV card to initialise it's VBIOS, and solve the problem.

Or if they supported the BIOSBase parameter, we'd have it working now, since I could strap a dumped BIOS into X.
sPOiDar is offline   Reply With Quote
Old 02-03-09, 09:32 AM   #32
gbin
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Problems with 9300M GS on Sony Vaio Z11

Another idea : it looks like the other laptops Fujitsu Siemens Amilo XI 3650 and BenQ Joybook S42 have an option in their bios to force the GPU switch at boot time.

If we can get a bios dump from one of them, it should be possible to disassemble them ?
gbin is offline   Reply With Quote

Old 02-03-09, 09:52 AM   #33
sPOiDar
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Problems with 9300M GS on Sony Vaio Z11

Not likely, do they run the same board?
sPOiDar is offline   Reply With Quote
Old 02-04-09, 07:23 AM   #34
gbin
Registered User
 
Join Date: Jan 2009
Posts: 8
Default Re: Problems with 9300M GS on Sony Vaio Z11

Quote:
Originally Posted by sPOiDar View Post
Not likely, do they run the same board?
They are advertised using the same technology, perhaps it could give us a clue about where the thing is done at least...

I really wonder why sony didn't put themselves this switch in their Bios...
gbin is offline   Reply With Quote
Old 02-08-09, 11:55 AM   #35
jtechs
Registered User
 
Join Date: Feb 2009
Posts: 6
Default Re: Problems with 9300M GS on Sony Vaio Z11

double..
jtechs is offline   Reply With Quote
Old 02-08-09, 12:00 PM   #36
jtechs
Registered User
 
Join Date: Feb 2009
Posts: 6
Default Re: Problems with 9300M GS on Sony Vaio Z11

I have a Z21 and was facing the same issue as all of you..

BUT

Reading somewhere about booting into vista/xp to initalise the video card I tried the same.. I will cut the rest short..

I eventually tried to install windows xp sp3 from CD and got a blue screen (7B error (no boot device.. sata?)) I didnt even get to the PRESS F8 To Agree.. I pressed the power button on the side (single click) and when the computer rebooted the SPEED mode was on (green light)

I then booted into Linux, Enabled the drivers and it worked?

So this tells me that windows is not reliant on drivers from sony/nvidia to init the card.. Must be a windows thing.. like ACPI? or .. I don't know... Might be that rebooting via the power (was like a reset switch) some how inits the card..

Hope we can get this sorted..

Jtech
jtechs is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I play PS3 on my Sony Vaio while using HDMI cable? AbbieJohnson Archived News Items 0 06-18-12 05:04 AM
Gaikai ' Sony Deal Never Existed, Says Founder Dave Perry News GAIKAI 0 06-07-12 06:50 AM
Sony Goes Whole Hog With a New Ultrabook, Updates Vaio Notebook Line News Archived News Items 0 06-04-12 07:40 PM
Why Buying A Cloud Gaming Company Could Be The Smartest Move Sony Has Made This Gener News Archived News Items 0 06-01-12 07:50 AM

All times are GMT -5. The time now is 07:20 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.