Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-15-09, 06:27 AM   #1
wayhigh
Registered User
 
Join Date: Jan 2009
Posts: 3
Default 180.29 fixed Flash on Integrated 8300!

Just an FYI for those of you that had the bad full screen flash problem with their integrated 8300 chipset. The latest stable driver fixed the problem on my systems.

Anyone else find it works for them since upgrading to it?
wayhigh is offline   Reply With Quote
Old 02-15-09, 06:56 AM   #2
lukeross
Registered User
 
Join Date: Sep 2006
Location: London, UK
Posts: 6
Default Re: 180.29 fixed Flash on Integrated 8300!

180.29 is much nippier on 2D, most noticeably on Flash - there's another thread where people with 8200/8300s seem generally happy with 180.29. After several suck-tastic releases it's nice to be able to scroll without it jumping and tearing.

However all is not completely well on the 3D front, as certain operations seem to lock the GPU and cause pixmap corruption until you restart X. It's not very frequent but annoying when it happens as you have to wait (often with a frozen mouse pointer) until the driver realises and reinitialises the GPU.
lukeross is offline   Reply With Quote
Old 02-15-09, 02:51 PM   #3
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: 180.29 fixed Flash on Integrated 8300!

hm... I have 9500GT and I can't watch flash full screen with any nVidia drivers... with or without Compiz, thought without Compiz fullscreen playback is a little faster - it choke once a 1-5s while with Compiz it's choked all the time.
Meddling with hardware acceleration at FlashPlayer settings gives nothing - so it is disabled by Adobe at least at x86_64 alpha version.
dk75 is offline   Reply With Quote
Old 02-15-09, 03:52 PM   #4
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by dk75 View Post
hm... I have 9500GT and I can't watch flash full screen with any nVidia drivers... with or without Compiz, thought without Compiz fullscreen playback is a little faster - it choke once a 1-5s while with Compiz it's choked all the time.
Meddling with hardware acceleration at FlashPlayer settings gives nothing - so it is disabled by Adobe at least at x86_64 alpha version.
The 64bit flash plugin does not support opengl so it uses software rendering which is slower.
The 32bit flash plugin disables opengl support when it detects compiz, this is not needed on driver that support redirected direct rendering (like the nvidia driver). Open libflashplayer.so with a hexeditor and replace "compiz" with "compix" (or any other 5 charater string) than it should use opengl even if compiz is running.
Dragoran is offline   Reply With Quote
Old 02-15-09, 05:23 PM   #5
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: 180.29 fixed Flash on Integrated 8300!

Oh... I've didn't know about this HEX editor Compiz "patch" though it don't work for me right now since I have 64bit system/flash ;P

The only hope is that Adobe add OpenGL support to 64bit plugin with Compiz detection so I could aplly the "patch" ;P but right now Adobe Flash Player plugin 64bit is a little old as for alpha version ( 16 December 2008 ) and I hope that new version will be released soon althought I don't belive that this next alpha will have OpenGL support any time now.
dk75 is offline   Reply With Quote
Old 03-03-09, 09:25 PM   #6
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by Dragoran View Post
The 64bit flash plugin does not support opengl so it uses software rendering which is slower.
The 32bit flash plugin disables opengl support when it detects compiz, this is not needed on driver that support redirected direct rendering (like the nvidia driver). Open libflashplayer.so with a hexeditor and replace "compiz" with "compix" (or any other 5 charater string) than it should use opengl even if compiz is running.
I was pretty certain I already had compiz disabled, but I did the hexedit anyway. Alas, no improvement on Hulu HD (using Legend of the Seeker as test material). CPU peaked at 170%. CPU freq was at max scale (2.7GHz).

32-bit Ubuntu 8.10 and 32-bit flash (10.0.15)
zim2dive is offline   Reply With Quote
Old 03-03-09, 10:23 PM   #7
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by zim2dive View Post
I was pretty certain I already had compiz disabled, but I did the hexedit anyway. Alas, no improvement on Hulu HD (using Legend of the Seeker as test material). CPU peaked at 170%. CPU freq was at max scale (2.7GHz).

32-bit Ubuntu 8.10 and 32-bit flash (10.0.15)
I watched the same video. 80-90% total cpu (~30% per core) on a 2.4ghz core 2 duo and 9650m gt. Fedora 10 64-bit, Flash 10.0.22.87 64-bit. Compiz enabled. In 720p mode (filled my screen).
mooninite is offline   Reply With Quote
Old 03-04-09, 06:50 AM   #8
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by mooninite View Post
I watched the same video. 80-90% total cpu (~30% per core) on a 2.4ghz core 2 duo and 9650m gt. Fedora 10 64-bit, Flash 10.0.22.87 64-bit. Compiz enabled. In 720p mode (filled my screen).
Heh.. sounds like the Intel chip did a better job (2.7GHz Athlon for me) (tho I was at 1080p)
zim2dive is offline   Reply With Quote

Old 03-04-09, 07:38 AM   #9
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by dk75 View Post
hm... I have 9500GT and I can't watch flash full screen with any nVidia drivers... with or without Compiz, thought without Compiz fullscreen playback is a little faster - it choke once a 1-5s while with Compiz it's choked all the time.
Meddling with hardware acceleration at FlashPlayer settings gives nothing - so it is disabled by Adobe at least at x86_64 alpha version.
As a hacky work-around, try creating a file named:
/etc/adobe/mms.cfg

And put:
OverrideGPUValidation=true

as the only line in the file.

Restart browser and test fullscreen flash, see if there is any improvmenent. I use this hack on an ATI/fglrx-based machine, and then Flash uses OpenGL for fullscreen playback just fine, even though the card/driver is "not supported".

I also have a nvidia-card on a 64bit machine (8600GT), and fullscreen 64-bit-flash-plugin is plenty fast so I'm pretty certain it uses OpenGL.
oyvind is offline   Reply With Quote
Old 03-04-09, 12:24 PM   #10
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: 180.29 fixed Flash on Integrated 8300!

OK. That works.

I've used "/etc/adobe/mms.cfg" for "Windowless" early 8.10 64bit beta ugly hack with 32bit FlashPlayer but I didn't know any other usefull settings.
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2

Last edited by dk75; 03-05-09 at 12:27 PM.
dk75 is offline   Reply With Quote
Old 03-04-09, 09:57 PM   #11
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: 180.29 fixed Flash on Integrated 8300!

Quote:
Originally Posted by oyvind View Post
As a hacky work-around, try creating a file named:
/etc/adobe/mms.cfg

And put:
OverrideGPUValidation=true

as the only line in the file.

Restart browser and test fullscreen flash, see if there is any improvmenent. I use this hack on an ATI/fglrx-based machine, and then Flash uses OpenGL for fullscreen playback just fine, even though the card/driver is "not supported".

I also have a nvidia-card on a 64bit machine (8600GT), and fullscreen 64-bit-flash-plugin is plenty fast so I'm pretty certain it uses OpenGL.
Is that only for 64-bit?

I tried on 32-bit for Hulu HD... still at 130% for full-screen
zim2dive is offline   Reply With Quote
Old 03-07-09, 03:09 AM   #12
marchetto
Registered User
 
Join Date: Mar 2005
Posts: 205
Default Re: 180.29 fixed Flash on Integrated 8300!

This doesn't solve on mine... I don't know if the path is wrong for me, I've got a SuSE 11.1 anyway I created /etc/adobe and the file, but I have the same behavior, if I play a low quality youtube movie in full screen *and* I don't move the mouse it's quite ok, if I move the mouse I got scattered behavior.
In HQ movies even with no mouse movement I've a scattered behavior.

So seems like that change doesn't work for me, because is exactly the same
marchetto is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thoughts from console owners on NVIDIA's GEFORCE GRID MikeC Console World 11 05-27-12 08:43 AM

All times are GMT -5. The time now is 10:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.